locked
Calling Speech Server from Communicator via OCS. RRS feed

  • Question

  • Hi,

    I have read Micheal Dunn article about the setup but I can't seems to figure it out. Currently my setup is Speech Server + IIS on Vista and OCS + DC on Windows Server 2008 R2.

    I have ensure the HelloWorld application on the Speech Server is deployed correctly by using a softphone, X-Lite to call directly to the Speech Server using "sip:888@192.168.0.53:5068;transport=tcp'. I hear dial tone, then it picks up and the "Hello World" message is being heard from the softphone.

    However, I tried setting up according to Michael's article, http://blogs.msdn.com/midunn/archive/2008/06/17/integrating-speech-server-with-office-communications-server.aspx, but I can't seems to connect to the server properly. So what happen is this..

    When I call a valid calling party, 123@abc.fabrikam.com, from my Communicator, I receive an error message saying "Cannot locate 123@abc.fabrikam.com". So I thought it could be the DNS problem. However, when I tried to call an INVALID calling party, 888@abc.fabrikam.com, I receive an error, "Call was not completed or has ended" and from the Event Viewer, it says "Speech Server was unable to find an enabled application matching the called party.".

    This clearly shows that the call can be routed to the speech server but there is an invalid called party. Since the valid calling party does not porvide any error at the Event Viewer, I have no clues of where to begin with.

    Any help would be great. Thanks.

    Cheers,
    Mickey
    • Edited by mickeyckm Tuesday, May 19, 2009 3:17 AM
    Tuesday, May 19, 2009 3:13 AM

All replies