locked
Webguide and PP1 RRS feed

  • Question

  • Hi team,

     

    I use the Webguide addin on my WHS to stream music remotely.  When I installed PP1, it broke Webguide.  The webguide pages didn't show properly online and when you selected an album or track to open in media player on the remote side, the download box never closed, so media player never opened.

     

    I went to the webguide page in the connector and hit configure.  I didn't change anything, just let it reconfigure and everything worked again.  Not a big deal and I realize its an addin (although the author works for MS now), but I thought I would mention it as something I found with PP1.

     

    Thursday, June 12, 2008 7:52 PM

All replies

  • Thanks for the feedback Greg.  Can you give me some more info about what you saw after installing PP1?  Did the page load but not show correct menu options (pictures/videos/music)?  Were you getting any error pages? 

    Also, it's a longshot, but there may be info in the logfiles that could help.  The logs are stored in the "c:\program files\webguide\webguide4\app_data" folder. 

    Can you file a bug on the Connect site for this?  I'll then try take a deeper look at it.  I've upgraded my WHS machine several times to the latest PP1 builds and haven't seen an issue, so I'd like to compare with what you saw.

    Thanks much.

    Doug

     

    Friday, June 13, 2008 4:46 PM
  • Doug nice to see you are here. 

    Webguide seems to work on my upgrade to PP1 but I have another problem.  When my clients try to access Webguide via https://xxxx.homeserver.com/webguide which used to work until April when I started getting this.  Any idea what broke it?

     

    Server Error in '/Remote' Application.


    Access is denied.

    Description: An error occurred while accessing the resources required to serve this request. The server may not be configured for access to the requested URL.

    Error message 401.2.: Unauthorized: Logon failed due to server configuration.  Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server.  Contact the Web server's administrator for additional assistance.
    Friday, June 13, 2008 5:33 PM
  • That looks like some permissions issue with WHS.  If you just try loading that page directly (without trying to load WebGuide first), do you get the same error? 

    Try this:

    http://support.microsoft.com/kb/253667

     

     

     Richard Plenty wrote:
    Doug nice to see you are here. 

    Webguide seems to work on my upgrade to PP1 but I have another problem.  When my clients try to access Webguide via https://xxxx.homeserver.com/webguide which used to work until April when I started getting this.  Any idea what broke it?

     

    Server Error in '/Remote' Application.


    Access is denied.

    Description: An error occurred while accessing the resources required to serve this request. The server may not be configured for access to the requested URL.

    Error message 401.2.: Unauthorized: Logon failed due to server configuration.  Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server.  Contact the Web server's administrator for additional assistance.
    Friday, June 13, 2008 11:35 PM
  • Doug, Tried this solution but same result.  I have anonymous access checked.   Not sure where to go next.     btw I did a server restore after this first happened and also no change.

    Sunday, June 15, 2008 3:04 PM
  • Doug

     

    I am also seeing issues since installing PP1. The message I get is:

     

    WebGuide could not access the music tracks. The configured web user may not have access to this location (usually network locations).
    - Location: "d:\shares\Music\Full Music\Compilations\Hard Candy\01 Candy Shop.mp3"
    - User Account: "WHS-SERVER\Administrator"


    To resolve this, edit the 'Web.config' file in your WebGuide directory. Modify the section titled 'identity', setting 'impersonate' to 'true' and setting the username and password values to a user with access to the location.

    For example:
    <identity impersonate="true" userName="MediaCenterUser" password="Password1234"/>

     
    I am accessing Webguide from within my network, and have not had problems before. I only have one account, aside from Adminstrator, set-up and I have always used this in the past.
     
    Any suggestions?
     
    Regards
    Simon
    Sunday, June 15, 2008 9:27 PM
  • Okay Doug so now it gets a little more weird.

     

    I have RDC'ed on to the server and logged-on as the Administrator. I have then done nothing else on the WHS box.

     

    Using the already open web browser application on my desk-top PC I have selected another album and it streams. Does this give you anymore clues or is there anything else I can check for you?

     

    Off to bed now as it is 22.40 in the UK, so I will post anything else I find tomorrow.

     

    Regards

    Simon

    Sunday, June 15, 2008 9:39 PM
  •  

    Hi Doug,

     

    Unfortunately I've formatted and reinstalled WHS in order to get my ACHI drivers working since last week, so my logs are gone.

     

    I have noticed that there seems to be two different problems.  The page loaded but did not show the correct menu options (pictures/videos/music) or the blue box with the welcome box.  The boxes were there, but nothing in them.  I've had this happen again since the reinstall, a couple of times actually.  Hitting the refresh button fixes the problem.  I didn't get any error pages.

     

    The other problem that I had upon first install is when you actually hit the "play album" button.  The download screen would pop up on the remote side, but when you hit open, WMP never opened.  This was fixed by reconfiguring Webguide.  Unfortunately my logs for this one are gone and I've never seen the problem again.

     

    I file a bug on connect tonight about the first problem.

     

    Thanks again for building this software, its definately the best part of my WHS.

    Wednesday, June 18, 2008 4:12 PM