locked
"This folder cannot be opened until Microsoft Dynamics for CRM is enabled" RRS feed

  • Question

  • After installing the Microsoft Dynamics CRM client for Outlook, I am not able to open any of the Microsoft Dyanmics CRM toolbar on Outlook . Whenever I try clicking on it I get an error which says "This folder cannot be opened until Microsoft Dynamics for CRM is enabled ".Can anyone please  help me with this issue?

    On running the CRM Diagnostics I get an error which states "You recently used a different outlook profile than the one Microsoft Dynamics CRM add-in has been configured for. The Microsoft Dynamics CRM add-in will be enabled only for the people it was configured for"

    I have the  IMAP outlook account for which the Microsoft Dynamics CRM set as default, and  have another e-mail address marketing@..  being forwarded to me.Please help me

    • Moved by Donna EdwardsMVP Tuesday, May 25, 2010 5:37 PM (From:CRM)
    • Moved by Xiaopeng Wu Tuesday, March 8, 2011 10:31 PM Forum consolidation (From:CRM Online)
    Tuesday, May 11, 2010 7:17 PM

Answers

All replies

  • Configure the Outlook Client again, and ensure you are configuring it for the user that is logged into the machine which should also be the Primary Outlook user (user login used to open Outlook)


    Regards, Donna

            Windows Live Blog

    Thursday, May 20, 2010 6:20 PM
  • Thanks Donna,

    I configured the outlook client several times and it is configured to the primary outlook user (the same live id which has authorization to use CRM) yet I am not able to resolve it. Is there any other fix for this?? Please help

    Thanks

    Pavan

     

    Tuesday, May 25, 2010 5:19 PM
  • It looks like this is CRM Online rather than On Premise since you reference a live id.  I'll move the post to the Online Community. 

    Regards, Donna

            Windows Live Blog

    Tuesday, May 25, 2010 5:37 PM
  • Donna,

    Yes it is CRM online, thanks for your help.

    Regards

    Pavan

    Tuesday, May 25, 2010 6:11 PM
  • Donna,

    I checked it out, it seems like I have posted the thread in the right "Online" section.Please help me resolve it or provide me the right contact whom I can contact to resolve this issue.

    Thanks,

    Pavan

    Wednesday, May 26, 2010 3:53 PM
  • You're right, I moved your post to this Online forum.

    Are you sure you installed the correct CRM Outlook Client?  Here is the link for the Online CRM Outlook Client download.

    I am not sure that having a forwarded e-mail address to your 'primary' e-mail address should be an issue, but maybe there is something else in your environment that is preventing a successful install.  Are you using a supported Operating System and Office product?  You could try an uninstall, download the Client again from the link I provided and try a fresh install.


    Regards, Donna

            Windows Live Blog

    Wednesday, May 26, 2010 5:36 PM
  • Donna,

    Thanks for your reply.

    I also tried downloading from the link which you provided ,yet it is not working.I have Windows XP with SP3 as OS and Microsoft Office 2003 with SP3 office product. I am clueless on why it is not working ? Please help.

    Thanks

    Pavan


    Wednesday, May 26, 2010 7:38 PM
  • Based on the error message you provided, my best guess, in the abscense of looking at your environment, is that the something is going wrong in the Configuration process.  I'm not clear on how Outlook is setup but under 'normal' conditions, I would expect this to work.  Unfortunately, I am out of suggestions at this point.

    If you leave the post as unanswered then maybe someone will jump in who has a solution.

    Thank you


    Regards, Donna

            Windows Live Blog

    Wednesday, May 26, 2010 8:12 PM
  • I have the same problem and I cannot believe that MS cannot come up with a solution.  My setup is this:

    Hosted Exchange 2007 Server and Hosted Dynamics CRM 4.0 with SherWeb

    PC: Windows XP Pro SP3, Outlook 2010 Beta

    I am using McAfee Total Protection and even tried disabling it completely, but no connection.

    I am not using Windows Firewall.

    SherWeb told me to install CRMV4.0-i386-Client-ENU.exe and MS’s website states to install this file, CRMOnlineClient_ENU_i386.exe, neither file fixes the connectivity issue.

    I am signing in with the same email address and password for both Outlook and CRM.

    Both times I chose the Service Provider, not My Company.

    I also add another users mailbox when I open Outlook, it is set in the Advanced tab of the MS Exchange profile, but I removed it from the profile in order to see if that would have any change

    I have checked the CRM site URL several times and even tried it with both http and https

    When I try to sign in using the CRM icon in the system tray, it connects for 2 seconds then responds with error "There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. Try again later..."

    I tried the CRM Diagnostics and twice it said that CRM was not enabled. I chose Fix and it stated that it was fixed, but received the same errors and no connection.

    MS Dynamics CRM shows as enabled in the Add-ins, but when I click on any of the CRM icons in the Add-ins section, nothing happens (obviously, because it is not connected)

    I CAN connect to my CRM account using IE8 and I installed this exact same config on another users laptop in my office running Windows 7 and Outlook 2010 beta, and it connects fine. 

    I have complete admin rights and roles under the CRM. 

    I am installing it under my profile, which I have deleted completely and re-installed twice, along with CRM, and I even deleted the Outlook folders under the hidden directories Local Settings and Application Data, prior to re-installing. 

    I have NOT re-installed Outlook 2010 beta.

    Using CRM Online through IE8, I verified that I have Full access and no restrictions on my profile.

    I tried adding a line in my Hosts file with the ip address and the url of the crm server

    I tried adding both the ip address and the FQDN to my Local intranets/Sites/Advanced section of IE8

    I tried reducing my CRM roles to that of salesperson, the same as the other user that was able to connect.

    I tried Working Offline in Outlook to see if there was a conflict between the connection to the Exchange server and the CRM servers, but that resulted in the same error.

    I can expand the CRM folders in Outlook, but when I click on a subfolder, I receive the message, "This folder cannot be opened..." again it is obvious that the folders won't open because I am not connected to the CRM server.

    The only other add-in that I recently installed is RingCentral, which works fine in Outlook and is resident in the system tray, but I completely uninstalled it prior to re-installing the CRM client.

    NONE of these changes have resulted in a connection for more than 2 seconds, with the exception of when it connected for 30 seconds one time, then reverted back to same error message.

    Please help 

    Sunday, June 6, 2010 1:39 PM
  • Hi Michael.  If you're seeing options for "service provider" and "my company", you probably have the on-premises build of the Outlook client.  You'll need the Online version of the client, linked below.  I'm sorry, I realize this is confusing, and we're working on making it just one download for the next version of CRM.

    http://www.microsoft.com/downloads/details.aspx?familyid=E8E6C81A-B7B2-4E57-8599-604967617396&displaylang=en

    Hope that helps,

    Matt

    Friday, June 11, 2010 4:20 PM
    Moderator