locked
Toshiba Satellite Pro Vista Business Invalid License Error 0xc004f012 RRS feed

  • Question

  • This error came up when I booted the machine.  No changes were made to the operating system and no programs were installed.  The diagnostic log from the MGADiag tool is:

    Diagnostic Report (1.7.0039.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Invalid License
    Detailed Status: 0xc004f012
    Cached / Grace status: (N/A, hr = 0xc004f012) / 0x0
    Windows Product Key: *****-*****-GJQQX-9DYQ4-H9MQD
    Windows Product Key Hash: qRzQG5hpfzV4OyKihHkSQJhFV50=
    Windows Product ID: 89576-OEM-7332141-00232
    Windows Product ID Type: 2
    CSVLK Server: N/A
    CSVLK PID: N/A
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6000.2.00010100.0.0.000
    ID: {05F0E720-F524-4BCD-B55D-DF9A64712307}(3)
    Is Admin: Yes
    Commit / Reboot / BRT: (N/A, hr = 0xc004f012) / 0x0 / (N/A, hr = 0xc004f012)
    WGA Version: Failed to retrieve file version. - 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Business
    Architecture: 0x00000000
    Build lab: 6000.vista_rtm.061101-2205
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: N/A
    File Exists: No
    Version: N/A
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    OGA Version: Failed to retrieve file version. - 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-2993-80070002_025D1FF3-282-80041010_025D1FF3-170-80041010_025D1FF3-171-1_025D1FF3-434-80040154_025D1FF3-178-80040154_025D1FF3-179-2_025D1FF3-185-80070002_025D1FF3-199-3_E2AD56EA-324-8009_E2AD56EA-325-2ee7_16E0B333-80-80004005_B4D0AA8B-911-8000400

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{05F0E720-F524-4BCD-B55D-DF9A64712307}</UGUID><Version>1.7.0039.0</Version><OS>6.0.6000.2.00010100.0.0.000</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-H9MQD</PKey><PID>89576-OEM-7332141-00232</PID><PIDType>2</PIDType><SID>S-1-5-21-426407208-1985190101-2790764312</SID><SYSTEM><Manufacturer>TOSHIBA</Manufacturer><Model>Satellite Pro P100</Model></SYSTEM><BIOS><Manufacturer>TOSHIBA</Manufacturer><Version>V3.50   </Version><SMBIOSVersion major="2" minor="4"/><Date>20070125000000.000000+000</Date></BIOS><HWID>88313507018400EA</HWID><UserLCID>1809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>TOSQCI</OEMID><OEMTableID>TOSQCI00</OEMTableID></OEM></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{91120000-0031-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>2007 Microsoft Office system</Name><Ver>12</Ver><Val>60AF617A8222F0A</Val><Hash>YquDsXf9idb8H1VBy+GYCu+NOyg=</Hash><Pid>89451-901-2545156-66513</Pid><PidType>1</PidType></Product></Products></Office></Software></GenuineResults> 


    I contacted Toshiba Support in UK and they stated I install this patch http://support.microsoft.com/kb/931573 I tried the patch but it comes up with an error that states the patch is not for my system.  After I log in the dialog box has a caption of Windows Activation, the next line says The Windows Vista Business product key you typed is invalid for activation.  I then only have three options - Access your computer with reduced functionality, Type a different product key and Contact TOSHIBA to help resolve this problem.  The last selection is useless.  When I choose the second one and type in the key from the bottom of the laptop I get an error code of 0xc004f033 - The software licensing service reported that the product key is not allowed to be installed.  Please see the eventlog for details.

    I've also tried to run "slui.exe 4" from an elevated and regular command prompt but nothing happens.

    Hopefully I've provided enough information for a solution.

    Cheers,

    eddie
    Tuesday, July 31, 2007 11:11 AM

Answers

  •  

    Eddie:

     

    It is probable (but hard to confirm without actually looking directly at the machine) that the memory issue may have caused this.

     

    As memory is part of the "hardware snapshot" we use for Activation, it may have started corrupting and repeatedly reported changes in memory installed (changing the hardware snapshot). However, I would recommend to do telephone activation in Windows once your memory and other hwardware issues are fixed.

     

    To do this, click the start/windows button and type in "slui.exe 4" and follow the steps to do activation over the phone.

     

    -phil

    Thursday, August 16, 2007 6:53 PM

All replies

  • I would suggest checking this KB article here:

     

    http://support.microsoft.com/kb/931276 (Search for error-code 0xc004f033)

     

    Also - what edition of Vista is your product key for (the one on the bottom of the PC)?

     

    -phil

    Wednesday, August 1, 2007 1:52 AM
  • The product key on the bottom of the laptop is for Vista Business.

    I checked the KB article which lead me to this article http://support.microsoft.com/kb/932616/ which is more of a guide and doesn't really have anything for me to try.

    I updated the bios on the laptop, but I'm still getting the same error.
    Wednesday, August 1, 2007 3:19 PM
  •  

    Hi Eddie,

    Were you able to reenter the product key from the label into the system.

    Please go to your System Properties panel (which you can access by right-clicking on Computer in the start menu and choosing Properties) and click on the blue "Change product key" link at the bottom of that window.  Then try entering your product key there. 

    When this is completed try to activate again.

    Let me know if that works.  Thank you!

    Wednesday, August 1, 2007 5:27 PM
  • I tried to re-enter the product key, but I noticed I was getting strange memory errors and errors that were saying there was not enough memory to perform the operation.  I then ran Memtest from www.memtest.org and it found many many errors with the memory in the laptop.  At that point I sent it off to the local repair depot for warranty repair and I'm hoping to get it back tomorrow or the next day.  I'm wondering if the memory problem some how made vista revert back to a not activated state ?? could it have corrupted some tokens that it stores in memory ???  The problem I now face is when I get the laptop back I'll still probably have the activation issue and with all the clients data on the machine I don't want to do a wipe and reload instead I would love a fix to the situation.  I'll keep ya'll updated when I get the laptop back.

     

    Cheers,

     

    eddie

    Wednesday, August 15, 2007 9:31 AM
  •  

    Eddie:

     

    It is probable (but hard to confirm without actually looking directly at the machine) that the memory issue may have caused this.

     

    As memory is part of the "hardware snapshot" we use for Activation, it may have started corrupting and repeatedly reported changes in memory installed (changing the hardware snapshot). However, I would recommend to do telephone activation in Windows once your memory and other hwardware issues are fixed.

     

    To do this, click the start/windows button and type in "slui.exe 4" and follow the steps to do activation over the phone.

     

    -phil

    Thursday, August 16, 2007 6:53 PM