none
WHS not accepting remote access connections - troubleshooter is happy tho' RRS feed

  • Question

  • I have a Belkin VISION N1 MIMO router thats listed on the Microsoft list. My server installed OK but I just can't solve this issue. I have good internet connection, but can't get my ????.homeserver.com domain to work. I have manually configured my virtual server settings for 4125, 443 and 80 but no joy. The router section reports configured, but not verified for remote access. The troubleshooter tool reports no errors and I have run out of ideas. Can anyone help me please???
    Wednesday, September 10, 2008 7:57 PM

Answers

  • From any computer on your network, you can test to see if your router is really configured correctly, and if your ISP is blocking any ports, by using Shields Up! to run a custom port scan of ports 80, 443, and 4125.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 10, 2008 8:27 PM
    Moderator

All replies

  • From any computer on your network, you can test to see if your router is really configured correctly, and if your ISP is blocking any ports, by using Shields Up! to run a custom port scan of ports 80, 443, and 4125.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 10, 2008 8:27 PM
    Moderator
  • Hi Ken,thank you for your answer. I am now even more confused. SU reports only port 80 is open. However, when I close off all the ports on my router (including 80) and re-run SU, it still shows 80 open. Where else on my Vista sysem should I look to open or close ports? THANX.
    • Proposed as answer by spile1 Thursday, September 11, 2008 8:59 PM
    Wednesday, September 10, 2008 9:30 PM
  • What is it reporting for 443 and 4125?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 10, 2008 9:57 PM
    Moderator
  • Are you trying to access your server site INSIDE the network?
    If this is the case then you need to test it OUTSIDE of the network as most routers don't support loopback.
    Thursday, September 11, 2008 9:01 PM
  • Hi Ken, I am really missing something fundamental here. Shields Up! reports the following:-

    80 is red - open!, 443 reports green - stealth, 4125 is blue - closed.

    All are showing as enabled on my router and I have re-booted the router and re-visited the firewall settings to make sure they are really enabled and stored.

    What amI missing? This is driving me crazy!!
    Saturday, September 13, 2008 12:30 PM
  • Hi,
    You have the ports forwarded in your router to the server's IP address? From my recollection the Vision does this as a Virtual Server in the Firewall section I believe.

    Colin
    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Saturday, September 13, 2008 5:00 PM
    Moderator
  • Just double checked again. Under Firewall>virtual servers the three port settings are assigned to 192.168.0.57. If I type this address into my browser, upcomes my WH server, so I am fairly sure the two do match. To be certain, I logged in to WHS console and confirmed I have the right IP address.
    Saturday, September 13, 2008 8:46 PM
  • thebestgadgetboy said:

    Hi Ken, I am really missing something fundamental here. Shields Up! reports the following:-

    80 is red - open!, 443 reports green - stealth, 4125 is blue - closed.

    All are showing as enabled on my router and I have re-booted the router and re-visited the firewall settings to make sure they are really enabled and stored.

    What amI missing? This is driving me crazy!!


    This indicates that your ISP is blocking port 443 (the standard HTTPS port), but not port 80 or 4125. Without HTTPS the remote access web site won't work, which explains your problem.

    If you do some searching in the forums you should find instructions for changing ports on WHS. Be aware that there may be bits that are wired down to specific ports for various reasons. And be careful; messing around in Remote Desktop without a complete understanding of what you're doing can lead to severe problems.

    I'm not on the WHS team, I just post a lot. :)
    Monday, September 15, 2008 11:38 AM
    Moderator
  • i have the same router and with my new setup i think i'm having a simlar problem...my ports 80 and 443 show open in sheilds up but when i use the website that the Technical Brief for remote access http://<servername>/home or https://<servername>/remote from my home network i can't connect.  router says it configured and available over the internet in WHS console.  i'm gonna try it when i get to the office tomorrow may it just doesn't work on ur home network. 
    • Proposed as answer by spile1 Saturday, September 20, 2008 5:51 PM
    Tuesday, September 16, 2008 4:12 AM
  • ncinsguy said:

    i have the same router and with my new setup i think i'm having a simlar problem...my ports 80 and 443 show open in sheilds up but when i use the website that the Technical Brief for remote access http://<servername>/home or https://<servername>/remote from my home network i can't connect.  router says it configured and available over the internet in WHS console.  i'm gonna try it when i get to the office tomorrow may it just doesn't work on ur home network. 

    Many consumer routers have trouble "looping back" to their external IP from within the local LAN, so you should definitely try from the office. (Or Starbucks, the local library, etc.)


    I'm not on the WHS team, I just post a lot. :)
    Tuesday, September 16, 2008 7:31 PM
    Moderator
  • If you open:
    C:\WINDOWS\system32\drivers\etc\hosts

    You can add a line
    IP_ADDRESS DOMAIN
    Where IP_ADDRESS is the internal IP address of your WHS and DOMAIN is your WHS domain.
    eg:
    192.168.0.200 mydomain.homeserver.com

    You can then access the WHS remotely inside your network. It also stops the certificate errors.
    Saturday, September 20, 2008 5:55 PM
  • I am having the same problem. Unable to verify that the web page is up, and unable to verify that remote access is working. I have a Lynksys wireless g/n router at home, and a lynksys wireless g router at work. I have Century tel at home with a Westell modem with a static IP address. I tried using two different home servers, and i have tried two different networks. Every time I am unable to access the server remotely. I want for this to work. Any help? I have been pulling out my hair all night trying to figure out why this will not work.

     

    Tuesday, September 30, 2008 4:20 PM
  •  

    Hello,
    It seems I cannot fix the WHS domain name for Remote Access.
    On the server side, the firewall ports (of built-in Microsoft firewall) that Mr. Warren mentioned in above posts, have been opened. Moreover, I opened HTTP en HTTPS for my server in Advanced Settings of this firewall.
    On my router (USR 5463) Upnp is enabled, and I have manually opened ports 80, 443 and 4125. Using Shields Up!, as suggested in this forum, ports 80 and 443 receive a 'perfect Trustealth' rating. Strangely, 4125 was found to be closed.
    I have downloaded the latest updates for WHS and installed all security packs et cetera.

    The WHS Remote Access page can be reached 'from the inside', behind the router, but not from the outside world.

    Any help would be more than welcome,
    Jan

    PS >

    In one of the posts here, mr Spile1 mentions:
    "You can add a line
    IP_ADDRESS DOMAIN
    Where IP_ADDRESS is the internal IP address of your WHS and DOMAIN is your WHS domain.
    eg:
    192.168.0.200 mydomain.homeserver.com"

    Is this correct? It would be handy. I assume it must be done on the client machine?

    Thanks in advance.

    Monday, October 20, 2008 2:19 PM
  • Hello Ken,

     

    I followed this thread and the advices, but unfortunately could not solve my problem.

    WHS Setting Remote Access approves everything except the web site and remote access connections. After adding my IP + address to C:\WINDOWS\system32\drivers\etc\hosts I can logon to my WHS-homeserver.com site, however, from the internet this fails.

    I tested with ShieldsUp for a possible blockage of ports 80 and 443 by my ISP; I disabled my TrendMicro Internet Security 2008 and in my router (Linksys WRVS4400N) I disabled "Firewall" and "Block WAN Request". I also forwarded ports TCP 80, 443, 4125 and 3389. UPnP is enabled as well as Firewall and Remote Management on port 8080. ShieldsUp keeps reporting all common and service ports as Stealth.

    I have a Thomson Speedtouch 500 series modem. The Help function mentions a firewall, but I cannot find anything in the settings. Could it be that the modem also firewalls the connection? If anyone knows how to disable the modem firewall (if any) I might be able to check whether my ISP is blocking ports 80 and 443.

    Any help would be appreciated. Thanks, Hans(epans).

    Tuesday, October 28, 2008 2:09 PM
  • Hans,

    As you have a speedtouch, have you forwarded the ports required on there as well? These will need to be forwarded to the WAN address of your router and then, on the router, forwarded to your server.

    It could be worthwhile going to Port Forward, select your speedtouch, and follow through the steps.

    Colin





    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Tuesday, October 28, 2008 6:31 PM
    Moderator
  • Hans, if Shields Up! is reporting your ports as STEALTH, then they are blocked somewhere. The possibilities for the blockage (assuming you've correctly forwarded your ports in your router) start at your server, and go back up the wire to your ISP. Switches (if any) will not interfere, but any router, cable/DSL modem, VOIP device, etc. could be the source. The two most likely possibilities in your case are that your DSL modem is also acting as a router (and thus also requires that port forwarding be configured, in this case from your external connection to your Linksys router), or that your ISP is blocking those ports. 

    If it's your modem, you should place either it or your Linksys router (but not both) in bridge mode, which will eliminate network address translation and firewalls on that device. This is a much more reliable (and less complex) configuration than multiple levels of NAT and firewall. If it's your ISP, you'll have to see what you can work out with them. 



    I'm not on the WHS team, I just post a lot. :)
    Wednesday, October 29, 2008 6:04 PM
    Moderator
  • Colin and Ken,

     

    Thanks for your reactions. I had already forwarded ports 80, 443, 4125 in my Linksys Router to the IP address of my WHS computer. With this I could reach my homeserver.com account from inside my home network, but not from outside my home.

    On basis of Colin's info (and of "Port Forward") I configured my SpeedTouch modem as follows: In NAPT I added these ports to IP 10.0.0.150 of my WAN. I can now successfully log-on to my homeserver.

    However, in WHS Settings / Remote Access I now get OK's on all items in the details summary, but in Router Details I still get warning triangles for Website and Remote Access connections.

    Questions:

    1. Could this be solved by Ken's suggestion to bridge my modem or router (instead of forwarding the SpeedTouch in NAPT to WAN)?

    2. If so can you please explain how to do that?

     

    I'm very happy I got as far as this and hope I can give it the final touch with your further help.

     

    Regards, Hans

    P.S. I newly set-up the Remote Acces Domain Name and the Router fields. The domain Name screen reports Status: working. However, the Router Config. detail screen now stays empty (no checked items) and the status says: Configured, but not verified.

    • Edited by Hansepans Thursday, October 30, 2008 3:52 PM
    Thursday, October 30, 2008 12:47 PM