locked
Disable Multi-monitor on Remote Desktop RRS feed

  • Question

  • At work I have 3 monitors connected and when I RDP any of the computers on my Home Server the RDP window uses all 3. I only want it to use a single monitor.


    In a normal RDP connection settings, this is the "Use all my monitors for the remote session" option.


    Is it possible to disable the multimon setting in the RDP connections that Home Server creates in Remote Web Access?

     


     


     

    Thursday, November 17, 2011 9:58 AM

Answers

  • I'm not sure how much flexibility WHS allows in configuring the actual gateway aspect since it's not operating in a true domain environment.  This certainly would limit how much control it has on the other systems in the network. There are probably ways of modifying registry entries to achieve this if one wanted to do the research.

    Since you're dealing with a limited number of systems, I'll have to side with Ken on his recommendation of modifying the local policies.  Seems like it would get the job done with the least amount of time and effort.

    I found the setting for Win7 as it's all I have in front of me at the moment. I don't think there would be any settings for XP since it was never available and I believe Vista only provided multi monitor spanning. The actual setting below does specifically say it only applies to Windows 7 and Server 2008 R2.

    Run gpedit.msc

    Computer Configuration ->Administrative Templates -> System ->Windows Components ->Remote Desktop Services ->Remote Desktop Session Host ->Remote Desktop Environment ->limit maximum number of monitors


    Nelson Sheffield, MCITP-EA Council of Better Business Bureaus
    • Marked as answer by cyrusc Friday, November 25, 2011 7:11 PM
    Friday, November 25, 2011 4:51 PM

All replies

  • When you log in to the Remote Access web site, click on "Computers" at the top. Then click on "Remote Desktop Options" and choose a screen size other than "Full screen".
    I'm not on the WHS team, I just post a lot. :)
    Thursday, November 17, 2011 11:55 AM
  • Thanks. I found that option and am using it as an interim option, however it's not quite what I want.

    I want it full screen but only on one of my 3 monitors.

    On a standard RDP session (see screenshot from original post) there is a check box.

    With it checked the RDP session will use all 3 monitors, full screen

    With it un-checked the RDP session will use 1 monitor, full screen, you can use Restore / Move / Maximise to move the session to any of the 3 monitors.

    Surely this must be configurable somewhere in WHS!

    Thursday, November 17, 2011 12:32 PM
  • ... Surely this must be configurable somewhere in WHS!

    I'm afraid not. What I pointed you to is what you get; it's part of the Remote Desktop gateway built into Windows Home Server, and if it's not exposed there, it's not available for an end user.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, November 17, 2011 1:10 PM
  • Thanks Ken.

     

     

    Thursday, November 17, 2011 1:53 PM
  • If I understand you correctly, you're simply looking to restrict RDS connections on the server to a single monitor.  This can be done, but the setting is somewhat buried.

    Log into the server as an administrator, actual desktop not the Dashboard. Go to Start -> Run -> tsconfig.msc

    In the middle pane you should see the "Connections" window and there should be one connection listed "RDP-Tcp"

    Right-click on "RDP-Tcp" and click Properties, then click the Client Settings tab.  You have several settings here that affect the connecting client, one of which is limiting the number of monitor connections.  Default allows up to 16 monitors!

     

    This should do what you want, although I'm not 100% clear how WHS handles the connections to other networked computers. Since everything must initially connect to the server, I'm going to assume that the session host changes made here will apply to all remote sessions.

     


    Nelson Sheffield, MCITP-EA Council of Better Business Bureaus
    Thursday, November 24, 2011 3:51 PM
  • Hi Nelson, many thanks for this

    It's certainly worked from my home PC connecting to the server -

    I set it to 2 and checked the "use all my monitors" option for an RDP session to the WHS, it used both

    I set it to 1 and checked the "use all my monitors" option for an RDP session to the WHS, it used only 1, ignoring the check box.

    I will try again tomorrow from work to RDP to my home PC.

    Thursday, November 24, 2011 5:13 PM
  • Unfortunately it didn't work. Accessing from outside the network via the WSH RDP Gateway still connects up all 3 of monitors.
    Friday, November 25, 2011 9:37 AM
  • It's likely that you will need to individually configure clients you want to connect to in order to get this to work as you want. On Windows 7, I believe there are group policy objects that can be set to control the number of monitors a remote desktop connection will be allowed to use; I don't know if there are equivalents for Vista or Windows XP. You may also need more configuration of the RD Gateway on your server. For the RD Gateway, you should probably start with Technet; for the clients, a search engine is your best bet.

    Unfortunately none of this is going to be "supported" by Microsoft for Windows Home Server.


    I'm not on the WHS team, I just post a lot. :)
    Friday, November 25, 2011 2:58 PM
  • I'm not sure how much flexibility WHS allows in configuring the actual gateway aspect since it's not operating in a true domain environment.  This certainly would limit how much control it has on the other systems in the network. There are probably ways of modifying registry entries to achieve this if one wanted to do the research.

    Since you're dealing with a limited number of systems, I'll have to side with Ken on his recommendation of modifying the local policies.  Seems like it would get the job done with the least amount of time and effort.

    I found the setting for Win7 as it's all I have in front of me at the moment. I don't think there would be any settings for XP since it was never available and I believe Vista only provided multi monitor spanning. The actual setting below does specifically say it only applies to Windows 7 and Server 2008 R2.

    Run gpedit.msc

    Computer Configuration ->Administrative Templates -> System ->Windows Components ->Remote Desktop Services ->Remote Desktop Session Host ->Remote Desktop Environment ->limit maximum number of monitors


    Nelson Sheffield, MCITP-EA Council of Better Business Bureaus
    • Marked as answer by cyrusc Friday, November 25, 2011 7:11 PM
    Friday, November 25, 2011 4:51 PM
  • Thanks Nelson, that did the trick.

    The path in gpedit is slightly incorrect though, it should be:

    Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment -> limit maximum number of monitors

    I have a desktop and a netbook at home. The desktop has 2 monitors. I used the RDP gateway to remote from the desktop to the netbook and it used both monitors. I set the group policy (from the RDP session!), logged off and on and it now only uses a single monitor!

    Many, many thanks.

    Friday, November 25, 2011 7:16 PM
  • I can confirm this worked on Windows 10 Pro late in 2018. Thanks!! Was bugging me like crazy.

    Tuesday, October 9, 2018 10:44 PM