none
Sphero Methods RRS feed

  • Question

  • I am trying to use the methods provided in the following page in order to connect with Sphero, but they do not work for me. I wonder if any one can help me.

    https://code.msdn.microsoft.com/windowsapps/Sphero-SDK-Sample-2b18913c

    Specifically, when setupRobot() is run, no indication of finding any Sphero is shown.

    I am using Ms Visual Studio Community 2017 and Windows 10. 

    Should I necessarily use Windows 8.1 and/or Visual Studio 2013 ? If so, I cannot even add RobotKit.dll to Visual Studio 2013 .

    • Moved by Xavier Xie-MSFT Tuesday, December 19, 2017 5:59 AM third-party sdk
    Monday, December 18, 2017 8:33 PM

Answers

  • Hi Sina.M,

    I checked the sample you mentioned. I could run the sample but there is no Sphero ball around me so I get the message dialog saying No Sphero Paired. Since the sample is using Bluetooth RFCOMM, it would be important to make sure both of the devices have turned on Bluetooth.

    The problem is more related to the RobotKit. It is a third party kit and is out of the scope of UWP forum. I suggest that you could ask about this in the official site of the Sphero.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Sina.M Tuesday, December 19, 2017 6:45 AM
    Tuesday, December 19, 2017 6:09 AM

All replies

  • Hi Sina.M,

    I checked the sample you mentioned. I could run the sample but there is no Sphero ball around me so I get the message dialog saying No Sphero Paired. Since the sample is using Bluetooth RFCOMM, it would be important to make sure both of the devices have turned on Bluetooth.

    The problem is more related to the RobotKit. It is a third party kit and is out of the scope of UWP forum. I suggest that you could ask about this in the official site of the Sphero.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Sina.M Tuesday, December 19, 2017 6:45 AM
    Tuesday, December 19, 2017 6:09 AM
  • Hi Roy,

    Thank you very much for your time and consideration.

    Best regards

    Sina

    Tuesday, December 19, 2017 6:46 AM