locked
User details not pulled from AD RRS feed

  • Question

  • Hello All!

    While creating / updating a user record in CRM 2015 IFD instance, after I enter the correct domain name and tab out of the field, I expect some of the fields [including first and last name of the user] to be automatically pulled from AD which is not happening.

    To further test if login user is lacking some kind of privilege, I logged in as same user to another CRM 2015 IFD instance [which is another server] under the same AD and the user details got pulled from AD as expected.

    Any inputs on why this is happening and how to overcome this issue?

    Tuesday, September 8, 2015 9:37 AM

All replies

  • Log onto the desktop of the CRM server with the issue and do a nslookup to the Active Directory machine and make sure it resolves.  The DC may have changed after that CRM server was installed.  If it has, you may need to add a registry key for the preferred DC or uninstall and reinstall CRM.

    Make sure that the CRM server isn't using a HOST file to spoof DNS.

    You may also want to check the firewall and make sure that the LDAP call isn't being blocked on the CRM server.


    Jason Peterson

    Tuesday, September 8, 2015 9:55 PM
  • Adding onto what Jason said it also maters what format the user name was entered in.  Last I had checked it won't do the AD check for a user that was entered using a name@domain.com format only a domain\name.  Also if the user is not part of the same domain where the CRM server resides it will not be able to pull that because the other fields are not pulled over for cross domain accounts.
    Thursday, September 10, 2015 3:58 PM
  • Crm will use the CrmAppPool identity to get the user data from AD. It could be that this account doesn't have sufficient AD privileges

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Friday, September 11, 2015 8:57 AM
    Moderator