locked
OCS2007 broke our legacy IIS applications? Integrated authentication fails RRS feed

  • Question

  • I've installed OCS2007 on one of our servers. The installation went fairly well, and I had tested it in beforehand on a virtual server some months ago. However, after installing OCS2007 we quickly noticed that two legacy IIS applications that normally run on Integrated Windows Authentication started failing. The users simply cannot log in. The exact error code is 401.1.0.

    Any web site that I manually put up in IIS behaves the same; I cannot get it to work with Integrated Windows Authentication. However, the SharePoint front end on the server works just fine, it accepts the connections authenticating with Integrated Windows Authentication. I noticed also another oddity: If I run Internet Explorer from my own domain machine, and navigate to the legacy application site, login simply fails. If I run on the server that hosts the legacy web applications, and run Internet Explorer with my own domain credentials, and navigate to the legacy application site, it works just fine. 

    It simply seems that OCS2007 has strenghtened the security of the server and thus the old intra applications fail to authenticate the users. Help is desperately needed here!
    Tuesday, June 9, 2009 11:39 AM