locked
CRM 2013 Online Sandbox Instance Field Permissions Error RRS feed

  • Question

  • There is an issue with my Sandbox after it was refreshed from Production.  All solutions are successfully copied over.  However, fields that had Field Level Security do not show up under Field Permissions even though they have Field Level Security Enabled.

    I can add and remove Field Level Security on fields that previously did not have it but am unable to do so with fields that previously had Field Level Security.  The error I get, even as a System Administrator (same as in our Production environment),  states that I do not have permission to modify those fields.

    Next, I was able to add the Field Permissions in Test for the entity fields I wasn't able to previously by adding a Field Security Profile in Production containing the fields.  I had hoped that I'd also be able to bring over which users were members after importing the  Solution.  Unfortunately, they weren’t and when I tried to add them again in Test, I got

    Caller [MY GUID] doesn't have privilege for attribute [ATTRIBUTE WITH THE FIELD LEVEL SECURITY] of entity [ENTITY WITH THE ATTRIBUTE]

    The added Fields are still not visible under System Administrator.  Even removing the fields and then trying to add myself as a member still gives me this error.  Looking at the XML, even though I removed field level security from the fields (confirmed they did not show in the Field Permissions list), they are not actually removed.  I compared it with the XML I saw previously which had no field level security on any fields (this was before I tried making any changes)

    Is this a bug?  Is there a possible step that was missed?


    tldr; Field Level Security issues when refreshing Sandbox from Production.  Cannot disable and re-enable Field Level Security on fields that had Field Level Security enabled in Production.




    • Edited by stopacio Thursday, July 31, 2014 6:58 PM
    Thursday, July 31, 2014 6:01 PM