locked
IFD Configuration Issue RRS feed

  • Question

  • I am trying to get the IFD config working on a test bed before I roll it out to production.  There are two organizations in the crm system (OrgA and OrgB).  I want them to be accessible from the internet at the addresses OrgA.testcrm.companyname.com and OrgB.testcrm.companyname.com.  I had my ISP create the testcrm.companyname.com zone and put an entry for both OrgA and OrgB pointing to the same public IP address (211.123.123.1).  In my firewall I have a NAT pointing the public IP (211.123.123.1) to the internal IP (192.168.1.67) and allowing only http and https traffic.  In the IFD configuration tool I put the IFD App and SDK Root Domains to testcrm.companyname.com and set the Domain Scheme to HTTPS.  In my internal DNS, I created an entry for both OrgA.testcrm.companyname.com and OrgB.testcrm.companyname.com pointing to the internal IP of 192.168.1.67.  When I go to access that URL from a workstation outside of the internal network I first get a certificate error and then a connection error.  Can anyone point out where I went wrong with all this?  Any troubleshooting suggestions would be welcome too.  Thanks!
    Tuesday, April 6, 2010 5:36 PM

Answers

  • Well nevermind, I got it all figured out.  The culprit was the SSL certificate, or lack thereof.  I switched it to HTTP and the site worked.  So I checked the certificate and realized there wasn't one.  After installing the a generic cert for testing, the site worked in HTTPS. Hope this helps someone else.
    Tuesday, April 6, 2010 7:22 PM