locked
Use the Email Router to send email with Hosted Exchange RRS feed

  • Question

  • Hello Experts,

       I am trying to set up CRM to send emails from workflows. I have installed the Email Router on the CRM Server, and our Exchange is Hosted. I have read plenty of material on how to set up the Router to RECIEVE mail, but there is virtually nothing about  SENDING mail.

       In email router I created an Outgoing profile with the following details:

    Name: Outgoing
    Direction: Outgoing
    Type: SMTP
    Authentication Type: Windows Auth

    Location
       Server: myexchange.server.com
       Use SLL: No

    Access Credentials: Other Specified
       User Name: myname@domain.com
       Password: *******


    ------------------------------------------

    I did not create an Incoming Profile since I don't want email Router to track email

    -----------------------------------------

    I then created a Deployment

    Deployment: My Company
    CRM Server: http://crmserver:5555/BusinessUnit
    Access Credentials: Local System Account

    Default Config Profiles
       Incoming: none (since I did not create an Incoming Profile as explained above)
      Outgoing: Outgoing (the profile listed above)

    --------------------------------------------------------

    On the Users, Queues, and Forward Mailboxes Tab, when I click the Load Data button, I get an error. When I run a workflow that sends an email, the email activity is created, but remains in a "Pending Send" state.

    Any ideas?
    Thursday, March 4, 2010 5:21 PM

Answers

All replies

  • Deployment: My Company
    CRM Server: http://crmserver:5555/BusinessUnit
    Access Credentials: Local System Account


    Try using a domain admin account rather than Local System Account for the Access Credentials and see if that works.
    Best Regards | Twitter: edwardsdna
    Thursday, March 4, 2010 6:17 PM
  • Hello Alex,

    first, you should enable tracing on the eMail router to get additional informations.
    How to do this look here: http://blogs.msdn.com/benlec/archive/2008/07/02/crm-4-0-e-mail-connector-logger-tool.aspx

    Then you can read this article about configuration and troubleshooting the email router with hosted exchange: http://jianwang.blogspot.com/2008/07/crm-40-e-mail-router-for-hosted.html
    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Thursday, March 4, 2010 6:39 PM
  • Michael,

       The email logger tool looks promising, but there does not seem to be a link I can click on to download it. I've searched the WEB, and all the links I find point to the page you referred me too. Does anyone know where I can download it?

    Al
    Friday, March 5, 2010 3:03 PM
  • Michael,

       The email logger tool looks promising, but there does not seem to be a link I can click on to download it. I've searched the WEB, and all the links I find point to the page you referred me too. Does anyone know where I can download it?

    Al

    The person (Ben) who had written the tools has stopped sharing it. :-(
    However, I have a copy from a previous download. ;-)

    Download


    Kaustubh Giri
    Friday, March 5, 2010 6:57 PM
  • Kaustubh,

       Wow, thank you so much. I'll try it out.

    Al
    Friday, March 5, 2010 9:12 PM
  • Kaustubh,

       Wow, thank you so much. I'll try it out.

    Al

    My pleasure :-)


    Kaustubh Giri
    Saturday, March 6, 2010 12:27 AM
  • Kaustubh,

       I put the file on the Desktop of the CRM server, and ran it. Immediately I got the following error:

    CRM Email connector Logger was no able to find any CRM Deployment configured in the Router Service Configuration File.
    Please run the Configuration Manager first and try again.

       Any ideas?


    Also, just for my knowledge, when the workflow fires, and the email activity is created, how long before the Email Router actually sends it?

    Al
    Thursday, March 11, 2010 9:25 PM