locked
Xrm.Utility.openEntityForm bug RRS feed

  • Question

  • Hi

    I have a script on Phone Call entity form that opens up Contact entity form using Xrm.Utility.openEntityForm. It works fine in below scenarios:

    1. Accessing CRM through Internet Explorer.(Contact record is already opened or not does not matter. If already opened it refresh the form).

    2. Accessing CRM through Outlook. (Contact record is not opened)

    It does not work in below scenario.

    1. Accessing CRM through Outlook. Contact record form is already opened. It does not do anything. I am passing some parameters in Phone Call entity script but nothing happens when contact record is already opened.

    Any thoughts?

    Sunday, March 30, 2014 11:32 PM

All replies

  • Hi,

    I have a requirement where when user is trying to save a phone call that is regarding a contact record, a confirmation box should come up and ask if user is interested in creating a new opportunity.

    If yes, then contact form should open up and focus should be on opportunity tab and on 'no' do nothing.

    On yes, I am using Xrm.Utility.openEntityForm and passing on the GUID of Contact and a parameter to set State of tab. I am checking value of that parameter in form on load of contact entity and setting state of tab on basis of that,

    It works fine in scenario where Contact form is not opened. If Contact form is already opened there it does not go to contact form and set focus on tab.

    This issue is happening when I am doing these steps from CRM with outlook client. If I do this from IE then it works fine.

    If I use Window.open then it opens up IE and ask user to provide credentials again. It is an IFD deployment. Any thoughts?

    Wednesday, March 12, 2014 12:01 AM
  • Any idea guys?
    Friday, March 28, 2014 1:51 PM