locked
Incorrect time shows against Appointment CRM/Outlook RRS feed

  • Question

  • When an Appointment is created in the Service Calendar, for example between 2-5pm strangely this then gets entered as an hour later [3-6pm] in the calendar view [it also suggests a conflict with work hours].

    When viewed in the Outlook Calendar by the user concerned it shows the same [3-6pm] but in other users calendars it shows as the correct times [2-5pm].

    I have checked the time for both windows and CRM and they are as they should be. I can't think what else this might be.

    Thanks in anticipation.

    Thursday, March 31, 2011 2:30 PM

Answers

  • Managed to get time zone settings to appear on client and found them to be incorrect - rectified this and problem was resolved.

    thanks for all the help

    • Marked as answer by DavidtMoore Tuesday, April 5, 2011 7:54 PM
    Tuesday, April 5, 2011 7:54 PM

All replies

  • David

    What region/country do you belong to?

    And what is the time zone setup on CRM server?

    Thursday, March 31, 2011 2:34 PM
  • Hi Karan. thanks for responding.

    I am in the UK.

    The time on the Server is correct, though i don't have access to the time zone settings, though i would imagine it would be GMT.

    Thanks

    Thursday, March 31, 2011 3:26 PM
  • Well, I faced similar problem.

    We had CRM server in Sweden and a tenant of CRM 4 for Portugal. We faced this 1 hour difference in that condition.

    Reason was Time zone between Portugal and Sweden was at a difference of one hour. While setting up tenant for Portugal, we set up Time Zone on Organisation on server as per Portugal.

    But it had to be setup for Sweden and then all the CRM clients should select their own timezone to Portugal in personal settings.

     

    So, kindly verify that in your case, timezone on organisation on server is setup to the location where your servers are actually located.

    You can check time zone setting by

    Browsing http://Localhost:<portname>/orgname on server.

    Now go to Tools --> Options --> General --> TimeZone. Verify if timezone is same as physical location/windows timezone of server machine.

    Let me know if this helps you

    • Proposed as answer by Jim Glass Jr Thursday, March 31, 2011 5:10 PM
    Thursday, March 31, 2011 4:23 PM
  • Hi. I have checked the time-zone settings on the server and they are correct.

    At the moment i can't find a way to check the time-zone settings on the client, though the actual time is showing as correct under the client profile.

    This must be an issue with the clients local machine as it only appears to be affecting them.

    Any additional comments/help would be welcome.

    thanks

    Friday, April 1, 2011 7:47 AM
  • Hi

    For client personal settings -->

    Go to Tools --> Options --> Formats --> Select appropriate format based on your region.

    Is this problem occurring on Outlook client, web client or both?

    Friday, April 1, 2011 9:37 AM
  • Thanks for that. Unfortunately under Formats there is no option to change the Time Zone, if available this would appear under the General Tab, though for some reason it does not.

    I have since found out that the issue is ONLY within Service Calendar, so the Outlook calendar is fine - Appointments in Service Calendar take on a new time [+1hour] this has only started to happen since the start of BST and the clocks went forward.

    I hope this makes sense and you can be of further assistance

    Friday, April 1, 2011 1:05 PM
  • David

    My bad while answering last reply :). I meant to say, select proper format based on your personal preference.

    Second, just curious to know if your database settings are in same timezone as of application server.

     

    Friday, April 1, 2011 1:09 PM
  • Hi.

    The format options dont have any bearing on the time itself only the way it is displayed!

    I'm not sure how to find out the database settings.

    I'll keep researching things and post any solutions.

    thanks

    Friday, April 1, 2011 1:46 PM
  • Managed to get time zone settings to appear on client and found them to be incorrect - rectified this and problem was resolved.

    thanks for all the help

    • Marked as answer by DavidtMoore Tuesday, April 5, 2011 7:54 PM
    Tuesday, April 5, 2011 7:54 PM