none
Azure SQL Database Elastic Scale: Shard Elasticity Problem RRS feed

  • Question

  • Hey Scripting Guys. I have been playing around with the scripts that you set up in Azure SQL Database Elastic Scale: Shard Elasticity - https://gallery.technet.microsoft.com/scriptcenter/Elastic-Scale-Shard-c9530cbe. The first time that I run the scripts, everything works fine. I get the Shard Map Manager Database created as well as today's shard. I then delete those 2 databases through Enterprise manager using the commands

    drop database [Shard_20150419]
    drop database [ShardMapManagerDb]

    When I run the scripts again, the databases are created, but there are no tables inside the databases. The scripts complete without errors and the output from the output window looks the same as the first time I created them. What's going on here? Do I need to do more to delete the databases than just drop them? When I wait another day, I get the same behaviour. The first time it works, then second time, empty databases. I have tried dropping and recreating the jobs in between runs, and that doesn't fix the problem. I have also tried publishing the jobs, and that doesn't fix the problem. I really need to know what is going on here before I can continue evaluating this technology.

    Regards,
    Paul


    • Edited by phebhardt Monday, April 20, 2015 7:45 AM added link
    • Moved by Bill_Stewart Thursday, May 28, 2015 8:04 PM Asked and answered in gallery entry's Q&A tab (also, this is not support forum for gallery scripts)
    Monday, April 20, 2015 1:36 AM