locked
Money Plus Delux Sunset on W8 hangs opening Money Plus Delux Sunset .mny files created on XP machine RRS feed

  • Question

  • I think I fit it into one line above.   I thought I was ready to kill the XP machine, but now I'm stuck.

    MPDS opens the sample .mny file on the W8 machine successfully.

    • Edited by ThreePines Sunday, July 31, 2016 6:26 PM
    Sunday, July 31, 2016 6:24 PM

Answers

  • Patience!

    I noticed that the sample file seemed to take quite a while longer to open on the W8.1 machine.

    So, I just launched my .mny file and waited.   Took about 5 mins, but lo and behold, it opens.

    I don't know if some phone home stuff had to time out, or maybe some DB reindex, who knows.   Nevertheless, I am now a happy camper.

    Thanks for your input. 

    • Marked as answer by ThreePines Thursday, August 4, 2016 12:06 AM
    Thursday, August 4, 2016 12:06 AM

All replies

  • When you installed Money on your Windows 8.1 machine did you replace the mnyob99.dll file with a patched version as described in the first "sticky" thread in this forum:

    https://social.microsoft.com/Forums/en-US/d28d6921-1f01-430f-b33e-f5a3ec47077b/important-patch-for-money-plus-maybe-20062007-mnyob99dll?forum=money

    If not, I would try that first.  Then, if that doesn't help, I would try opening an older backup of your .mny file.  Let u know how you make out.


    Bill Becker

    Sunday, July 31, 2016 6:59 PM
  • Initially, no.

    Since, I have done so.  I replaced the DLL anyway.  Is it no longer necessary to register dlls?

    Money still hangs, but I have not yet tried rebooting.

    Sunday, July 31, 2016 7:11 PM
  • Also try the firewall entry described here: https://microsoftmoneyoffline.wordpress.com/2016/06/06/eliminating-the-online-updatingdelays-and-errors-when-opening-money/

    That is in case Money is waiting for some online thing.

    When you say Money Plus will open the sample file, do you mean the sample file copied from the XP machine?

    Sunday, July 31, 2016 8:33 PM
    Moderator
  • I meant the sample file on the W8 machine.  I expect it came from the install, which I re-did earlier on this quest.
    Sunday, July 31, 2016 9:07 PM
  • I would try copying sample.mny from the XP machine to the newer machine, and rename the file to sam_xp.mny or some such. See what happens if you try to open that file on newer machine.
    Sunday, July 31, 2016 9:39 PM
    Moderator
  • Well, I'm stumped. 

    Same version of Money running on side by side XP and W8.1 machines.   Money hangs on the W8 machine whenever I try to open a .mny file created on the XP machine.  File Restore (on W8) of back up made on XP machine also hangs, but only AFTER creation of full sized .mny file.   Can't open that .mny file either, though it is created on the W8 machine. 

    Reiterating, W8 machine Money opens the sample .mny file that came with the install.  Seems the install of Money on the W8 machine is OK.  

    Sunday, July 31, 2016 10:20 PM
  • V17.0.120
    Sunday, July 31, 2016 10:22 PM
  • Check file permissions on the .mny file after copied over to Windows 8.1 machine.

    Bill Becker


    Sunday, July 31, 2016 10:26 PM
  • Check file permissions on the .mny file aftercopied over to Windows 8.1 machine.

    Bill Becker

    When I want to remove permissions, I copy a file to a USB flash drive that has been formatted to FAT32. I suspect you have a better simple way.

    If the problem is permissions, I would like to think that Windows 10 would have given a clear error message.

    Try this: launch Money by right-clicking the launch icon and choosing RunAsAdministrator. Then see if you can File->Open the file you have a problem with.


    Sunday, July 31, 2016 10:31 PM
    Moderator
  • XP will open user files in the Program Files area but Windows 7 and later will not. In newer versions of Windows your user files must be in the User area.

    Is your .mny file in your C:\Users\<username>\Documents area or in C:\Program Files (x86)\Microsoft Money? If it is in C:\Program Files (x86)\Microsoft Money move it to your C:\Users\<username>\Documents area. Then start Money and select File - Open.

    Monday, August 1, 2016 7:53 AM
  • I was excited about this possibility, but no dice. 

    Similarly, I had checked permissions, and that wasn't the problem.

    I get well past password authentification.   When I select OPEN and browse to my .mny file in the C:\Users\Dave\Documents\MSMoney, I get precisely the same behavior as if the file is in the program_files x86 directory.

    Money establishes anywhere between 17 and 23 threads in about 10 seconds, before going "not responding" in resource monitor.  It also creates a file in the same directory where the .mny file is located, an .lrd file.  When I open with a text editor, I see it is recording the name of my PC.

    Same when running as Administrator.

    I found OS log files that refer to "hang signatures", but I don't know how to interpret them. 

    Money running on the XP machine opens the .mny file off of the USB key quite fine.  





    • Edited by ThreePines Wednesday, August 3, 2016 11:55 PM
    Wednesday, August 3, 2016 11:22 PM
  • Opens fine.........

    Answering Cal on the transferred sample.mny file.


    • Edited by ThreePines Wednesday, August 3, 2016 11:59 PM
    Wednesday, August 3, 2016 11:46 PM
  • Patience!

    I noticed that the sample file seemed to take quite a while longer to open on the W8.1 machine.

    So, I just launched my .mny file and waited.   Took about 5 mins, but lo and behold, it opens.

    I don't know if some phone home stuff had to time out, or maybe some DB reindex, who knows.   Nevertheless, I am now a happy camper.

    Thanks for your input. 

    • Marked as answer by ThreePines Thursday, August 4, 2016 12:06 AM
    Thursday, August 4, 2016 12:06 AM
  • Patience!

    I noticed that the sample file seemed to take quite a while longer to open on the W8.1 machine.

    So, I just launched my .mny file and waited.   Took about 5 mins, but lo and behold, it opens.

    I don't know if some phone home stuff had to time out, or maybe some DB reindex, who knows.   Nevertheless, I am now a happy camper.

    Thanks for your input. 

    I suspect you did not do the firewall thing suggested.
    Thursday, August 4, 2016 12:11 AM
    Moderator