none
Error Message: Parameter is incorrect or it is in wrong fromat

    Question

  • I have to reinstall Windows HPC 2012 to the head node.  HPC databases sit on remote SQL 2014 server so we are following the "Reinstall While Preserving Database Data" article (https://technet.microsoft.com/en-us/library/gg750758(v=ws.11).aspx#BKMK_Steps).  When trying to set up the "setup.exe" command and running it, I keep getting the following error:  

    The parameter  is incorrect or it is in the wrong format.

    Setup.exe [-unattend] [-client] [-clusteredInstance:xxx] [-headNode] [-computenode:xxx] [-brokernode:xxx] [-workstationnode:xxx] [-installdir:xxx] [-datadir:xxx] [-dbInstName:xxx] [-MgmtDbDir:xxx] [-MgmtDbLogDir:xxx] [-MgmtDbConStr:xxx] [-SchdDbDir:xxx] [-SchdDbLogDir:xxx] [-SchdDbConStr:xxx] [-ReportingDbDir:xxx] [-ReportingDbLogDir:xxx] [-RptDbConStr:xxx] [-DiagDbDir:xxx] [-DiagDbLogDir:xxx] [-DiagDbConStr:xxx] [-MonDbDir:xxx] [-MonDbLogDir:xxx] [-MonDbConStr:xxx] [-EnableMicrosoftUpdate] [-EnableSqm] [-KeepData] [-skipFirewall] [-runtimeShareDirectory:xxx] [-?]

    Parameters:


    I've tried various edits to make the command correct, but the same error continues to pop up with the above error all the time.  I have no idea what parameter the error refers too .... 

    Below is my command, could someone please tell me what I need to fix to make it run.

    setup.exe -keepdata -unattend -headnode [-installdir:D:\Program Files\Microsoft HPC Pack 2012] [-datadir:D:\Program Files\Microsoft HPC Pack 2012\Data] [-dbInstName:XXXXXX] [-MgmtDbConStr:Data Source="XXXXXXX\XXXXXXX;Initial Catalog=HPCManagementIntegratedSecurity=True;"] [-SchdDBConStr:Data Source="XXXXXXX\XXXXXXX;Initial Catalog=HPCSchedulerIntegrated Security=True;"] [-RptDbConStr:Data Source="XXXXXXX\XXXXXXX;Initial Catalog=HPCReportingIntegratedSecurity=True;"] [-DiagDbConStr:Data Source="XXXXXXX\XXXXXXX;Initial Catalog=HPCDiagnostics;IntegratedSecurity=True;"] [-MonDbConStr:Data Source="XXXXXXX\XXXXXXX;Initial Catalog=HPCMonitoringIntegratedSecurity=true;"] [-runtimeShareDirectory:D:\HPCRuntimeDirectory]


    I've put in brackets, semi-colons, colons, checked spelling, confirmed path names, DB name, server name, etc ... and cannot figure it out.

    Thanks!

    Friday, May 12, 2017 9:30 PM

All replies

  • Please remove -installdir and -datadir as you're using the default setting and looks like these two parameters are complaining as you didn't use quote for the path.

    And the other way to recover is:

    - Make a fresh install

    - Restore the Database and restart the services on the headnode


    Qiufang Shi

    Monday, May 22, 2017 5:30 AM
  • Please remove "[" and "]", a parameter with "[]" brackets just mean it is optional, you shall not put "[]" in the command when you specify the parameter.
    • Edited by Sunbin Zhu Monday, May 22, 2017 5:39 AM
    Monday, May 22, 2017 5:37 AM
  • Oh, okay ... a fresh install sounds like the easiest and best way.  I just wasn't sure if I did that and then a database restore, if that would cause any issues with the database connections and all against a fresh install.  I'll give it a shot.  Thanks!
    Monday, May 22, 2017 3:43 PM