locked
Remote Web Access with Windows 10 Home RRS feed

  • Question

  • Hi,

    I can use all feature using the connector software in my local network. But when on the road, I connect via xxx.homeserver.com. Login works, can access my shared folders, but when I want to access the WHS 2011 Server Dashboard, I got an error like this: The Computer can't connect with the Remotedesktop-Gatewayserver. (translated from german) . This workes without problems on an Windows 7 Home and on a 7 Pro Computer. The same problem happens on my Windows 10 tablet. Only local working with the connector software. Windows 10 is version 1607.

    Monday, September 26, 2016 7:28 PM

All replies

  • Hi,

    According to your description, my understanding is that it failed to open Dashboard remotely from Windows 10 to WHS 2011, with error: The Computer can't connect with the Remotedesktop-Gatewayserver.

    Try to disable any 3rd party program, including anti-virus software and windows firewall temporarily, and check the result. Add the xxx.homeserver.com as a trusted website and change to use different browser.

    Besides, try to ping the IP address of Remotedesktop-Gatewayserver when this problem happens, in order to identify the network connectivity. 

    If the problem persists, check event on both client and server, make sure if any related event has been logged.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 27, 2016 8:58 AM
  • Hi,

    RWA with Windows 7 Professional Home and Windows 7 Professional works. I can log in, get the Dashboard via homeserver.com can access my Outlook 2010 via WHS 2011 Outlook, get shares. Everything work!

    On 2 Windows 10 Home Computers I can log on homeserver.com. I can use my shares, but I get the error accessing the Dashboard or Outlook. Disabeling the Firewall changed nothing. There is no 3rd party anti-virus only Windows Defender. Homeserver.com is allready added as thrusted website. RWA works only with Internet-Explorer, because of the ActiveX control. This one is installed.

    It seems, that is a specific Windows 10 anniversary update problem, because before it worked!

    I've just installed an VPN client to get etablished an connection with my router. And this connection worked too. I can use RDP to connect the server.

    Manfred

    Tuesday, September 27, 2016 9:46 AM
  • Hi,

    Windows 10 client failed to open WHS 2011 Dashboard/Outlook via RWA, and this problem only happens when outside the local network. Try to add the corresponding entry(IP address and xxx.homeserver.com) on local hosts file(%windir%\system32\drivers\etc), then, check the result.

    If this problem only happens after Windows 10 Anniversary Update, make sure that your client has been updated to data, as there are following updates which has been released latterly, it would be helpful for resolving some known issues.

    Reference - Windows 10 update history:
    https://support.microsoft.com/en-us/help/12387/windows-10-update-history

    Besides, have checked the Event Viewer and find any useful event log?

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 29, 2016 2:55 AM
  • Hi,

    thanks for your suggestions.Edit the local hosts file but it changed nothing. All updates on the windows 10 machine are installed. In the event viewer I don't find any relevant items.

    Thursday, September 29, 2016 12:04 PM
  • Hi,

    after all I installed 2 optional Updates on the Server and then den RWA crahed on the Windows 10 Maschine and also on the Windows 7 Machine. Then I deinstalled these. And now the connection don't work on both maschines. Windoes 7 tells me a little more. It seems that the authentification is not the one as exepeted. And now these optional updates are not offerd again.....I look again at the logs and now I finally found these.

    Windows 10:

    Komponentenname:CAAClientAdapter, :: 'm_spHelper->ReadCreds failed' in CAAClientAdapter::CreateTunnel at 380 err=[0xffffffff], Fehlercode:0xFFFFFFFF
    Komponentenname:CClientProxyTransport, :: 'm_ClientAdapter->CreateTunnel failed' in CProxyRawTrans::CreateProxyConnection at 2116 err=[0x800759d9], Fehlercode:0x800759D9
    Komponentenname:CClientProxyTransport, :: 'Gateway connection time out is 90' in CClientHTTPProxyTransport::Connect at 1099 err=[0x800759d9], Fehlercode:0x800759D9
    Komponentenname:CClientProxyTransport, :: 'CreateConnection failed' in CClientHTTPProxyTransport::Connect at 1108 err=[0x800759d9], Fehlercode:0x800759D9
    Komponentenname:CClientProxyTransport, :: 'Gateway Error' in CClientProxyTransport::SetErrorStatus at 2818 err=[0x800759d9], Fehlercode:0x800759D9
    Komponentenname:CAAClientAdapter, :: 'm_spHelper->ReadCreds failed' in CAAClientAdapter::CreateTunnel at 380 err=[0xffffffff], Fehlercode:0xFFFFFFFF
    Komponentenname:CAAHttpClientTunnel, :: 'Workspace ID was obtained, but it does not smell like a GUID ()' in CAAHttpClientTunnel::ObtainWorkspaceId at 3789 err=[0x0], Fehlercode:0x0
    Komponentenname:CAAHttpClientRawTransport, :: 'CAAHttpClientRawTransport::InitializeInstance' in CAAHttpClientRawTransport::InitializeInstance at 260 err=[0x0], Fehlercode:0x0
    Komponentenname:CheckInternetConnectionTask, :: 'Internet-connection is alive. Server checked: http://www.microsoft.com' in CheckInternetConnectionTask::ExecuteTask at 3595 err=[0x0], Fehlercode:0x0
    Komponentenname:CheckInternetConnectionTask, :: 'Connection-to-server is alive. Server checked: https://xxx.homeserver.com' in CheckInternetConnectionTask::ExecuteTask at 3609 err=[0x0], Fehlercode:0x0
    RDPClient_Gateway: Fehler beim Übergang von "AAStateCreatingOutChannel" zu "AAStateError" in Reaktion auf "AAEventOutChannelSendRequestFailed" (Fehlercode: 0x80190194).
    Komponentenname:CAAHttpClientTunnel, :: 'connect failed' in CAAHttpClientTunnel::OnConnected at 1053 err=[0x80190194], Fehlercode:0x80190194
    RDPClient_Gateway: Fehler beim Übergang von "AAStateInitializingTunnel" zu "AAStateError" in Reaktion auf "AAEventTunnelOnConnectedFailed" (Fehlercode: 0x80190194).
    Komponentenname:CAAClientAdapter, :: 'm_spHelper->ReadCreds failed' in CAAClientAdapter::CreateTunnel at 380 err=[0xffffffff], Fehlercode:0xFFFFFFFF
    Komponentenname:CClientProxyTransport, :: 'Gateway Error' in CClientProxyTransport::SetErrorStatus at 2818 err=[0x800706f4], Fehlercode:0x800706F4

    Windows 7:

    RDPClient_Gateway: Fehler beim Übergang von "AAStateCreatingOutChannel" zu "AAStateError" in Reaktion auf "3" (Fehlercode: 0x80190194).
    RDPClient_Gateway: Fehler beim Übergang von "AAStateCreatingOutChannel" zu "AAStateError" in Reaktion auf "3" (Fehlercode: 0x80190194).
    RDPClient_Gateway: Fehler beim Übergang von "AAStateInitializingTunnel" zu "AAStateError" in Reaktion auf "6" (Fehlercode: 0x80190194).
    RDPClient_SSL: Fehler beim Übergang von "TsSslStateHandshakeInProgress" zu "TsSslStateDisconnecting" in Reaktion auf "8" (Fehlercode: 0x80004005).

    Regards

    Manfred

    Monday, October 3, 2016 7:06 AM
  • OK, some news. Used an Server Backup to restore the WHS. Now again I can use RWA on the Windows 7 computers. But on the Windows 10 machines nothing changed. The error log shows the same as posted before.
    Monday, October 3, 2016 8:30 PM
  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. 

    Appreciate your patience.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 7, 2016 3:00 AM
  • Hi,

    Please reference below link to check network relate configurations:
    https://technet.microsoft.com/en-us/library/remote-connectivity-support-2(v=ws.11).aspx

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 10, 2016 1:38 AM
  • Hi,

    I am checking to see how things are going there on this issue. Please let us know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 12, 2016 8:54 AM
  • Hi Eve,

    thank you for the answer, but this is not the problem. All our Windows 7 computers can connect to all services via xxx.homeserver.com. Only our 2 Windows 10 devices can't. It is an notebook and a tablet. After a lot of reading on different forums there was the suggestion to try the Microsoft Remote Desktop Connection Manager. I set up a connection to xxx.homeserver.com and can connect to the Server Desktop. This looks now, that in Windows 10 is something broken after the AU. On the German deskmodder.de forum, there is also someone with the same problem. Can it be, that the remote session is changed in AU and WHS 2011 didn't recognize it? Or .....

    Best regards

    Manfred Bartelt

    Sunday, October 16, 2016 6:53 AM