locked
CRM 2013 - Silverlight plugins which are called from HTML web resource are not working RRS feed

  • Question

  • Hi All,

    I have created Silverlight plugin.

    1) One button is created in ribbon named Create Order inside Quote form

    2) On clicking Create Order button, one dialog opens where it will display Quote id and Quote item details are moved to Order form

    3) This Silverlight plugin is called from HTML web resource.

    4) This was working fine in CRM 2011

    5) But after upgrading to CRM 2013 this plugin is not working.

    6) only HTML blank window is opening.

    And i found issue in HTML web resource

    This was for CRM 2011 which is working fine

     <form id="form1" runat="server" style="height: 100%">
        <div id="silverlightControlHost">
            <object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="100%" height="100%">
                <param name="source" value="ClientBin/QuoteToOrder.xap">
                <param name="onError" value="onSilverlightError">
                <param name="background" value="white">
                <param name="minRuntimeVersion" value="4.0.50401.0">
                <param name="autoUpgrade" value="true">
                <a href="http://go.microsoft.com/fwlink/?LinkID=149156&amp;v=4.0.50401.0" style="text-decoration: none">
                    <img src="http://go.microsoft.com/fwlink/?LinkId=161376" alt="Get Microsoft Silverlight" style="border-style: none">
                </a>
            </object>
            <iframe id="_sl_historyFrame" style="visibility: hidden; height: 0px; width: 0px;
                border: 0px"></iframe>
        </div>
        </form>

    but in CRM 2013

                                                                            

    <form id="form1" style="height: 100%;" runat="server">
    <div id="silverlightControlHost">
    <object width="100%" height="100%" data="data:application/x-oleobject;base64,QfXq3+HzJEysrJnDBxUISgAJAABIQwAA6BgAAAAAAAAAAAAAAAAAAAAAAAAAAAAAPAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAEAAAABAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=" type="application/x-silverlight-2">

                <a style="text-decoration: none;" href="http://go.microsoft.com/fwlink/?LinkID=149156&amp;v=4.0.50401.0">
                    <img style="" alt="Get Microsoft Silverlight" src="http://go.microsoft.com/fwlink/?LinkId=161376">
                </a>
            </object><iframe id="_sl_historyFrame" style="border: 0px currentColor; width: 0px; height: 0px; visibility: hidden;"></iframe></div></form>

    There is difference in Object and param tags.

    Please someone give some solutions for this.


    blrSvsTech

    Friday, May 2, 2014 12:31 PM