Online Updates Hanging, Money Plus Will Not Close Completely RRS feed

  • Question

  • I have used Money for many years with no problems and have it installed on two Window 7 machines, one for active use and the other for backup only. I use Avast and Online Armor.

    Today I noticed that Money would not completely unload from memory. When I close Money and then quickly re-open, I get a notice that "Money is already running finish task". It still is resident in task manager. This occurs on both machines.

    Since something like this has never happened before, I investigated by removing the firewall and av - same issue. 

    I never noticed before that the online update icon revolves for a long time. I have no online services of any kind. After the online update stops turning, then I get a clean close.

    If anyone could please advise I would appreciate it...


    Friday, December 26, 2014 4:44 PM

All replies

  • Reboot your computer, and see if that fixes things.

    I presume "I have no online services of any kind" means that you don't have any online service related to Microsoft Money.


    Friday, December 26, 2014 10:02 PM
  • Yes, I have no online service of any kind. I do not download bank statements or access accounts online.

    Rebooting does not fix anything.

    The online updates icon spins and stutters for about 2 minutes then finally shuts down.  This just started yesterday.

    If I close out Money before it shuts down, then Money remains running in memory. If I shutdown the computer, Windows says Money still running.

    On second computer, did an full uninstall and then re install, same issue.

    I have no other problems with the computers, so I am thinking Money is contacting a server of some kind and not getting thru or a long slow process.

    This is the second day of this

    Any one else experiencing this?

    Saturday, December 27, 2014 12:16 PM
  • You might say what version of Money you are using.

    You might change the backup settings from automatically making a backup. Your version will have something similar to this:

     x Automatically backup to hard disk on exit
      x Prompt me before backing up each time*
      x Make my file small ...

    Try ticking to Prompt me before backing up each time. Then, when the pop-up occurs, try both having it not back up, and telling it to back up.

    You might try un-ticking Make my file small . That seems less likely to help.

    Saturday, December 27, 2014 1:37 PM
  • US Money Deluxe Sunset

    Followed your suggestions, no luck.

    Saturday, December 27, 2014 1:52 PM
  • As a test, after a reboot, try copying Sample.mny from the install folder (which is often C:\Program Files\Microsoft Money Plus) to your Documents folder. From Windows Explorer, double-click that copy to launch Money. Exit. Does Money keep running? If not, that would tend to say that the problem is associated with your Money file somehow.

    If you have fairly recent backup that pre-dates the problem, don't overwrite it. Make a copy onto other media.

    Then try a repair of your Money file. You could try a quick repair. Then try making a repaired version of your file.

    File->RepairMoneyFile->StandardFileRepair level 2

    You can assign a new filename to the repaired version.

    Saturday, December 27, 2014 2:12 PM
  • Thanks once again... no luck with Sample... keeps running.

    - On reboot I get a notice about "Insights".

    - Tried an old backup, no luck either.

    - For good measure, ran repair on backup, no luck.

    Maybe I am having problems somehow connecting to server?

    Nothing seems to work..

    Saturday, December 27, 2014 2:19 PM
  • Look in the tray to see if there is an icon to control Insights -- a blue circle with a white M.

    I see there is an icon off of my Start Menu for Insights. AllPrograms->MicrosoftMoneyPlus->Insights. It points to "C:\Program Files\Microsoft Money Plus\MNYCoreFiles\mnyinsit.exe"

    If you launch that, it may have a control.  I just launched it. It put an M icon into the tray. (You probably won't have to launch Insights, because Insights is already running.) Right-clicking icon that gave Options. You could try un-ticking everything. I then tried Exit. That gave me a pop-up that said "You have chosen to exit Insights. Would you like Insights to run the next time you log on to Windows?" I selected No.

    That will probably fix it for you. If not, there are other steps that could be taken.

    Saturday, December 27, 2014 2:53 PM
  • Thanks... never saw this insights thing before.

    Looks like my original problem is due to the internet/server. Disconnecting from the internet "solves" the issue and speeds up the backup process. Something must be going on with the connection to the Money server.

    Saturday, December 27, 2014 4:18 PM
  • Do you have a liveID/Passport on your file? If so, remove that, and either replace it with no password or a conventional password. However that can't be your problem, because Sample.mny does not have any passwording.

    Experimental idea: You could reboot, and try netstat -f in a command window. Note connections. Start Money. netstat -f again. Note any additions. Maybe do netstat -f >filename to save the output to a file instead of the screen.

    If the "foreign connections" column shows a symbolic pathname for the suspect server attempt, you could set that pathname to address 0:0:0:0 in the hosts file. That would make any reference to the address instantly fail.

    Advanced stuff... don't have a step-by-step for you. Maybe there is some other diagnostic tool that would do a better job of monitoring attempted internet accesses.

    Saturday, December 27, 2014 4:53 PM
  • No live ID regular password.
    Checked the grid on Online Armor. First connects with MS Money site, disconnects, and then re connects. Whole process takes about 2 minutes. If I close Money during this process, Money remains in memory while the process apparently completes. Disconnected AV and firewall, still the same. Beginning to think it is on the server side.

    Sunday, December 28, 2014 2:32 PM