locked
Can't get Connector to install RRS feed

  • Question

  • I have tried and tried but I can't get the new Connector to install on my main WHS from any of the clients.  I use both http://Server:55000 and direct to the Home Server Connector Software share and it looks like it is working until it gives me the following error message:

     

    "Setup has detected that the Windows Home Server Connector or Admin Console is currently running.  Please close all Windows HomeServer windows and run setup again."

     

    I have uninstalled the old connector and rebooted the client and still get the error message when trying to install the new connector.  This is when trying to connect to the main WHS.  My TestWHS connects just fine with the new connector.

     

    I don't know what the error message is referring too.  What do I need to close?  There is no connector software installed on the client and no Console windows open on the WHS.  Any ideas would be appreciated.  Thanks!

    Ted

     

    Wednesday, June 18, 2008 2:41 PM

All replies

  • There could be a hung connection somewhere. Check in Task Manager, that there is no WHS service has been left running. Also, you could remote into the server, and check to ensure that the Terminal Services Clients have been logged off. To do so, RDP into the server,then go to Control Panel - Administrative Tools - Terminal Services Manager. This will open the Manager window, and against your server name, under the Users Tab, there should only be your current Admin session.

     

    Colin

    Wednesday, June 18, 2008 3:10 PM
  • I went there and saw one listening and one active.  So, I disconnectd all and re-connected and just saw one connection (my RDP session).  Tried the Connector install again and got the same message!  I agree, something is hung on the Server.  Maybe one of the Team Members can tell us what the error message means?

    Thanks for the help.

    Ted

     

    Wednesday, June 18, 2008 3:47 PM
  •  

    Hi Ted,

     

    This message is only thrown when the WHS Console is open during the install (setup). Could you please try the following steps to see if any of the related processes are left open:-

     

    - Install process explorer from http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

    - Run it from elevated command prompt

    - From the menu choose Find/Find Handle or Dll

    - Type MSWHSClientConsole.exe for builds older than RC4 builds and MSWHSSetup.exe

    - Click search

    - You get the process who holds the lock, if any

     

    Please try these steps and let us know. If this doesnt work, please file a bug through Connect and please include your logs so that we can troubleshoot. Instructions from Connect are here:

     

    Please submit all bug reports for this release using the following bug reporting form on MS Connect:  https://connect.microsoft.com/WindowsHomeServer/Feedback

     

    Every submitted bug report (Feedback) must include accompanying CAB Numbers so that the Home Server team can examine the logs and try to help resolve the issue. Complete instructions for downloading, installing and submitting CAB’s using the Windows Home Server Toolkit can be found here:

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=2253939&SiteID=50  

     

    Thanks,

    Rohita

    Windows Home Server

    Wednesday, June 18, 2008 10:02 PM
  • Thanks for the input.  I will try that if I can get out of this deep hole I am in now.  I had to run a Server Reinstallation on my main WHS.  At the end of the process, it said there is an error and WHS could not finish Setup.  When I get out of that screen, I see everything else but, of course, it doesn't work right.  I am going to try another Server reinstall.  I think I am toast and have lost everything.  If it comes back and I still can't get the connector to install, I will try the above suggestion.  My gut feel is that I am going to lose 2.7TB of data and have to start all over again.  Not a good week!

     

    Wednesday, June 18, 2008 10:07 PM
  • Did two Server Reinstalls.  First one had setup errors.  AFter spending all day on this WHS, I installed PP1 once again (don't say it!)  Got the same error message on three clients.  So, I uninstalled PP1 and have started to get the main WHS back operational.  I ran the Process Explorer nut thee were no results in Search.  Now, I ran it on the client (my main desktop).  SHould it have been run on the Server?

     

    Thursday, June 19, 2008 1:21 AM
  • Hi Ted,

     

    No, it was meant to be run on the client. Please open a Connect bug with all this information and please attach logs from the server and the client boxes. Instructions in my previous post.

     

    Thanks,

    Rohita

    Windows Home Server

    Thursday, June 19, 2008 3:47 PM
  • I am thinking that my problem is with my main WHS.  I initially installed PP1 on my TestWHS and it worked quite well.  I have no problem with the Connector and it ran for a week backing up the one client that I had connected with no problems. So...I decided to install PP1 on my main WHS.  The install basically corrupted the WHS.  It said some of the backups were deleted and other wierd error messages.  So, I did a Server reinstallation and recovered the WHS to a point so that it backed up the remaining clients (7) overnight and looked ok at that point.  So, I decided to install PP1 again and see what happened.  It installed okay (from the desktop this time, not RDP) and looked okay.  Next, I tried to install the new connector from my main workstation (Vista x86) and got the aforementioned error.  I tried it from the http://Server:55000/ URL and directly to the Home Connector Software folder.  All of the files listed herein were there.  But, got the above listed error.  I tried to do the same from three other clients and got the same error each time. 

     

    "Setup has detected that the Windows Home Server Connector or Admin Console is currently running.  Please close all Windows HomeServer windows and run setup again."

     

    OK, today I did a Server Reinstallation on the TestWHS to see if I could duplicate the error.  Installed PP1 again with no problem and installed the new connector from a client (Vista x86) via the http://TestServer:55000/ link.  It worked beautifully.  No problem whatsoever.

     

    So, there is something wrong in the main WHS OS that is causing this error,  Any ideas how I can discover and fix the error?  I don't think it is PP1 related directly except for the initial corruption the first time I installed PP1. The WHS appears to working okay so it has to be a minor discrepancy in the code somewhere.  Or, is there a way to replace the C: drive with the one from the Test WHS and keep all of my existing backups, etc?  Just wondering. Thanks.

    Ted

    Thursday, June 19, 2008 9:05 PM