locked
autoconfigure the outlook plugin and remove button from Outlook for unconfigured users RRS feed

  • Question

  • Hi,
    I installed CRM2011 for outlook on 2008R2SP1 in TS environment g Office2010 we do not have enough licenses to cover all available users so i will limit the us by preventing configuration of most users,

    they way i tried doing it is by running the following in a .BAT file per user :

    "D:\LOCALFOLDER\Client\ConfigWizard\Microsoft.Crm.Application.Outlook.ConfigWizard.exe" /q /i "D:\LOCALFOLDER\Client_Config.xml"

    the content of the xml file is:

    <Deployments>
      <Deployment>
        <DiscoveryUrl>http://SERVER-crm01.domain:5555</DiscoveryUrl>
        <Organizations>
          <Organization IsPrimary='true'>CRM</Organization>
        </Organizations>
      </Deployment>
    </Deployments>


    this doesn't work for regular users, only for admins, but i think i'll be able to over come it - must be missing some permission somewhere.
    the main issue though is that unconfigured users get a prompt to configure CRM for outlook as well as a button "Configure Microsoft Dynamics CRM for Outlook" appears on their addin tab on the ribbon.
    to stop the autoconfiguration i created a new reg key to  HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins called crmaddin.Addin and added as a dword :LoadBehavior=8
    (as detailed here http://msdn.microsoft.com/en-us/library/hh699743.aspx )

    I am still getting these prompts , how can i stop these ?

    the 2nd question, how do i remove the actual button from the outlook ribbon ?

    Thursday, October 10, 2013 9:58 PM

All replies

  • anything at all ? anyone?

    i read somewhere else that the plugin does not honor the loadbehavior registry key, is there another way of doing it ?

    Friday, October 11, 2013 10:20 AM
  • No one at all ?

    I would have thought its quite a common config issue for TS, any thoughts on other configurations approaches ?

    Tuesday, October 22, 2013 1:28 PM