How to change the Display Name attribute of the fullname field on the lead entity? RRS feed

  • Question

  • The default Display Name for the 'firstname' field on a lead in CRM 2011 is 'Name'

    Changing the display name is normally an easy thing to do but in this instance the field appears as if you can update the Display Name but once changed you cannot save the field. Try it.

    So given this, how can this display name be changed.

    I tried going through the back end, although not recommended (I did it on an org that I can dump at a moments notice) but also had no joy. Changed the 'Label' field on the [MetadataSchema].[LocalizedLabel] table but this didn't seem to change in any forms or views, although when viewing any design screen (form or view) it was changed. Yes, I did publish after the DB change.

    Why is this field not changable anyway?

    Friday, September 26, 2014 5:40 AM

All replies

  • Hi Troy,

    I've had a go at this and it seems to work OK for me on my system. I can't think of a reason why this would happen but, if it's any use, you could always try using the following piece of code to update the field name via JavaScript.

    Xrm.Page.ui.controls.get(fieldname).setLabel("New field name");
    If that line is run onLoad, it will update the field on the form whenever it's loaded.

    Friday, September 26, 2014 3:57 PM
  • Actually the defualt display name of 'fullname' is 'Name' and is the primary attribute of Lead Entity but you will still be able to update the display name of the primary attribute. 

    Please make sure that you you have not changed the dispaly name  on  form  because this overrides the display name on the entity.

    You have enough privileges(security roles)  to update lead entity.
    Check your systemuser record and make sure that you have full Read - write acces. 

    Hope this helps. Amar

    CRM Forum Guidance on how to Help Us Help You

    Friday, September 26, 2014 4:26 PM
  • changing display name of a field is a basic customisation. Please check your permission in the organization.

    try with either system customizer or system administrator role.


    Saturday, September 27, 2014 9:46 AM
  • I am a System Administrator and I know it is a basic operation, which is what I stated in my question. My issue is it is NOT possible in my setup, regardless of permissions.
    • Edited by Troy Adams Monday, September 29, 2014 10:32 PM
    Monday, September 29, 2014 10:32 PM
  • It's more the views that I am trying to change.

    I'm able to change the field, just not save.

    Monday, September 29, 2014 10:34 PM
  • hello Troy,

    full name format is specified in system settings. Not sure if you are looking for this.

    please post a picture for better understanding.



    Monday, September 29, 2014 11:19 PM
  • Hi Jithesh

    No it is not the format of the field. See the below screen shot. This is a screenshot of the edit field window for the 'fullname' field of the 'lead' entity, which in this case I have renamed to 'Service*' as can be seen highlighted.

    The 'Display Name' of the field appears as if it can be edited, and I can change this value, however when I then choose to save the record nothing happens. If I close the window I get a message usually reserved for times when you have made a change but not saved, something like 'your changes have not been saved ....blah blah'. Neither 'Save', 'Save and Close' nor 'Save and New' perform any action.

    I have tried in several environments and they are all the same. I am running 2011 with UR16.

    Tuesday, September 30, 2014 12:04 AM
  • Hello Troy,

     Sorry for not trusting you. It is a bug. May be you are the first person to identify it

    I tried to modify fullname of lead on CRM 4, worked fine.

    I tried to modify fullname of lead in CRM 2011, UR16, save does not happen, same as you reported.

    I tried to modify fullname of lead in CRM 2013, Sp1, worked fine.

    Please try see if the issue goes away after uninstalling rollup 16 - I haven't tried. Also you can advise your customer about the problem and inform the issue is not there in CRM2013.

    I would not advise you to do unsupported changes to fix this. You could raise a ticket with Microsoft to get a hot fix.



    Tuesday, September 30, 2014 12:50 AM
  • Thanks Jithesh for confirming the issue. I was starting to think it was just me.

    Once UR18 comes out we'll see if it fixes it. UR17 has a bug with deployment manager so we can't try that.

    Tuesday, September 30, 2014 1:44 AM