Help with changing the format in CRM RRS feed

  • Question

  • I am having trouble changing the format on a new field I have created.  When I try to change the format I only get 3 options, Check box, Two radial buttons, and list.  I am trying to change the format to date.  Below are the steps I have done so far but have hit a wall. 


    1)      Customize the correct folder I have created.

    2)      Selected form

    3)      Add new fields

    4)      Double clicked the new field then 4 tabs popped up.  Display, formatting, Name, Event

    5)      Went to display formatting.  This is where it offers me 3 options but I need it to be shown as a date


    Can you help me.

    Monday, April 11, 2011 9:31 PM

All replies

  • Hi

    the field that you are trying to convert to a Date Format is a "Two Options" type of field that can only be a checkbox, Two Radial Button or a list with two values - this is what is calleda Bit field. You cannot display this as a Date field niether can you store a date in it. For a Date field, you need to create a Date Type of field.

    Unfortunately, you cannot change the type of a field once you have created it in CRM. The only option is to delete it. For deleteing the field, make sure you remove it from the form, publish your form, fo to fields, select your field and then delete.

    Ok, so if you want to show a date, while you are still on form customization, click on "New Field" on the right hand panel. This will open a new field screen. Enter the name of the field, and go down to type - the type by default is "Single Line of Text". Change the value to "Date and Time", select theformat (Date Only" or "Date and Time" and save the field. Go back to your form customization screen. The new field will now be availabe on teh right hand panel. Select and place the field on the form. Save the form and clikc on "Publish".

    Open the entity and the date field should be visisble.

    Thanks and Regards



    • Proposed as answer by AniMandal Monday, April 11, 2011 10:28 PM
    Monday, April 11, 2011 10:28 PM