locked
CRM 2013 Rehome to SQL Cluster AO AG RRS feed

  • Question

  • Dear Friends,

    i am trying to rehome CRM 2013 Web Application Server to use our new 2 Node AO AG SQL Cluster and i am a bit confused.

    1- how do i use Listener and it's port in Reg Key ! i tried to add AG Listner to Reg Key but after that seems Deployment manager cannot find the SQL and logs the error "SQL Service Agent is not running on SQLAOAG.Domain.Com"

    my setup is like this :

    1 x WSFC

    2 X SQL 2012

    one of sql servers is servicing CRM Database on Instance CRM2013 and other is using Defaults

    i'm also aware i have to prepare other replica members by restoring databases with setting recovery mode to full and restore databases with same name and norecovery mode. i can see Cluster Fully Synced. but i don't know how do i use the listener to connect CRM 2013 !!

    2- after migration of SQL Service, what happens if i create a new organization ? does this replicate and will be created on other Replica members ?

    Kind Regards,

    Monday, October 6, 2014 5:36 AM

All replies

  • Monday, October 6, 2014 5:42 AM
  • thans Jithesh

    the problem is using the port ?

    where should i put the Port? can u give me a sample of MSConfig reg key ?


    Monday, October 6, 2014 5:46 AM
  • Hello,

     The port can be added with a comma along with the listener name.

    see the picture.

    Regards,

    Jithesh.K

    Monday, October 6, 2014 6:42 AM
  • Dear Jithesh,

    i have set MSconfigdb and is working properly since i open deployment administrator

    i tried to change the connection string for existing organizations like this 

    Update Organization set ConnectionString = 'Provider=SQLOLEDB;Data Source=CRMSQLAOAG01.Domain.net, 6114;Initial Catalog=OrganizationName_MSCRM;Integrated Security=SSPI;multisubnetfailover=true' where DatabaseName = 'AlmaFanavaran_MSCRM'

    sql query affected 1 row and checking table data seems it's ok

    but when i try to get properties of organization MMC pops an error like this and crashes:

    Type is not resolved for member 'Microsoft.Crm.CrmException,Microsoft.Crm.Core, Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.

    and Exception Stack Trace:

     at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
       at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
       at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
       at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)

    all other organizations which i didn't change yet are working properly

    also i have tried to add CRM Groups to secondary replica and set user mappings but the new login wizard is saying selected login also has a mapping on database.

    whats the issue?

    i have restored databases from master replica also.

    Kind

    Thursday, October 9, 2014 3:45 AM
  • A quick thing I remembered. got an error when tried to follow that post, then tried to change the string in script to

    Data Source=MAPSDEVAG1VN,10002;Initial Catalog=<Organisationname_MSCRM>;Integrated Security=True;Connect Timeout=60

    Remove the rest and it worked.

    Hope you have already created a asymmetric key also.

    Regards,

    Jithesh

    Thursday, October 9, 2014 4:19 AM
  • i cannot create Key :

    The certificate, asymmetric key, or private key file is not valid or does not exist; or you do not have permissions for it.

    what should i do now ?

    really documentation is broken about this :(
    Friday, October 10, 2014 8:55 PM
  • no mate, the document is fine. Please read the entire document peacefully and try again.

    let me know if you need any help.

    regards

    Jithesh

    Friday, October 10, 2014 10:32 PM
  • thanks for time you spend on my issue,

    The certificate, asymmetric key, or private key file is not valid or does not exist; or you do not have permissions for it.

    this is the issue 

    from where should i start configuring Asymmetric key ? is there any prerequirements? my CRM Web Application Setup is over HTTP also.

    Regards,

    Saturday, October 11, 2014 5:56 AM
  • not a problem mate, posting with intention to help, returning favors received :)

    Link - http://technet.microsoft.com/en-us/library/jj822357.aspx

    section - Please make sure you have completed all the steps in the above link. I recon this is the last step, please double check. The file may not be in the same location based on your installtion. So please search on the SQL server.


    Saturday, October 11, 2014 8:30 AM
  • Hello Guys, 

    I have the same issue for "The certificate, asymmetric key, or private key file is not valid or does not exist; or you do not have permissions for it.". I followed all the above configuration steps, but I got the error in the following step.

    Create the asymmetric key for the MSCRMSqlClrLogin SQL Login


    Your help is really appreciated. 

    Thanks.

    Monday, December 7, 2015 10:04 AM
  • Hi,

    please make sure that you have created asymmetric key using the dll specified in the link.

    regards,

    Jithesh

    Monday, December 7, 2015 9:20 PM
  • Dear mohamed,

    if i remember correctly i could not fix it using a unc path and just moved the DLL and executed required steps using a local path.

    Tuesday, December 8, 2015 6:47 AM