locked
Setting up Router Hangs RRS feed

  • Question

  • I previously had Remote Access setup on my whs 2011 machine. I had some non related issues that affected DHCP on my router (Actiontec M1424WR) that have since been resolved. Now, I am unable to setup remote access.

    I go to "Server Settings -> Remote Web Access -> Turn On button" I get the Getting Started window that has a check box at the bottom for bypassing router setup. Whether I check this box or not, the next step hangs at "Setting up Router." I've let it sit for almost 1/2 hour with no response, just stuck on "Setting up Router." I do get the "Setting up web site" and "Setting up certificate" responses prior to this.

     

    1. Is there any way to force this step to complete/fail?
    2. Why is WHS trying to setup the router if I've check the box to disable this step? I noticed that when I got RA working before but didn't worry since it completed the process. 

    Any help would be greatly appreciated.

    update: I have verified ports 80 and 443 are open on the router. I've also rebooted both the server and the router.

    Tony


    • Edited by mb2k11 Friday, October 7, 2011 1:53 PM
    Friday, October 7, 2011 1:43 PM

Answers

  • I had the same problem. Killing the Dashboard didn't work for me. I found a solution that worked for me: 
     
    Remote web access has been working fine before. Yesterday WHS told me that it couldn't get domain ip updated (xxx.homeserver.com). Repair didn't work. Then I turned remote access off and after that setting up hangs in "setting up router" even when I checked the box I 'set up router manually'.
     
    My solution involves editing the registry so usual backup caveats apply. Additionally it took a few goes round some wizards so this isn't a completely accurate account of what I did but I hope you get the idea. To break the wizard's insistence on trying to set up my router, I edited HKLM\Software \Microsoft \Windows Server \Domain Manager \ActiveConfiguration\Manual Mode Enabled from False to True. I thought that would stop RWA trying to configure the router but actually I think the effect was to make the wizard think it didn't know the domain details (although I did leave them in the regisitry).
     
    I ran the set-up wizard again (checked the box I want to set up my router manually) and the wizard now skipped router configuration. I suspect at that point the wizard may have wiped my router's port forwarding because I later found they had disappeared (it was previously configured fine and was not on the face of it the cause of RWA's initial problems). I set them back up manually!
     
    I had password problems trying to reuse my xxx.homeserver.com domain because it was first registered using a old password which I have forgotten. (I had to change password a few days ago but based on other forums, I don't think this was the root cause of RWA's problems - I believe that homeserver domain RWA access doesn't track Microsoft Live account password changes so you need the original registered MS Live username/password if you need to set RWA up again).
     
    Since this password problem prevented me from reconnect to my existing xxx.homeserver.com domain, I selected to register a new domain. The wizard then allowed me to log in to my Live account with my new password. Once in, I could choose an existing registered domain so I could keep my original domain.
     
    One other point from a second go around this loop as I tried to figure out what had gone on: When HKLM\Software \Microsoft \Windows Server \Domain Manager \Active Configuration Manual Mode Enabled is changed from False to True, RWA Domain name is lost. I did Setup, Next to change domain name and 'Release the current domain name from this server'. Once released I was able to re-select my original domain.
     
    Hope this helps someone.
    • Marked as answer by Olaf Engelke Tuesday, June 10, 2014 7:37 AM
    Tuesday, June 10, 2014 6:05 AM
  • I previously had Remote Access setup on my whs 2011 machine. I had some non related issues that affected DHCP on my router (Actiontec M1424WR) that have since been resolved. Now, I am unable to setup remote access.

    I go to "Server Settings -> Remote Web Access -> Turn On button" I get the Getting Started window that has a check box at the bottom for bypassing router setup. Whether I check this box or not, the next step hangs at "Setting up Router." I've let it sit for almost 1/2 hour with no response, just stuck on "Setting up Router." I do get the "Setting up web site" and "Setting up certificate" responses prior to this.

     

    1. Is there any way to force this step to complete/fail?
    2. Why is WHS trying to setup the router if I've check the box to disable this step? I noticed that when I got RA working before but didn't worry since it completed the process. 

    Any help would be greatly appreciated.

    update: I have verified ports 80 and 443 are open on the router. I've also rebooted both the server and the router.

    Tony


    I had this problem too, I would start the RA wizard and it would continue indefinitely at the stage where it was "Setting up the Router" even though I had unchecked the box to skip the Router Setup.  After trying many things (mostly to do with the router itself) it seems like it may have actually been a third party add-in that I had installed that was causing the problem.  I uninstalled both Cloudberry backup and the Advanced Administrator Console, then retried the Wizard and it worked without a problem. I had already disabled uPnP on the router and port-forwarded 80, 443 and 4125 for remote access to the Server IP.  Everything went through without a problem after that.  So I wold uninstall any 3rd party add-ins that might possibly be using or interfering with outside access and try the wizard again.  It worked for me.

    Richard

    • Marked as answer by Olaf Engelke Monday, August 25, 2014 12:43 PM
    Sunday, August 10, 2014 5:17 AM

All replies

  • I have the same problem.  Did you find a solution
    Sunday, October 23, 2011 2:10 AM
  • Same problem here as well - oddly it was working last week and now it stopped. All ports are open on my end as well.
    Thursday, October 27, 2011 1:00 PM
  • Did you find any solution, I'm having the exact same issue today. Even if I check the "skip router setup" box, it hangs on "setting up the router".

     

    Wednesday, November 2, 2011 9:38 PM
  • Have you tried pulling the power plug out of the router for 30 seconds and then re-powering it ?.

    If the router has got itself confused a soft reboot via the web interface will not always clear up the issue.

    Dave


    The Frog on the Lilypad at Home
    Friday, November 4, 2011 2:51 AM
  • Well isn't this interesting.

    I have the same problem. The system was working until yesterday (I had full remote access) and now the setup hangs and all remote access is gone.

    I did reset the router and the cable box (multiple times).

    I have also "skipped the router setup" and manually configured the system ... with no luck. The router UPnP had worked up until last night.

    Any help would be appreciated ... As an off the wall thought ... has the "Windows Live" end malfunctioned and WHS 2011 can;t communicate with the site?

     


    Aussie
    Wednesday, November 9, 2011 9:25 PM
  • ... has the "Windows Live" end malfunctioned and WHS 2011 can;t communicate with the site?
    This can happen. However, have you rebooted your broadband modem and router yet? Sometimes a power failure can leave everything in an unknown (and undesired) state, and having UPnP stop working is pretty suggestive.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 9, 2011 10:23 PM
  • Ken ... thanks for the reponse ... It's good to know that you aer out there monitoring us mere mortals :-)

    I am going to assume that you are addressing the posters before me ... as I indicated that "I did reset the router and the cable box (multiple times)." Or am I missing something?

    Anyway ... I am going to try to get it to work again tonight ...


    Aussie
    Thursday, November 10, 2011 12:30 AM
  • All,

    I am back!!! Well actually my server is back ... I didn't go anywhere because I am too busy fixing my computers ... :-|

    2.5 hours of tearing apart hardware and software yesterday and another hour today rechecking all the settings (in case I screwed up late last night) ... Repowered the server, checked the IP address was "static" where it was supposed to be, fired up the router setup wizard ... said a prayer to the computer gods ... and some minutes later ... the wizard succeeded.

    The system configuration is the same as it was yesterday when it crashed! Nothing changed ...

    So I am budding out ... Good luck to you all.

    In case anyone needs any direction on setting up routers and WHSs I did run across some useful sites as shown here (noting that I am running the router "static" IP address, and the UPnP router setup) ...

    http://social.technet.microsoft.com/wiki/contents/articles/windows-home-server-router-setup.aspx 

    Reserve and IP address for the WHS, UPnP Router Configuration and Manual Port Forwarding

    http://wiki.wegotserved.com/index.php?title=Set_up_Static_IP_for_Windows_Home_Server Static IP setup for WHS Computer

    I hope this helps and as I said ... good luck!

     


    Aussie
    Thursday, November 10, 2011 1:26 AM
  • I've noticed when setting up of router hangs with the WHS 2011 dashboard, I close the dashboard app, do a CTRL+ALT+DEL and go to the Process tab and end the task of dashboard.exe.  sometimes it appears the app doesn't close even after you X out of the app window.  This may help.
    • Proposed as answer by rekd0514 Monday, November 28, 2011 5:12 AM
    Thursday, November 10, 2011 2:33 AM
  • I've noticed when setting up of router hangs with the WHS 2011 dashboard, I close the dashboard app, do a CTRL+ALT+DEL and go to the Process tab and end the task of dashboard.exe.  sometimes it appears the app doesn't close even after you X out of the app window.  This may help.
    I was having this exact problem and this oddly enough worked for me. Even after restarting the server!?! This is really odd, but I'm glad I got it figured out. :) Thank you!
    Monday, November 28, 2011 5:14 AM
  • Just as an FYI, this issue seems to have resolved itself after a few days. I did try the following:

     

    Reboot/reset router (Actiontec mi424wr gen)

    Rebooted the server several times.

    Turned RA on and off and on and off several times.

    Went into the router, removed all port forwarding related to WHS, then reopened appropriate ports.

     

    Note that I had this exact same problem a few times with WHS v1 (different router) and the fix was the same: problem went away after a few days. My issue is that the server OS should at least tell me what the issue is and timeout rather than just hang. Very frustrating.

     

    Sorry for the late followup

    Tony

    Friday, December 9, 2011 1:43 AM
  • I am having the same problem.  Whether I choose "dynamic" (UPnP) or "manual" ("Skip router configuration"), the wizard hangs on "Setting Up Router."

    I have rebooted and power cycled *everything*.  The problem has persisted for several days.  This is completely maddening, as Remote Access was the ONLY reason I configured this box with WHS 2011 versus Win7.

    Has anyone found any clues on this?


    Dan Holme, Intelliem
    Sunday, December 11, 2011 7:46 PM
  • I'm no expert, but I honestly believe there's a bug with the "skip router" option. It seems like whether you choose to skip it or not, the wizard will still try to configure it. I feel your pain. Shortly after I posted my last message I ran into problems again. This time, the issue was that accessing the website gave me a certificate error. The fix was weird. My login/password was not being accepted when releasing then renewing the domain address. I wound up having to ask for a new web address and choose the one I used to use.

     

    Dan, in my experiences with this problematic wizard I've tried the following:

    • Delete and recreate port forwarding for 80 and 443 in my router
    • Reboot router and server.
    • Release then renew web address.(actually release then request a new one using your original address)
    • Remember that it takes a few minutes when requesting a new addy so give it at least 1/2 hr.
    • Verify RA is setup correctly by just going to "server settings", click remote access and wait for validation.

    Hope you get it resolved.

     

    Tony

    Sunday, December 11, 2011 10:18 PM
  • Dan ... I concur that this problem is frustrating. I would go with mb2k's solution. Then check my post from Nov 10. It has some links to sites that will take you thru manual setup of the router. If you manually reset the router, clear all the settings and try again. Make sure the router has PnP set.

    In the end though ... after I had a problem similar to yours ... I reset/restarted everyting and it came good. So try sleeping on it ... and attack it with a clear head. Maybe you ahve something set incorrectly ... maybe something process has hung. Maybe you'll be lucky like I was ... good luck.


    Aussie
    Monday, December 12, 2011 1:11 AM
  • I've noticed when setting up of router hangs with the WHS 2011 dashboard, I close the dashboard app, do a CTRL+ALT+DEL and go to the Process tab and end the task of dashboard.exe.  sometimes it appears the app doesn't close even after you X out of the app window.  This may help.
    Thanks!!! ... Never would have thought of this ... worked for me!
    Sunday, April 1, 2012 11:58 PM
  • I just ran into this issue today, and when I got to this step and launched task manager I did not see dashboard.exe running so I thought this must not be the problem and kept troubleshooting.  Turns out, after launching the dashboard, then killing dashboard.exe, it started working.  So don't skip this step even if dashboard.exe isn't running!
    Friday, March 1, 2013 11:43 AM
  • Hi, I have done ALL of the steps outlined in each and every one of the suggested in these threads and still "setting up Router" hangs for hours.  It worked one time then I turned off RWA and now can't get it to start.  Oddly, I pulled out my old identical HPx495 server with WHS v.1 on it, turned on remote web access and it worked PERFECTLY!  There is OBVISOULY a BUG in the WHS 2011 software that lets this hang with no apparent error, option, or solution. 

    Is there ANY remaining support at MS for this product purchased with a valid license less than 30days ago?  Any one try contacting MS support directly?  Any other solutions?

    Linksys WRT610n with latest firmware,

    HP ex495 with WHS 2011, 4gb RAM, E8500 CPU'

    Win 8.1 Pro on one pc and Win 7 Pro on other

    Direct connections to Router from server and PCs

    thanks


    • Edited by kassey22000 Wednesday, March 5, 2014 12:59 AM
    Tuesday, March 4, 2014 8:22 PM
  • All,

    My WHS 2011 was working perfectly up to about a week ago. I applied software updates and it has not been able to set up the router since ... I am thinking updates ... I don't have time to pull them out at present though.

    Are your machines set up to auto-update ... is that the problem?

    Orrrr ... I changed my Windows Live password (due to the "Target" hack) ... and maybe that is interfering so I might try ... Going into the WHS remote access and create a NEW Live ID and create a microsoft xxxx.homeserver.com DNS.  Do not use anything else for now.  Verify the server address using the network or ipconfig /all and make sure that is the IP that you are forwarding too. 


    Aussie



    • Edited by Aussie_1 Tuesday, March 4, 2014 10:07 PM typo
    Tuesday, March 4, 2014 9:56 PM
  • Funny that, have the exact same problem (wizard hanging at "Setting up the router...")  since early next week without having changed anything. I have forwarded ports 80 & 443 (even though I did not need to in the past) and can confirm that I can contact my Server from outside my network but it will show a WHS 2011 website saying Remote Web Access is turned off. No clue how to debug/diagnose the issue at hand here but I suspect one service or another is not running. I can get an HTTP 503 error if I connect to https://myservername.homeserver.com/remote.
    Wednesday, March 5, 2014 12:20 AM
  • OK, I left the wizard running at home, it is stuck at "Setting up the router...".

    From work, outside the LAN/WAN therefore, I get the following:

    - If I browse to https://myservername.homeserver.com -> WHS saying Remote Web Access is turned off

    - If I browse to https://myservername.homeserver.com/remote -> I get to the WHS website!

    I can then also log on to the Server Dashboard (which closes the session at home). All add-ins work etc. When I go to Server Settings -> Remote Web Access, it reports as Unavailanle and I could press the Turn on button which then again hangs at "Setting up the router...". The bar is working, so connection stays alive.

    If I then cancel the wizard, close the dashboard and try to logon again, the /remote way does not work anymore and I get an HTTP 503 Service Unavailable message.

    I think it is save to say that this can not have anything to do with the router or the way WHS communicates with it but rather that there is some sort of issue with the script or whatever it is the wizard runs.

    Am I *really* the only one having this issue?

    • Edited by Umfriend Thursday, March 6, 2014 8:37 AM
    Thursday, March 6, 2014 8:34 AM
  • No you are not the only one! ... My access shut down two weeks ago on a WHS 2011 system that has been in use well over a year with no problems. No known changes occurred to the system except for windows updates (maybe Windows Live password?).

    1) I tried your "trick" to get to remote access but my WHS Remote Web Access window has now cleared my domain name ... so I think that the domain has vaporized ...

    2) I tried to work a solution for Windows Live password changing by could not find one.

    3) I manually set up the router forwarding ... but there was no change  in operation.

    4) I also started the Task Manager and went to the Process tab and end the task of dashboard.exe. Then restarted the dashboard with no change in operation.

    I don't have as much time as I used to ... so debug is a problem ...

    Update 140309 ... OK ... I said "nothing changed" ... but we all know something changed ... well I meditated on that for a while and I am reasonably sure I did a router update to fix a back-door problem ... My access may have gone down then and I didn't realize it ... My current debug path (no time today) is to reset the router to default and try again ...


    Aussie



    • Edited by Aussie_1 Monday, March 10, 2014 12:53 AM Updated debug path
    Saturday, March 8, 2014 3:34 PM
  • Can you still do a ping to yourservername.homeserver.com and does it give your IP-address? If "yes" to both then the domain name is still active and forwarding to you. I have seen the wizard not mentioning the domain name but then after starting it and cancelling it (due to it hanging a while on setting up the router), it would in fact show the domain name...

    Wrt to point 4, I read that a while ago but I did not understand how killing dashboard.exe could have anything to do with it. Only since a few days (dumbwit I can be) do I get that one should kill dashboard.exe _while_ the RWA wizard is running and hanging on "Setting up the router". THis is because pressing cancel will undo the script, including activating (I assume) IIS and/or the website.

    So, with me it is running with the following caveats:
    1. Server Settings/RWA Wizard says RWA is Unavailable; and,
    2. I can only access the website if I add the /remote bit to the address.

    Hope this helps you a bit. *So* glad I am not alone in this ;-)

    Sunday, March 9, 2014 5:02 PM
  • See my update two posts back ... Update 140309 ... I haven't solved the problem yet ... but I have a new debug path!

    Aussie

    Monday, March 10, 2014 12:53 AM
  • I hope it works for you. With me, I really have not changed anything *and* I had reset the router twice to see if that would help, which it didn't. Please keep us posted on your progress and I am really interested to learn whether your domain is still ping-able / existing. If it is, I would advise to try the kill_dashboard_while_setting_up_router option. I am now firmly believing that if the wizards hangs there (and not giving any errors about the router, which it *can* do if something is wrong with the router) that there is a scripting issue at the Server, not with the router.
    Monday, March 10, 2014 9:08 AM
  • This is so frustrating!  I upgraded to WHS 2011 because of the supposed better implementation of Remote Web Access. 

    Killing the Dashboard either in RDP mode or on the client does not work for me. 

    Setting up Router hangs whether I skip the router set up option or not. 

    Hangs whether I'm using win 8.1 client, or win 7, or RDP on server. 

    Hangs whether I reset my router to factory or have all the latest firmware installed. 

    Hangs if I do all the router settings manually or not.

    WHS v.1 RWA with same exact router/PCs WORKS PERFECTLY!

    Is there anyone at MS we can escalate this to?  This IS a program BUG in the set-up wizard and I can't find any way to bypass it. 

    thanks

    Monday, March 10, 2014 6:56 PM
  • One thing you may need to try is, at the Server either live or through RDP, kill the dashboard while running the RWA wizard _and_ also kill the dashboard.exe process. This one stays alive even after killing the application.

    Also, while the wizard is stuck at setting up the router, prior to killing anything, try from a client:
    - https://servername/remote (So without any www or homeserver.com etc)
    - https://yourservername.homeserver.com/remote (that is assuming you have been able to set up a domain name earlier one way or the other).

    Other than that, I share your frustration. I was given this link https://connect.microsoft.com/SBS/ a while ago but it appears dead right now.


    • Edited by Umfriend Tuesday, March 11, 2014 8:27 AM
    Tuesday, March 11, 2014 8:20 AM
  • Oh my gosh!!! I got bored last night and remote logged in to my server and hit the "Turn on" button ... and the dang thing ran and set up the router and the Remote Access. I had changed the password for Live (some time ago) and it choked on that ... but even after not accepting the password the remote access went operational and the myserver.homeserver.com is operational ... No changes were made to anything since yesterday!!!

    I don't get it! We'll see if it stays up ...


    Aussie

    Tuesday, March 11, 2014 1:59 PM
  • What a very fickle wizard indeed!  Only 23hrs ago I RDP'd to the server and once again just like the 50 other times I ran the RWA wizard and it got stuck on "setting up the Router".  NOTHING has changed in that 23hrs.  After getting Aussie's reply to this forum, I reluctantly tried it again and Shazam! it decided to UNSTICK and got as far as throwing up 2 router error messages. 1. that UPNP was turned off (FALSE), 2. ports 80/443 may be blocked (also false). So I selected manual router set-up, tried the REPAIR button and got all the way through.  Tested the HTTPS//xxx.homeserver.com and got in no problem. 

    I checked the windows update history and other than Widows Defender update, no hotfixes or updates to the server software. 

    I have NO idea why this worked and have no idea if it will stay working/stable, but my fingers are crossed as the $80 LOGMEIN fee is coming up and I really would rather use the RWA features of my WHS. 

    Thanks again to all on this forum who have contributed and I will report back if anything changes.  Microsoft still needs to clearly address this mystery. 

    Happy serving!

    Tuesday, March 11, 2014 6:49 PM
  • So ... Maybe we get a bit more confirmation ... But are we going to land on an external problem? Microsoft?

    Aussie

    Tuesday, March 11, 2014 10:15 PM
  • I am still up and running ...

    Aussie

    Wednesday, March 12, 2014 10:35 PM
  • So ... Maybe we get a bit more confirmation ... But are we going to land on an external problem? Microsoft?

    I'm pretty sure unfortunately, that Microsoft doesn't care a lot any more with the Windows Home Server team disbanded and the product in the removal process from the market.

    Best greetings from Germany
    Olaf

    Thursday, March 13, 2014 3:11 PM
  • Dang! You lucky guys...

    WIth me the wizard still hangs at setting up the router. I am now thinking that it may be trying to raise an error but the actual window may not pop-up. Have seen that with VBA/Office products in the past. Anyway, the "Kill Dashboard (app + service) While Setting Up Router" _feature_ works for me if u connect to /remote. But it remains extremely annoying.

    • Proposed as answer by Chuck Chunder Tuesday, June 10, 2014 6:01 AM
    • Unproposed as answer by Chuck Chunder Tuesday, June 10, 2014 6:01 AM
    Friday, March 14, 2014 7:08 AM
  • I had the same problem. Killing the Dashboard didn't work for me. I found a solution that worked for me: 
     
    Remote web access has been working fine before. Yesterday WHS told me that it couldn't get domain ip updated (xxx.homeserver.com). Repair didn't work. Then I turned remote access off and after that setting up hangs in "setting up router" even when I checked the box I 'set up router manually'.
     
    My solution involves editing the registry so usual backup caveats apply. Additionally it took a few goes round some wizards so this isn't a completely accurate account of what I did but I hope you get the idea. To break the wizard's insistence on trying to set up my router, I edited HKLM\Software \Microsoft \Windows Server \Domain Manager \ActiveConfiguration\Manual Mode Enabled from False to True. I thought that would stop RWA trying to configure the router but actually I think the effect was to make the wizard think it didn't know the domain details (although I did leave them in the regisitry).
     
    I ran the set-up wizard again (checked the box I want to set up my router manually) and the wizard now skipped router configuration. I suspect at that point the wizard may have wiped my router's port forwarding because I later found they had disappeared (it was previously configured fine and was not on the face of it the cause of RWA's initial problems). I set them back up manually!
     
    I had password problems trying to reuse my xxx.homeserver.com domain because it was first registered using a old password which I have forgotten. (I had to change password a few days ago but based on other forums, I don't think this was the root cause of RWA's problems - I believe that homeserver domain RWA access doesn't track Microsoft Live account password changes so you need the original registered MS Live username/password if you need to set RWA up again).
     
    Since this password problem prevented me from reconnect to my existing xxx.homeserver.com domain, I selected to register a new domain. The wizard then allowed me to log in to my Live account with my new password. Once in, I could choose an existing registered domain so I could keep my original domain.
     
    One other point from a second go around this loop as I tried to figure out what had gone on: When HKLM\Software \Microsoft \Windows Server \Domain Manager \Active Configuration Manual Mode Enabled is changed from False to True, RWA Domain name is lost. I did Setup, Next to change domain name and 'Release the current domain name from this server'. Once released I was able to re-select my original domain.
     
    Hope this helps someone.
    • Marked as answer by Olaf Engelke Tuesday, June 10, 2014 7:37 AM
    Tuesday, June 10, 2014 6:05 AM
  • I previously had Remote Access setup on my whs 2011 machine. I had some non related issues that affected DHCP on my router (Actiontec M1424WR) that have since been resolved. Now, I am unable to setup remote access.

    I go to "Server Settings -> Remote Web Access -> Turn On button" I get the Getting Started window that has a check box at the bottom for bypassing router setup. Whether I check this box or not, the next step hangs at "Setting up Router." I've let it sit for almost 1/2 hour with no response, just stuck on "Setting up Router." I do get the "Setting up web site" and "Setting up certificate" responses prior to this.

     

    1. Is there any way to force this step to complete/fail?
    2. Why is WHS trying to setup the router if I've check the box to disable this step? I noticed that when I got RA working before but didn't worry since it completed the process. 

    Any help would be greatly appreciated.

    update: I have verified ports 80 and 443 are open on the router. I've also rebooted both the server and the router.

    Tony


    I had this problem too, I would start the RA wizard and it would continue indefinitely at the stage where it was "Setting up the Router" even though I had unchecked the box to skip the Router Setup.  After trying many things (mostly to do with the router itself) it seems like it may have actually been a third party add-in that I had installed that was causing the problem.  I uninstalled both Cloudberry backup and the Advanced Administrator Console, then retried the Wizard and it worked without a problem. I had already disabled uPnP on the router and port-forwarded 80, 443 and 4125 for remote access to the Server IP.  Everything went through without a problem after that.  So I wold uninstall any 3rd party add-ins that might possibly be using or interfering with outside access and try the wizard again.  It worked for me.

    Richard

    • Marked as answer by Olaf Engelke Monday, August 25, 2014 12:43 PM
    Sunday, August 10, 2014 5:17 AM
  • I previously had Remote Access setup on my whs 2011 machine. I had some non related issues that affected DHCP on my router (Actiontec M1424WR) that have since been resolved. Now, I am unable to setup remote access.

    I go to "Server Settings -> Remote Web Access -> Turn On button" I get the Getting Started window that has a check box at the bottom for bypassing router setup. Whether I check this box or not, the next step hangs at "Setting up Router." I've let it sit for almost 1/2 hour with no response, just stuck on "Setting up Router." I do get the "Setting up web site" and "Setting up certificate" responses prior to this.

     

    1. Is there any way to force this step to complete/fail?
    2. Why is WHS trying to setup the router if I've check the box to disable this step? I noticed that when I got RA working before but didn't worry since it completed the process. 

    Any help would be greatly appreciated.

    update: I have verified ports 80 and 443 are open on the router. I've also rebooted both the server and the router.

    Tony


    I had this problem too, I would start the RA wizard and it would continue indefinitely at the stage where it was "Setting up the Router" even though I had unchecked the box to skip the Router Setup.  After trying many things (mostly to do with the router itself) it seems like it may have actually been a third party add-in that I had installed that was causing the problem.  I uninstalled both Cloudberry backup and the Advanced Administrator Console, then retried the Wizard and it worked without a problem. I had already disabled uPnP on the router and port-forwarded 80, 443 and 4125 for remote access to the Server IP.  Everything went through without a problem after that.  So I wold uninstall any 3rd party add-ins that might possibly be using or interfering with outside access and try the wizard again.  It worked for me.

    Richard

    Yup, the moment I uninstalled Advanced Administrator Console, closed and reopened the Dashboard, it got past the setting up router on the first try.
    Wednesday, September 17, 2014 11:11 PM
  • Wow ... It still amazes me that WHS hangs ... although MS isn't working on it anymore.

    I changed ISPs and modems recently and sure 'nuff ... the home server webpage and remote access went away. I tried the usual steps with the usual problems and no results. So I did my usual thing ... walked away from it (see some of my other posts). Three days later I was bored at work and decided to dial in my home server address ... sure 'nuff ... it was working again ... I have no idea what changes.

    All I can say is good luck ...


    Aussie

    Thursday, September 18, 2014 12:01 AM
  • This worked for me too. Used RDP to connect to the server and good old regedit led the way.
    Friday, November 28, 2014 5:34 PM