Update migration that preserves GUID? RRS feed

  • Question

  • The basic question I have is:

    Is there an "update" migration method in CRM so that GUIDs are preserved?

    I have migrated Contacts, then Companies (who link to contacts) and then Conferences (who link to contacts and companies).

    Now, there was a mistake with a lot of the data from the original Contacts migration.  Basically the only correct info is the name of the contact, whereas all the email, phone number, etc information has been jumbled up.

    Now, I have the correct CSV file to migrate, with the CRM GUID as an export.  I want to import back to the Contact entity using the GUID to "overwrite" or "update" the current fields that are missing or incorrect.

    When I try to do this I gives me a "Generic SQL Error" (very useful!).  I figure CRM doesn't like the fact the GUID is included because when I drop that from the migration it is okay... except for the fact that CRM creates a duplicate which I want to avoid.  I need to preserve the GUID so that all the links made by the thousands of migrated Companies and Conferences won't be broken.

    Any suggestions?  This comes short of my having to start migrating all over again, which I want to avoid.  We spent many days hand importing a lot of Conference data because we don't have that info at had in a useful spreadsheet.

    Thanks in advance!

    Using CRM 4.0 by the way.
    Sunday, November 23, 2008 7:16 PM

All replies

  • Yes, you should be able to update records and not create new ones.  The best way to make this happen is to create an Advanced Find thta includes all the fields you have in your file that you are trying to import or match.  Using the Excel export feature after you run the Advanced Find, copy the header row of the Advanced Find export and use it for your import file header.   This will ensure that CRM creates the data map correctly because it will be able to match all the fields.


    Test 2 or 3 records and see how it goes. 


    You might also want to check out this post as it might help with this effort.  I haven't tried it yet but I believe others have had succes.




    Monday, November 24, 2008 12:43 PM
  • Thanks.  I have download the products (including the SDK) and put in the credentials, and receive this error before it automatically closes:

    "Application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission, contact your system administrator, or use the Microsoft .NET Framework Configuration tool."

    No idea where to go from here!
    Monday, November 24, 2008 8:38 PM
  • I would post an issue at this link.  Chances are they will respond and let you know what you need to do differently.  I assume you have full Admin rights on the server.




    You can also try using the Import Tool in CRM based on the suggestions about Advanced Find from the previous post.




    Monday, November 24, 2008 9:11 PM
  • Thanks again.  Posted on that forum!  Yes I do have admin priviledges.

    I've tried importing a couple of records and linking the GUIDs using the CRM Migration tool but I get a "Generic SQL Error".  If I don't include the GUID in the migration the problem goes away, except for of course it migrated a duplicate!
    Monday, November 24, 2008 9:35 PM
  • Try the Import rather than the Data Migration Manager.  You might want to try mapping to the Full Name rather than the guid in the Import Tool

    Monday, November 24, 2008 9:59 PM
  • Yep tried mapping using the FullName and all it did was create a new entry with the same name!

    I think the best way to do this right now is export, and do VLOOKUPs on Excel to preserve links between entities.

    Although Excel crashes if I export every single column so I'll also need to do that in parts!

    Hopefully the people from Codeplex will get back to me soon.  That sounds like the a great solution!
    Tuesday, November 25, 2008 4:11 PM
  • This should work with the Import tool.  You might want to consider opening a ticket with Microsoft and let them know that you are not able to update Lead records using the Import Tool and with the Leadid value in the file.  I would be interested to know the result.




    Tuesday, November 25, 2008 10:20 PM
  • Ticket?

    Mind you, the field in the Contact entity that I'm trying to update that refers to a Full Name is called FullName2 (suspicious?).  There is no FullName column/field.
    Tuesday, November 25, 2008 11:13 PM
  • Hi,


    My apologies, the Import Tool does not expose the Full Name field, please disregard. 


    For the Import Tool in CRM, the Guid should work for an update.  Please see this post for one reference.  



    The key to getting the Import to work properly is for CRM to automatically generate the data map.  If your file is formatted correctly, CRM will autogenerate the map.  The column headers in your file have to match CRM display names exactly thus my reason for suggesting the export of the column headers from Advanced Find and use copy / paste to replace your header row in your csv file.


    If the Import tool is not working for updating a record as expected, I would open a support ticket with Microsoft to identify why it is not working as expected.  Support can fully troubleshoot the issue.


    Wednesday, November 26, 2008 2:40 AM
  • Thanks, I'll follow those instructions and let you know....
    Wednesday, November 26, 2008 7:42 PM
  • I did a little test and it worked!!  Thanks!  Auto mapping worked like a charm.  I haven't tried this yet, but I hope that all the reference linking such as Acconts, etc are also mapped through (considering this can't be done manually using this tool).  I'll try that out tomorrow.
    Thursday, November 27, 2008 12:10 AM
  • No good Sad

    I've attempted a mass update migration for Organisations (Accounts) and I don't see any results.  There are basically two new fields that I'm trying to populate: A pick list, and a lookup table.  The lookup table is for a list of Countries (the Countries entity has information such as language, currency, etc but only the country name appears in the Organiations form).

    I checked the System Jobs list and it was imported successfully.  Should I be waiting a while for Matchcode Updates? So far I've randomly looked at Organisation entries and none seem to have been updated.

    Sunday, November 30, 2008 8:39 PM

    When you update Accounts, it will not update the fields on the Countries form.  You need to do an import to Countries if that is an entity to update fields on the Countries form.  You will need to export the Countries records and obtain the Guid or Id from the Countries and use that in a file to update Countries.


    It sounds like the Account entity updated correctly if it is now showing the name of the Country in the Account lookup field for Countries.

    Monday, December 1, 2008 12:13 AM
  • Hey Donna

    I don't think I explained myself correctly!

    No fields were updated after the "Successful" migration.

    I am only updating the Accounts form (which on our system is called Organisations).

    When I did a test update migration, I tried updating only text fields which WORKED.

    For this update migration though, I needed to update two fields:

    1.  One called "Profile" which is a pick list.
    2.  One called "Country" which is a lookup reference table to an entity called Country.

    I assumed that if the text for the "Pick List" and the text for the "Country" are exactly as they are in their respective pick list items and Country entity (after all, when I export from Organisations, that is what appears, not their IDs), the CRM Import tool would be clever enough to make the connection and update (like the CRM Migration Wizard does).

    I will try to replace the Countries with their GUIDs and the picklist items with their pick list IDs.  Although this is going to get quite cumbersome when I need to do an update for Contacts, which involve a lot more pick list and lookup table referencing!


    Monday, December 1, 2008 9:06 AM
  • Hi Nel,


    thank you for the clarification.  You will most likely need the guid's for the Countries but not the picklist values.  The picklist values should update correctly if you have the exact display name used.  You can find the values of the picklist in the attributes for Organisations entity. 


    For example, if your picklist available values are Red, green, Blue then the values in your import file should be Red, green, Blue with no spaces or other characters in the field.


    You may need to create a data map for use when importing picklist values so you can map the attributes correctly.  CRM may not be able to automatically do it.  I would create a test file with 2 records and try the Import using Automatic.  If that does not update the picklist then create a datamap and map the attribute values in the picklist.


    Importing data frequently requires an interative process so your patience is appreciated.  Once everything is mapped correctly everything will go in quickly.



    Monday, December 1, 2008 4:12 PM
  • Hi Donna,

    Thanks for having the patience with me!

    Well I tried putting in the GUIDs for companies and it still didn't import a single item (same story with the pick lists, I made sure they were all corresponding to an actual pick list item).

    I did a small test and made a custom map in the CRM import tool and I got the same results.

    I would try using the CRM Migration Wizard, but I'm guessing the same thing will happen where a duplicate will occur (since the CRM wizard doesn't allow for GUID mapping).

    I'm a point where I'm starting to think that the best solution (or the only one?) is to export everything and compeltely erase CRM entity data (how do you do that?) and then re-import everything, somehow linking the old GUIDs with the new ones to preseve all the relationships.

    Monday, December 1, 2008 8:47 PM
  • There is possibly something we are missing that is fairly easily resolved.  It is easy to overlook things using electronic communication.  The update should work with the Import Tool.  At this point, I would open a support ticket with Microsoft and let them know that records are not updating as expected when using the Import Tool.  I am sure they will be able to resolve the issue and get you moving forward. I don't recommend wiping the data.


    Best of Luck and let me know how it goes.


    Monday, December 1, 2008 8:57 PM
  • I'm goin to sound silly asking this... but what is a ticket with Microsoft?  Does that relate to Assisted Support Request?
    Monday, December 1, 2008 9:42 PM
  • Doesn't sound silly at all.  Yes, open a Support Ticket directly with Microsoft.  It will save you a lot of time and trouble and is relatively inexpensive.  If you have a support plan with Microsoft then it might be included.


    If you have access to CustomerSource or PartnerSource, you can submit a Support request through those Web sites.  If not, then you can submit a Support request through the Microsoft Web site.  Here is a link:




    At the bottom of the page for the link above, you will find Contact options under "Contacts". 


    Monday, December 1, 2008 10:41 PM
  • Back again!  I didn't realise that the "Success" message in the System Jobs section of CRM doesn't actually show any errors in Importing.  I DID find an error list under Imports in the Data Management section.

    The good news is... it seems that the mapping is all okay.... that the lookup references are also okay.

    These are the error messages:

    * A record was not created or updated because a duplicate of the current record already exists.
    * A SWL Server error occured.  Try this action again.  If the problem continues, check the Microsoft Dynamics CRM Community....
    * A record with these values already exists.  A duplicate record cannot be created. Select one or more unique values and try again.

    As a reminder, the entity is called Organisations, which is based on the Accounts entity.  In the CSV file the first column is called Account with a list of GUIDs.

    The other columns are:

    Organisation (this is mandatory, so I've had to leave this in)
    Organisation Type (also mandatory)
    Country (maps to a reference table)
    CRM Portfolio (maps to a pick list)

    I think we're close!!
    Tuesday, December 2, 2008 10:20 PM
  • Hi,


    I have lost track of what is not working, sorry. 


    I am confused by the post because it looks like the errors are related to creating duplicate records and what we want the system to do is update the record so I am not sure why it is not updating the record.  The system seems to be able to make the match to the existing record but doesn't appear to update it.


    In looking through the posts, I found another tool that you might want to have a look at.  I think it is a great fit for what you are trying to do.




    However, a support ticket with Microsoft will be less expensive.


    Wednesday, December 3, 2008 3:31 PM
  • That tool looks AMAZING!

    Except... that it only works on Excel 2007.  We and our client still have 2003 Sad

    Lets hope we can convince either or to upgrade......
    Wednesday, December 3, 2008 6:07 PM