none
Windows Home Server Keeps Asking for Password

    Question

  •  

    I just got WHS up and running yesterday using the OEM version.  However, on my XP laptop the icon in the taskbar says that my password is needed by WHS.  However, I keep telling it to update the password and it says it has but that message just keeps popping back up.

     

    I can access shares just fine, no problems there whatsoever.

     

    It's driving me nuts with that message popping up every few minutes.  My other two computers this isn't happening on.

    Thursday, October 18, 2007 7:36 PM

Answers

  • After a long of searching, I think I found the answer to the problem I encountered.

     

    To recap.  My WHS had the same name as an old Windows 2003 server that used to be on my network.  One of my client computers was constantly asking me to "Update my password" through the WHS tray icon.  This was being caused because XP was storing the old server login parameters.

     

    Running the following command from the client that was asking for the password to be updated:

     

    rundll32.exe keymgr.dll, KRShowKeyMgr

     

    I deleted the reference to the WHS machine.  Logging off, then back in, and one last time updating my password everything fell into place.  Now WHS seems to be happy with my password once and for all.

     

     

    Friday, October 19, 2007 4:57 AM

All replies

  • Same with me, see my thread posted last night for details.  Nothing I've tried will stop it and no one has posted any response or help.  This is definitely a bug.

    Thursday, October 18, 2007 8:29 PM
  • What version of Windows Home Server are you running?

     

    Thursday, October 18, 2007 9:20 PM
    Moderator
  • I am running the OEM version 6.0.1500.6,  the connector software on the affected computer is the version that came with the OEM package, it updated over the old RC1 version.

    Thursday, October 18, 2007 9:49 PM
  • My post from last night is only one entry long here it is to save me bouncing and refering to it:

     

     

    Just updated to the OEM version and got all updates.  Everything seems to work but the tray icon is constantly asking me to update my password on one of the computer (the one connected by cable) the other is ok and does not ask fo an update.  I have re set all the user accounts as they were before the upgrade/reinstall and have manually reset the password on my computer and the WHS several times but it still asks to have them changed to match.  They do already.  If I just click on the tray icon I get the error message about the passwords not matching but if I right click and access the consol that way everything is ok.  I can access the console from the wireless computer by just clicking on the icon with the same user name and password as on the wired one.  I have deleted the original account and made a new one but still the WHS is asking for my password.  Help!

     

    Running XP on all machines, one with problem is wired (cat6) to router others are wireless (one pc one laptop) both server and computers have been restarted.  Didn't have this problem with RC1 just since upgrading to OEM.  Would unistalling connector from the client and reistalling help clear it's password amnesia?  The password has been confirmed as the same on both the client and the server.  Client is set to automatic login as I am the only user on it, I turned it off and manually entered the password at login but the connector software is still asking "Your password is needed".  I installed the new connector software over the old RC1 version, it said it was uninstalling the old version during the upgrade install but maybe something was left behind that has confused it.  Also tried removing the account on the server and re-doing it after a reboot.  No change.  I think the problem is with the connector software.  I am running McAfee VirusScan 2008 for firewall and AV, WHS connector is "allowed" but that access may be the old RC1 version, it never asked to allow access for the new connector after OEM version was installed and that's odd as it should have seen the new version as a different program and asked for access premissions.  Think I'll check that when I get home.  Any help or advice would be appreciated, Thanks.

    Thursday, October 18, 2007 9:53 PM
  •  

    When you updated your Windows Home Server with Windows Update, did it ask you to update the Windows Home Server Connector on the computer that has the password question problem?
    Thursday, October 18, 2007 10:21 PM
    Moderator
  • The OEM "kit" I got had a production build date of 9/27/2007 if that helps any.  Otherwise, I have updated all the components through Windows Update but did not see anything updated Windows Home Server specific. 

     

    Here is the version information:

     

    Windows Home Server Console: 6.0.1500.6
    Windows Home Server Backup & Restore: 6.0.1500.6
    Windows Home Server Drive Extender: 6.0.1500.6
    Windows Home Server Remote Access: 6.0.1500.6
    Windows Home Server Storage Manager: 6.0.1500.6

     

    Now here is the only thing I can think of.

     

    Before I had WHS, I ran Windows 2003 server and the server name was "TRANSAM" and I had file shares.

     

    My WHS is now named "TRANSAM" and I am wondering if the XP laptop is "caching" any of the old user credentials for the old server, since there was a user account on it with the same name as I have now.

     

    Thanks,

     

    Robert

    www.robertstinnett.com

     

    Thursday, October 18, 2007 10:34 PM
  • We have had several different issues when the Windows Home Server matches or matched other computer names.  Can you try changing the name of the Windows Home Server, reboot and run Discovery.exe in the c:\program files\Windows Home Server folder?

     

    Thursday, October 18, 2007 10:45 PM
    Moderator
  • Joel -

     

    Unfortunately, changing the name is not an option in this case since I have several servers in my home and have a defined naming scheme for them that I stick to.  I'd much rather prefer a permanent solution in this case.  I can just "get used to" the error messages and hope that in the future this problem is identified and resolved.

     

    Robert

     

    Thursday, October 18, 2007 11:16 PM
  • No, the connector software on the affected computer was updated by the connector install disk that came with the OEM package but has not been updated by windows update yet.

    Friday, October 19, 2007 12:06 AM
  • The server is named "server" and the affected computer is named Dad and the logon name is David, they are not close to the same and like the other guy everything else seems to work except the constant password nag.

    Friday, October 19, 2007 12:10 AM
  • Changed it to Bob rebooted ran Discovery and same symptoms.  Put things back the way they were so the other computers could find the server , they do no problem but the password nag is still there for my wired computer.  I'm going to completely unistall the connector software and remove the directory and anything else I can find associated with it and re-install the connector on my computer.  Are there any registry references you can point me to to root this out? 

    Friday, October 19, 2007 12:30 AM
  • Did complete uninstall and removed all program directories.  Did not remove any registry values as some of them seemed to refer to backups and status.  There was one labled password sync that had no value set before I uninstalled and still doesn't.  The whole effort was futile as I still get the "Your password is needed" nag from the tray icon but I can still access all the server functions.  I get the "update your password" box when I click on the icon but it does nothing and the password change does not turn off the nag.  If someone can tell me it's ok to delete the registry values after I uninstall, I can try this at another level and maybe get the bad value out.  Can I use the RC1 connector and let it update on Windows Update?  I never had this problem with that version, or would that not work?

    Friday, October 19, 2007 1:44 AM
  • After you uninstall the connector, it should be safe to remove the key

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server

    from your client PC's registry. I assume that's the one you're asking about?

    And no, you won't be able to use the connector software from RC1.

    Friday, October 19, 2007 3:06 AM
    Moderator
  • After a long of searching, I think I found the answer to the problem I encountered.

     

    To recap.  My WHS had the same name as an old Windows 2003 server that used to be on my network.  One of my client computers was constantly asking me to "Update my password" through the WHS tray icon.  This was being caused because XP was storing the old server login parameters.

     

    Running the following command from the client that was asking for the password to be updated:

     

    rundll32.exe keymgr.dll, KRShowKeyMgr

     

    I deleted the reference to the WHS machine.  Logging off, then back in, and one last time updating my password everything fell into place.  Now WHS seems to be happy with my password once and for all.

     

     

    Friday, October 19, 2007 4:57 AM
  • YEA!!!

     

    dmxrob you are the man!  That fixed it perfectly.  I did not change  the WHS server's name from the default during setup to the OEM version and perhaps thiat Key Manager was keeping old information from the RC1 install and the discrepancy was causing the constant requests for the password to be correctly updated.  Deleteing the reference to the WHS server

    in the Key Manager utility corrected the problem and all is well now.  These nagging little problems you can't seem to solve can bug you worse than the big ones, this has been chewing on me for a week.  How did you figure this one out? 

    Thanks again! 

    Friday, October 19, 2007 1:38 PM
  • Thanks for the reply Ken,

     

    Actually there are several under both Local Machine and Current User that it leaves behind after uninstall.  (Messy, Messy) 

     

    Won't need to try though as dmxrob's solution worked fine, apparently XP's key manager holds an old reference to the WHS server that messes things up after upgrade to OEM and it needs to be removed to correct the problem. 

     

    Thanks to everyone for your help and ideas.

    Friday, October 19, 2007 1:44 PM
  • Glad to be of help!

     

    I remembered having something like this happen at work for a network share so dug through some old notes and found this command.  Wouldn't you know -- worked perfectly!

     

    Rob

     

     

    Friday, October 19, 2007 1:55 PM
  • Well, my turn, and I'm going to pick this thread since it's describing one of several problems I'm having with WHS.  I have to say after a week of searching, reading, trying things out, and finding myself back to square one every time, I'm pretty much ready to ditch WHS.  This shouldn't be this hard.

    So, I have an old (circa 2005) HP Slimline that I've been using as a server, it's been running Windows 7 and I've been using SyncBack to back up our computers to it, but had heard some good things about WHS and was intrigued at having all the features - shadow copy, previous versions, remote access, etc. - plus, Windows 7 runs slow on that system, so I downloaded the Eval version of WHS.  It installed without a hitch, except that at the end of the many reboots, when it was finally done, I had no internet connection.  The Slimlines use specialty hardware, so I copied over a driver bundle from DriverPacks.net, which worked like a charm, and then ran Windows Update over and over until I was up to speed.  One of the updates was for my NIC, so I had Windows Update install over my DriversPack driver, rebooted, and all was good - better in fact, since WHS is amazongly fast on that old computer, compared to Windows 7.

    I then booted up my office desktop (Dell XPS running Windows 7 Ultimate), downloaded the WHS Connector software from <WHS>:55000 and installed it, so far so good.  When I ran the Console application, it warned me that I had no account on the WHS system and to create one with the same name as my account on my Dell, which I did.  That night, it backed up my Dell (at least, the WHS Console says it did), and all seemed good.

    Then, I immediately started receiving the same error discussed in this thread: "Your password is needed".  I've run the little password update utility a million times, trying out different things (changing my office desktop password, changing my account password on the WHS, etc.), to no avail.  Each time, the utility says everything was updated successfully, but that appears to mean nothing - if I float my mouse over the Console systray icon it still says "Your password is needed", and it tells me in a bubble notification every time I boot up.  I removed the WHS credentials from both the "rundll32.exe keymgr.dll, KRShowKeyMgr" dialog as well as the "Windows Vault" credentials manager - I did this over and over again until I realized that I wasn't actually removing it because I wasn't running the utility as admin, so it just failed silently each time, which is so useful - thanks Microsoft.

    Finally, I uninstalled the Home Connector software from the Dell, RDC'd into the WHS and deleted my account, as well as my computer, and rebooted both systems.  I then ran the "rundll32.exe keymgr.dll, KRShowKeyMgr" command from an elevated command prompt, removed the WHS from the dialog, checked the Windows Vault dialog to ensure it was gone from there as well, rebooted and checked again - the credentials were truly gone.  I then reinstalled the Connector software from scratch, went through the wizard steps again, created an account on the WHS with the exact same credentials as my office desktop, and immediately began getting the "Your password is needed" message again.  I ran the password update utility again for old time's sake, and again, although it says everything is swell, I still get the error message.

    A second problem I'm having is that when I right-click my Shared Folder in the Console and select "Open" - which by the way, should be the default double-click action for that icon, but after my experience so far I'm not surprised at bad design - I get an "Access is denied" error, which is amazing considering that folder was created by the WHS software specifically for me.  I figure there's a chance this second problem might be caused by the first, so I'd like to resolve the "Your password is need" issue first and see where it leaves me.

    I've run the Toolkit software and resolved all the issues it found.  What really irks me is that all the search hits I get for this error are all from like 2007 and 2008, so it's not like this isn't a known issue and MS hasn't had time to fix it.  I have about 20 days left in my Eval, and needless to say, if I'm still having issues like this at the end there's no way I can buy this or recommend it to anybody.  Sorry, but I'm really frustrated at this point and can understand why Apple and Google are kicking MS's pants based on my experience with this product.

    Wednesday, November 10, 2010 2:21 AM
  • Disappointing.  I really thought I'd get some kind of reponse after a week and a half.  Since I've tried everything else I can think of, and as far as I can tell, this is Microsoft's only support venue for this product, I guess I'll be uninstalling it in 12 days when the license runs out.  Sad.

    Again, I apologize for the tone of my post - the reason for my anger is that, believe it or not, I was for the last 15 years one of the biggest fans of Microsoft products, but for the past 6-7 years it's been harder and harder to defend them, and I feel pretty let down.  My experience with WHS is just the latest in a string of disappointments from this company.  What WHS is trying to do isn't that hard, and there are several alternate solutions that not only work better but are free.

    Saturday, November 20, 2010 3:09 PM