none
File synchronization over VPN aborts with COM exception 25035 (large files causing this)

    Question

  • Hi all,

    I try to sync my files over Internet via VPN to a network share. Although it is slow due to my internet connection, the file synchronization works very well. The only very annoying problem is that sometimes after a file was uploaded, the errors 25035 and 25051 occur (see https://technet.microsoft.com/en-us/library/ms171879%28v=sql.110%29.aspx).

    After some investigation, it seems that it only happens, when a file was uploaded, that was large enough to take a specific amout of time. The minimum file size causing this was 149 MB. Having an upload rate of 128 kb/s, this results in about 20 minutes.

    The errors say that there was a file sharing violation. Maybe the framework opens the metadata file for synchronization on the network share, leaves it open during the file upload and tries to write again when the upload finished. I can imagine that there is some timeout, so that writing to the still open file is recognized as a new file access. I tried to dispose the FileSyncProvider and to create a new one, but this does not help. Also restarting the VPN connection does not work. Only a restart of the application itself allows me to continue the synchronization. Maybe during the shutdown, all connections to the network share are released.

    I am no expert in these things and tried to learn a bit about it but found no further hints to solve this problem.

    I dont think that the windows indexing process of the remote machine is the reason because only I have access to the files using a local account on the remote machine (I removed all other users in the security tab). Has anybody some suggestions?

    Kind regards,

    Vincent



    Saturday, August 29, 2015 9:18 AM

All replies

  • I think I solved the problem. Moving the filesync.metadata file to the local pc seems to work.
    Monday, September 07, 2015 7:41 PM