locked
Can't Download WinHlp32.exe - keep getting stuck on validation RRS feed

  • Question

  • Ok first of all I have read way too many threads on this and have been following them to no avail so I am sorry to have to post this.  I am trying to download WinHlp32.exe for my wife who needs it for a class.  When I get to the download page it gives me the "Validation Required" message and only presents the "Continue" button.  I know this doesn't work with Windows 7 so no need to explain the issues with GenuineCheck.exe again.  In looking over other threads on this I found that I needed to use the 32-bit version of IE instead of the 64.  I tried that and it didn't work.  I also found posts that said to try 'www.microsoft.com/genuine/validate'  first as this would ensure that the activeX control was loaded.  I did that, it validated correctly, and it still didn't fix the problem.  I also ran the diagnostics at 'www.microsoft.com/genuine/diag' and everything passed.  Still the download page will not get past the "Validation Required" message.  This is a brand new Toshiba laptop.  Here is the diag report as requested.  Any ideas as to why the ActiveX validation is not working?

    Andy

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    Windows Validation Data-->

    Validation Code: 0
    Cached Online Validation Code: 0x0
    Windows Product Key: *****-*****-4F8HK-M4P73-W8DQG
    Windows Product Key Hash: Xs1iQgVeo0C+sObJxS7eu+FuBPQ=
    Windows Product ID: 00359-OEM-8992687-00057
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.1.7601.2.00010300.1.0.003
    ID: {45335C18-3726-410C-AE02-AF43E8797B4F}(1)
    Is Admin: Yes
    TestCab: 0x0
    LegitcheckControl ActiveX: Registered, 1.9.42.0
    Signed By: Microsoft
    Product Name: Windows 7 Home Premium
    Architecture: 0x00000009
    Build lab: 7601.win7sp1_gdr.120830-0333
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Vista WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files (x86)\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Prompt
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{45335C18-3726-410C-AE02-AF43E8797B4F}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-W8DQG</PKey><PID>00359-OEM-8992687-00057</PID><PIDType>2</PIDType><SID>S-1-5-21-2315342588-1231628562-3114941506</SID><SYSTEM><Manufacturer>TOSHIBA</Manufacturer><Model>Satellite L875</Model></SYSTEM><BIOS><Manufacturer>Insyde Corp.</Manufacturer><Version>1.60</Version><SMBIOSVersion major="2" minor="7"/><Date>20120627000000.000000+000</Date></BIOS><HWID>6F333B07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>TOSASU</OEMID><OEMTableID>TOSASU00</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    Software licensing service version: 6.1.7601.17514

    Name: Windows(R) 7, HomePremium edition
    Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
    Activation ID: d2c04e90-c3dd-4260-b0f3-f845f5d27d64
    Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
    Extended PID: 00359-00178-926-800057-02-1033-7601.0000-0922012
    Installation ID: 017746166775438993554560034510364235857110322505639930
    Processor Certificate URL: 'http://go.microsoft.com/fwlink/?LinkID=88338'
    Machine Certificate URL: 'http://go.microsoft.com/fwlink/?LinkID=88339'
    Use License URL: 'http://go.microsoft.com/fwlink/?LinkID=88341'
    Product Key Certificate URL: 'http://go.microsoft.com/fwlink/?LinkID=88340'

    Partial Product Key: W8DQG
    License Status: Licensed
    Remaining Windows rearm count: 2
    Trusted time: 10/18/2012 9:22:19 PM

    Windows Activation Technologies-->
    HrOffline: 0x00000000
    HrOnline: N/A
    HealthStatus: 0x0000000000000000
    Event Time Stamp: N/A
    ActiveX: Registered, Version: 7.1.7600.16395
    Admin Service: Registered, Version: 7.1.7600.16395
    HealthStatus Bitmask Output:


    HWID Data-->
    HWID Hash Current: LAAAAAEAAQABAAEAAAABAAAAAgABAAEA6GHydYRGBF0qIdJ3MsLGPXghLnM=

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20001
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name OEMID Value OEMTableID Value
      APIC   TOSASU  TOSASU00
      FACP   TOSASU  TOSASU00
      HPET   TOSASU  TOSASU00
      BOOT   TOSASU  TOSASU00
      MCFG   TOSASU  TOSASU00
      WDAT   TOSASU  TOSASU00
      ECDT   TOSASU  TOSASU00
      UEFI   TOSASU  TOSASU00
      ASF!   TOSASU  TOSASU00
      SLIC   TOSASU  TOSASU00
      SSDT   INSYDE  CR CRB 
      ASPT   TOSASU  TOSASU00
      FPDT   TOSASU  TOSASU00
      SSDT   INSYDE  CR CRB 
      SSDT   INSYDE  CR CRB 


    Friday, October 19, 2012 1:43 AM

Answers

All replies

  • Please post the details of the page and file you are attempting to download - note that you should simply need to click on the 'Continue' button, and the page will refresh, and the button transform to a Download button.

    Try it from here.... http://www.microsoft.com/en-us/download/details.aspx?id=91


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, October 19, 2012 10:26 AM
    Moderator
  • Noel,

    That is the page I am using.

    Window Help Program (WinHlp32.exe) for Windows 7
    'http://www.microsoft.com/en-us/download/details.aspx?id=91'

    Unfortunately when I click on the 'Continue' button it takes me to the page that attempts to run GenuineCheck.exe which I know from reading many of your posts doesn't work.

    Andy

    Friday, October 19, 2012 2:35 PM
  • This particular page seems to be causing problems for many  - I can't actually download it from my proper locaised site, but I can from the US site.

    See if it works the other way around....

    http://www.microsoft.com/en-gb/download/details.aspx?id=91


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, October 19, 2012 9:47 PM
    Moderator
  • I can confirm this as well. I also need to download the winhlp32.exe file but the same problem happens... when I click to download the file, it redirects to a page asking to validate windows. When you download and run genuinecheck.exe, an error comes up saying "Windows Genuine Advantage. The version of the Windows Genuine Advantage validation tool is no longer supported. Please download the newest version that your system clock is accurate".

    The problem appears to be isolated to the links for Vista and 7, but I can go to the links for Server 2008 and R2 and download the exe's which won't install on Windows 7. It does not seem to change when I change the locale of the site for me anyway.

    I have reported the issue via phone through answers.microsoft.com, and hopefully this will be escalated to the proper channels...

    Friday, October 19, 2012 10:00 PM
  • I have reported the issue via phone through answers.microsoft.com, and hopefully this will be escalated to the proper channels...

    We can all hope - but since I first brought this to the attention of MS on Aug 17th, nothing has changed :(

    They *may* simply be waiting for the launch of Win8......

    (don't hold your breath, though!)


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, October 19, 2012 10:24 PM
    Moderator
  • Unfortunately using the gb site does not resolve the issue for me.  Are there any other work arounds you can suggest?

    Thanks,

    Andy

    Saturday, October 20, 2012 2:36 AM
  • Try deleting your Cookies (from Internet options) and then going back to the page.

    There are third-party sites with this file - but....


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Saturday, October 20, 2012 8:53 AM
    Moderator
  • We have a solution :)

    use the following link

    http://www.microsoft.com/en-us/download/genuine-validation.aspx?id=91

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Sunday, October 21, 2012 8:59 PM
    Moderator
  • Noel,

        Thank you so much that worked.  I appreciate your help.

    Andy

    Tuesday, October 23, 2012 2:38 PM
  • I recently had this problem when I updated my Firefox; even thou I knew my default browser was IE; the new version of Firefox set my UserAgent as Firefox; so when I’m using IE and I visit an MS site for instance it thinks I’m using Firefox since it see that as my UserAgent.

    Your UserAgent for your browser is set to Firefox - has to be set to IE.

    User Agent and Default Browser have to be the same under the Browser Data section after you run the MSDiag.exe (Search - I'm a new user and unable to post links)

    How to Change bowser UserAgent (Search - I'm a new user and unable to post links )

    List of Bowser UserAgent String (make sure you select the right one for OS and IE version) (Search - I'm a new user and unable to post links )

    If the UserAgent is listed as Firefox you must go into Firefox and change it to IE


    Wednesday, October 24, 2012 6:46 PM
  • That's not the problem at all, currently - it's simply that the Download Center servers are serving the wrong links.

    I am attempting to get some action from MS on this. Hopefully it will be fixed soon.


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Wednesday, October 24, 2012 7:23 PM
    Moderator
  • First of all I posted what worked for me.  It it was an issue of being sent to the wrong URL; every machine would have this problem and that NOT the case.  I have tested this on two different PCs; one it work the the other it did not; only difference was the UserAgent; I change the UserAgent and it works fine.

    You have only provided an band-aid or workaround; cause once the user gets the WGA pop-up again the issue will resurface.

    Thursday, October 25, 2012 12:28 PM
  • The problem here is that that you are not seeing the same issue as the other posters.

    I had the same problem for over a month - whereby I could access the proper links using IE9 in Win7 or IE8 in XP.

    The links are no lenger working without manual adjustment - with no changes to my system that I'm aware of, and with the proper User Agent String.

    The problem lies with the server at MS - I am attampting to get some action within MS on this matter, but they claim not to be able to repro it currently.


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Thursday, October 25, 2012 12:45 PM
    Moderator
  • Noel - thanks for providing the workaround in the meantime. I followed up with the team that owns this download and it should be fixed now.

    Sincerely,

    Paul O'Rear


    Paul O'Rear, Microsoft Corporation http://blogs.msdn.com/TheHelpGuy

    Friday, October 26, 2012 6:28 PM
  • It does seem to be fixed, now (I checked this morning to give time after I'd heard the fix had been applied for propagation - it still failed for me last night when I tested).

    You can probably tell from the tone of my posts that I was getting pretty frustrated dealing with the hundreds of queries on this in the past couple of  months!

    Thanks for coming in, Paul - hopefully this isn't going to be a common occurence for you :)


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, October 26, 2012 6:39 PM
    Moderator
  • I'm having the same issue - regardless of the links I try or how many times I install Windows Genuine Advantage. WinHlp32 does not appear to be available under MSDN Subscriber Downloads either.

    Thursday, January 3, 2013 5:31 PM
  • Please start a NEW thread of your own, and post your problems in detail - and provide an MGADiag report.....

    To properly analyse and solve problems with Activation and Validation, we need to see a full copy of the report produced by the MGADiag tool
    (download and save to desktop - http://go.microsoft.com/fwlink/?linkid=52012 )
     Once saved, run the tool.
    Click on the Continue button, which will produce the report.
     To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.
      - **in your own thread**, please
     
    Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!
    http://www.microsoft.com/en-us/howtotell/Hardware.aspx


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Thursday, January 3, 2013 9:34 PM
    Moderator