locked
crm outlook client xml RRS feed

  • Question

  • We have Office 365 and CRM Online. Our users are synced with DirSync to Office 365 and thus CRM online. Our domain in Office 365 is federated. Users can succesfull login to CRM Online. Also users can successfully manually configure CRM Outlook client and connect to CRM online. But now we want to automate this for users and we are hitting a wall.

    The XML we use is as follow:

    <Deployments>
    <Deployment>
    <DiscoveryUrl>https://disco.crm4.dynamics.com&lt;/DiscoveryUrl>
    <Organizations>
    <Organization IsPrimary='true'>Our CRM Org</Organization>
    </Organizations>
    </Deployment>
    </Deployments>

    Then we run

    "C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard\Microsoft.Crm.Application.Outlook.ConfigWizard.exe" /q /i "C:\Program Files\Microsoft Dynamics CRM\Default_Client_Config.xml"

    But nothing happens and it errors out.

    Is there something wrong in my XML ?

    Friday, November 13, 2015 8:16 AM

All replies

  • Hi,

    Do you get any error logs somewhere in \AppData\Roaming\Microsoft of the running user?

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Friday, November 13, 2015 8:44 AM

  • </Deployments>
    <Deployment>
    <DiscoveryUrl>https://disco.crm4.dynamics.com</DiscoveryUrl>
    <Organizations>
    <Organization IsPrimary='true'>My Organizaton</Organization>
    </Organizations>
    </Deployment>
    </Deployments>

    When running the configwizard with /QR i see it does not fill in CRMOnline or the disco URL and stops there.
    If i change disco url in the XML file to CRMONLINE is fills in CRM Online in the dropdown menu and stops there

    Friday, November 13, 2015 9:23 AM
  • Hi,

    Could it be a space in the Organization name? The org unique name can be found in the Developer Resources section, that might be the issue. Just of the top of my head the xml looks ok otherwise.


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Friday, November 13, 2015 9:31 AM
  • When i use the disco URL i see in log file 'configuratio file type on-premise' so i changed the disco URL to CRMONLINE.
    Now i see configuration file type Online'

    XML i use

    <Deployments>
    <Deployment>
    <DiscoveryUrl>crmonline</DiscoveryUrl>
    <Organizations>
    <Organization IsPrimary='true'>org1234abcd</Organization>
    </Organizations>
    </Deployment>
    </Deployments>

    Still same behaviour running configwizard with /QR i see the configuration screen and it choose CRM Online automatically but it hangs there waiting for input / i click connect.

    Friday, November 13, 2015 9:41 AM
  • Hi,

    Have a look at this: https://technet.microsoft.com/en-us/library/hh699665.aspx (if you haven't already). The disco URL should be https://orgname.crm.dynamics.com Which is found as the organization service in the developer Resources. It is a bit tricky to do this so it might take some time to get it right.


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Friday, November 13, 2015 9:48 AM
  • Mister Rickard,
    I found the orgname as per http://blogs.technet.com/cfs-file.ashx/__key/communityserver-blogs-components-weblogfiles/00-00-00-75-32/2555.Picture10.png

    <Deployments>
    <Deployment>
    <DiscoveryUrl>https://org1234abcd.crm.dynamics.com</DiscoveryUrl>
    <Organizations>
    <Organization IsPrimary='true'>org1234abcd</Organization>
    </Organizations>
    </Deployment>
    </Deployments>

    Running configwizard with /QR opens the configwizard and just shows http:// and stops and waits for manual input
    With DiscoveryUrl set to crmonline in the XML it shows Crm Online 


    Friday, November 13, 2015 10:04 AM
  • Hi,

    I'm not sure if it's a typo, but what does the /QR flag do? Have you added logging to the installation, maybe even the verbose one (/LV)?

    As I said, it is a bit of fiddling with the quiet install.

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Friday, November 13, 2015 10:15 AM
  • I also found this blog
    https://community.dynamics.com/crm/b/crminthefield/archive/2011/02/23/configuring-the-crm-online-2011-outlook-client-silently

    There it states to use /QR so you can see that the /Q silent config does.

    With the /L i get 

    Error connecting to Microsoft Online Services Endpoint using UPN  Exception: Microsoft.Crm.CrmException: get_user_name_failed: Failed to get user name ---> Microsoft.IdentityModel.Clients.ActiveDirectory.AdalException: get_user_name_failed: Failed to get user name ---> System.ComponentModel.Win32Exception: There is no mapping between account names and security IDs


    Friday, November 13, 2015 11:03 AM