none
Job task requests only 1-1 Cores RRS feed

  • Question

  • Hi,

    When a job is started, it allocates 52-52 Cores according to template, but the task inside that job is still 1-1 Cores.

    I'm using a 3rd party application, which passes the command line to HPC via Integration Service.

    These tasks are not repeatable and the command line does not include any resource parameters.

    Where should i look on how to set Resources PER TASK? Because i can export job XML and see that the task is set to min:1 max:1 core resource, but i cannot resubmit the task/job so i'm like a sitting duck here.

    Why are "Job Resources" reserving 52 Cores and use only 1 for the only task it's running?

    Monday, March 4, 2019 11:45 AM

Answers

  • Hi w115,

    Right. With HPC Pack, you can specify the number of cores for a task via API, command line or PowerShell. However if the application adds and submits the task for you, you need to check if the application has exposed a parameter for setting the task cores.

    Regards,

    Yutong Sun

    • Marked as answer by w115 Tuesday, March 12, 2019 7:16 AM
    Wednesday, March 6, 2019 9:40 AM
    Moderator

All replies

  • Hi w115,

    Job is like a resource container for tasks, when running it holds at least the Min resources for the tasks. Tasks can come and go in a job.

    In your case, if you know there is only one task for 1-1 cores, you may alter the job for 1-1 cores, so that no cores in the job are wasted. Or you may also alter the task for 52-52 cores.

    A job can also be specified with *-* cores, which means the Min and Max are auto-calculated according to the tasks.

    Regards,

    Yutong Sun

    Tuesday, March 5, 2019 8:07 AM
    Moderator
  • Hi Yutong,

    Thanks for response, maybe i formulated my question in a bit weird way.

    I want my task to use the maximum amount of resources. If i allocate 52 cores for a job, i expect the task to use all of them and not 1-1 or autocalculate.

    After some digging i found that this may be due to the application im using, i suspect its powershell string is not specifying -NumCores and according to Documentation, that means:  If you do not specify NumCoresNumNodes, or NumSockets, the task is allocated one core.

    So maybe that means the problem is outside of HPC? or could it be configured from within somehow?

    Tuesday, March 5, 2019 10:53 AM
  • Hi w115,

    Right. With HPC Pack, you can specify the number of cores for a task via API, command line or PowerShell. However if the application adds and submits the task for you, you need to check if the application has exposed a parameter for setting the task cores.

    Regards,

    Yutong Sun

    • Marked as answer by w115 Tuesday, March 12, 2019 7:16 AM
    Wednesday, March 6, 2019 9:40 AM
    Moderator