locked
IP adgress not corresponding to the physical address RRS feed

  • Question

  • Hi.
    I have a setup with two NIC's. One connecting a smal local network (IP 192.168.0.1) and the other connecting to the Intenett through a wireless nettwork (10.0.0.51). (faster file transfere on a wired network). When checking the Remot access > Router configuratin, the Router IP adress is OK but the Home Server IP address is wrong. First it is the adress connecting the local nettork and second it is not the address that corresponds to the listed Home Server physical address.
    see Screen capture

    I suspect this beeing the reason my server beeing unable to configure the router.

    Is there any way i could configure this?

    Thanks
    Åsmund
    Monday, December 8, 2008 10:41 PM

Answers

  • I agree with previous posters; Unless you have good reasons not to I would also advise you to connect the your router (192.168.0.1) to the wireless modem (10.0.0.51).
     
    Then properly configure the routers WAN settings. It should have IP in the range of the modem, either set manually or by DHCP from the modem. After you have managed to get internet connectivity this way you will need to setup portforwarding in the both the modem and router. Alternatively you can set the router in bridge mode.


    If you don't want to mess with your (currently working) network setup you can also try:
     
    1. Open network connections window from the control panel
    2. From the top menu choose Advanced, Advanced Settings
    3. Change the order in which the network adapters are accessed, then try again.
    4. If this works please let us know.
    • Marked as answer by åsmundl Tuesday, December 9, 2008 7:38 PM
    Tuesday, December 9, 2008 2:53 PM
    Moderator

All replies

  • I think WHS is picking up that the wired 192 network is the one it wants to use by default. WHS should not be connected by wireless
    You can probably configure the router manually by using port forwarding
    Monday, December 8, 2008 10:59 PM
  • I'd agree with Evader's thoughts on it.  Since WHS isn't meant to be used on a wireless network (there's a reason that there's no option to set that up in the Console), it probably is expecting to be connected to the internet via the hardwire network, rather than the wireless.
    Also, trying to dual-home the machine as you have is:
    1- not supported;
    2- likely to create issues (more than you already have seen); and
    3- is against the EULA.

    Question:  is there a reason (over and above "why do you have two logically separate, if not physically separate networks" - it can be a PITA to get to work right...) that you absolutely cannot simply properly connect (via hardwire) the WHS to the router?

    Yes, you could manually configure port-forwarding in the wireless router.  While you're at it, you should also assign the WHS a static IP address (either in the router's DHCP server config, or directly at the WHS.)  However, you might not - ever - get remote access via name working properly.  The WHS (not your router) is reponsible for updating the DNS record for your *.homeserver.com address.  Since the WHS will (likely) be attempting to do that over the LAN (rather than over your WLAN), it might not ever actually do that.

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Proposed as answer by kariya21Moderator Tuesday, December 9, 2008 3:03 AM
    • Unproposed as answer by åsmundl Tuesday, December 9, 2008 6:58 PM
    Tuesday, December 9, 2008 1:17 AM
  • I agree with previous posters; Unless you have good reasons not to I would also advise you to connect the your router (192.168.0.1) to the wireless modem (10.0.0.51).
     
    Then properly configure the routers WAN settings. It should have IP in the range of the modem, either set manually or by DHCP from the modem. After you have managed to get internet connectivity this way you will need to setup portforwarding in the both the modem and router. Alternatively you can set the router in bridge mode.


    If you don't want to mess with your (currently working) network setup you can also try:
     
    1. Open network connections window from the control panel
    2. From the top menu choose Advanced, Advanced Settings
    3. Change the order in which the network adapters are accessed, then try again.
    4. If this works please let us know.
    • Marked as answer by åsmundl Tuesday, December 9, 2008 7:38 PM
    Tuesday, December 9, 2008 2:53 PM
    Moderator
  • I got it working!

    brubbers suggestion corrected the issue with the Router configuration displaying the wrong IP address, but it did not allow the uPnP to configure the router.
    Manually port forwarding the required ports did the connection trick,  and both the Router and Domain name status is working. One issue remains: the Remote Access to Windows Home Server Console errors with a connection time out, but that's not a big issue :-)

    The reason for connecting the server to two networks is that the modem and router (i.e my internet connection) is situated on a second floor, no wires running through the roof. All backup, media sharing etc is done through a wired network in my flat. The server is connected to the wireless network through a D-Link DWL-2100AP in client mode, via a ordinary NIC. The "Client for Microsoft networks" and "File and Printer Sharing" is disabled on the wireless side and enabled on the hardwired side. This also goes for my desktop computer running XP. This setup enables me to access shared files on the server via the wired network and the internet through the wireless connection.

    Thanks!
    Åsmund
    Tuesday, December 9, 2008 7:38 PM
  • Hi Åsmund,
    if the console access via remote website is timing out, this usually points to íssues with port 4125. Very often its a corporate firewall, which blocks the access via this port from your client. Sometimes it can also be the ISP blocking ports or a misconfiguration on your side.
    Best greetings from Germany
    Olaf
    Tuesday, December 9, 2008 9:22 PM
    Moderator