none
SyncToy 2.0 MS Access database corruption when syncing to IOmega NAS Server RRS feed

  • Question

  • I just installed SyncToy 2.0 and discovered that my Access database files are corrupted when copied to my backup drive.

    Seq of events:
    1- delete the backup drive (NAS) creating a clean point of departure.
    2- create a new folder pair.
    3- run the folder pair (backup local drive to NAS)
    4- executing Access database from NAS reported a corrupt .mdb file
    5- executing the same database file from the internal PC drive (ESmile works fine
    6- copy by hand the corrupted database file from NAS to E: (other map)
    7- database still reported corruption when executing.
    8- copy the original database by hand to the NAS (other map)
    9- database works fine from the NAS.

    My conclusion from the above seq of events is that the Access database file got corrupted by SyncToy when moved.

    Any suggestions?
    Friday, August 22, 2008 2:04 PM

All replies

  • Sorry to hear that.. We haven't heard of other people encountering any corruption issues with any kinds of file. This may be a combination of how SyncToy is doing the file copy and the particular SMB implementation for your NAS device. Can you give us some details on your NAS device and whether it uses a SAMBA implementation?

     

    Friday, August 22, 2008 9:46 PM
    Answerer
  • To add to my previous post.

    The corruption only seems to happen when the backup destination is the NAS.

    The NAS I am using is a 500GB Iomega with a SMB server
    Friday, August 22, 2008 9:47 PM
  • The NAS is a Iomega, capacity 500GB, Type Storcenter Home Network Hard Drive 33457

    http://www.iomega-europe.com/section?SID=345eb3ecc4851b3297cc86ec692172eb16a:4720&secid=76622&newlang=en

    Again when copying the Access database file with Windows Explorer to the NAS the file is OK.
    Friday, August 22, 2008 10:12 PM
  • Does this issue also happen if you connect the device via USB cable to the PC, such that it just appears as an attached HD?  This would tell us if this is an issue with the interaction of SyncToy and the SMB implementation on the NAS.

     

     

    Saturday, August 23, 2008 6:04 AM
    Answerer
  • I observed file corruption with SyncToy 2.0 using the Iomega 500 home network configured as an SMB server also.  Details are available on this forum at http://forums.microsoft.com/sync/ShowPost.aspx?PostID=3721952&SiteID=75

    SyncToys 1.4 worked fine with the same files corrupted by SyncToy 2.0 with this particular NAS, so you may wish to install that version until a fix is found.



    Monday, August 25, 2008 2:14 AM
  • I could do so, however excluding subdirectories does not work on SyncToy 1.4 (that is the main reason I upgraded to version 2.0), so I still keep hooping on a fix soon.
    Monday, August 25, 2008 8:21 AM
  • The test you proposed showed that no file corruption occurred when the drive was attached via USB.

    What will be the next step? Can we expect a patch within a reasonable time?
    Tuesday, August 26, 2008 8:27 AM
  • It appears that the SMB implementation on the Iomaga disk runs into corruption issues along with the Windows Copy API that we use. Currently, there is no patch available that we know of and I am sorry there is no fix we can currently offer for SyncToy 2.0 to make this work. The only workaround would be what Ashish suggested above to connect it via USB but I can understand why this might not be a permanent solution for you to pursue.

     

    Thanks

    Deepa

    Tuesday, August 26, 2008 6:31 PM
    Moderator
  • Thanks, I suppose I have to look for another backup utility 
    Wednesday, August 27, 2008 6:53 AM
  • Sorry we don't have an immediate answer to your issue. We will look into it and see if we can resolve this with an upcoming release of the Sync Framework (the underlying platform piece that SyncToy uses). Please check back on the forum in a few months time.

     

    Wednesday, August 27, 2008 5:02 PM
    Answerer
  • I will certainly do !!

    Thanks
    Tuesday, September 2, 2008 10:11 AM
  • Hi, I had identical problems syncing my Microsoft money files onto an IOMEGA 250 gig network drive using SMB. Everything worked fine before using Syctoy1.4. One thing I noticed was that the time stamp on the copied files was set 1 hour in advance of when I sync'd them with ver2. I uninstalled Ver2 & installed ver1.4 & everything works fine again.

    I must learn to leave things alone if they're working ok !

     

    Friday, September 5, 2008 9:40 AM