locked
Order of hard drives changes in disk management (Win XP) ?? RRS feed

  • Question

  • I have a Gigabyte GA-EX58-UD5 motherboard connected with 2 SATA hard drives (2x Western Digital 1 TB).
    I had RAID 1 (mirrored, with 6 partitions) and deleted it (removed the raid volume, made it NON-RAID) because i no longer wanted RAID and needed more space. I had also taken a backup of everything.
    Afterwards i have a few partitions on one disk combined. So now i have one drive with 3 partitions, the other drive has 6 partitions.

    Now, under disk management (Win XP) changes "disk 0" and "Disk 1" of place when i change in bios the "IDE" or "RAID or AHCI" mode setting.
    In other words:
    If in bios "IDE" setting is set, disk management shows "Disk 0" is the one with 6 partitions and "Disk 1" the one with 3 partitions.
    When i choose in bios "RAID" mode, disk management shows "Disk 0" is the one with 3 partitions and "Disk 1" the one with 6 partitions.
    When i choose in bios "AHCI" mode, disk management shows "Disk 0" is the one with 3 partitions and "Disk 1" the one with 6 partitions.

    I see the same happening (in the programs) when i boot with the boot CD ShadowProtect (backup program), or when i boot with the "Acronis Disk Director home 11" boot CD.

    I thought the display of the order of hard drives was a fixture, depending on how they are connected to the motherboard. So according to the order of the SATA port connections on the motherboard.
    This appears not to be exact.
    Where's the order of displaying the hard drives determined?
    And how can i change them?

    Monday, January 3, 2011 11:44 AM

Answers