locked
Automatic Contact Creation for Unresolved Senders on CRM 2013 RRS feed

  • Question

  • ·         Business Goal: Avoid lost time and energy from deleting unnecessary contacts
    ·         Repro Steps: Send an email to a user from an email address that doesn't exist in the system
    ·         Expected Results: Emails that don't resolve and are not regarded should not appear in any history
    ·         Actual Results: Every unresolved email sender is created as new contact in CRM
    ·         Environment: We have MSCRM 2013 On Premise running on the min req for the new version. Both CRM and SQL are on the same box. The email router is on a separate server that also has Exchange and AD. I'm not aware of any rollups yet available for the new version.

    With regards to this setting:

    Go to File - Options- Email tab and change the default display Settings (Uncheck Automatically create records for Microsoft Dyanmics CRM). 

    I've already disabled this setting and I am still able to reproduce the problem.

    http://social.msdn.microsoft.com/Forums/en-US/0f3f46ea-f58f-450e-8459-d1c7f8d9968f/automatic-creation-of-duplicate-contacts-in-crm-2011?forum=crm

    Someone responded to the above forum post and suggested that there may be a system account that still has the auto create on promote setting turned on. He included an SQL query that lists out the users the values. The account that the email router uses to authenticate was set to 1. I disabled the setting for that user and I'm going to test to find out whether that resolves the issue. I'm hoping that posting this on the forums will help others who have the same problem when they upgrade to CRM 2013.

    Eric Hula


    Eric Hula - CRM Administrator

    Thursday, April 3, 2014 7:11 PM

Answers

  • I tested out the proposed fix from the above link and it worked. The key is to ensure that the account used to authenticate the email router has the setting turned off. To do disable it, I logged into a computer as that user (which is only used for admin purposes) and opened CRM in a browser. I clicked on the gear icon, clicked options, then the email tab. I unchecked the Create checkbox and clicked OK.

    I verified that it's working as it did previously in v4 by asking someone to send me an email that has never sent us an email before. It worked!


    Eric Hula - CRM Administrator

    • Marked as answer by Eric Hula Thursday, April 3, 2014 7:34 PM
    Thursday, April 3, 2014 7:34 PM