locked
Vail (Aurora) - Provider SDK Sample RRS feed

  • Question

  • Hello together,

    I experince a problem with the Chat-Provider Example of the Windows Server Solutions SDK. Although I run it on Windows SBS Aurora it should the same with Vail, cause the share the same sources.

    If I build the Chat-Provider sample and deploy it to "%Program Files%\Windows Server\Bin" (as mentioned in the SDK Help) I can run it on the server without any problems. I can open 2 or more ChatWindow.exe Clients, press "connect" and see the sent Chat-Text in all of the opened ChatWindow applications. Whereby the ChatProvider.exe must be started with "run as administrator".

    If I deploy (copy) the ChatObjectModel.dll and the ChatWindow.exe to a client computer (in the same directory as described above), which is connected to the SBS Aurora server and I am logged in via the launchpad or the dashboard (so there is a runnning session with the server and the credentials should be existant) and start ChatWindow.exe and press "connect" after entering a user-name, nothing happens. Whereby the ChatProvide.exe ist still running on the server and ChatWidow.exe applications too.
    That means ChatWindow.exe seems to call the Provider on the server via the ObjectModel, but does not get any response - wheter a "connection failed" nor a "connection time-out" or something like that.

    I tried a lot of things and at least I changed the follwing code in ObjectImplementation.cs :
    from : 
       m_connector = ConnectorFactory.GetConnector<IProvider>("provider", this);

    to :
       m_connector = ConnectorFactory.GetServerConnector<IProvider>("provider, this, new NetworkCredential("userx", "passwordy", "domainz"));

    as I thought, that if you are on the client you have to tell the provider framework that you want to connect to a provider which resides on the server. But this did not change anything.

    What lead me to that and maybe shows the underlying problem is, that if you start the ChatWindow.exe on a client , enter a user-name and press "connect", while the application seems to wait for a ProviderConnection to signal the ConnectionOpened (maybe till the end of time / the beta phase ;-) - you could start a ChatProvider.exe on the client and the connection will be established. But in that case you only have a ChatProvider running on that client computer and it is (understandable) not possible to communicate with the ChatWindow applications running on the server.

    So the final question : Is it a "beta feature" that the Provider Framework cannot establish a connection from a client to the server respectively to get a reference of a ProviderConnector running on the server?

    Thanks
    gebco

     

    Thursday, October 21, 2010 10:13 AM

All replies

  • Hi !

    this Example works for me... on Server and Client...
    it must be something else---

     

    Wednesday, October 27, 2010 8:21 PM