locked
Problem: User privilege issue when installing client for outlook? RRS feed

  • Question

  • Is the administrator privilege of a user disregarded when the CRM client for outlook is installed? I can no longer able to enable or disable a user when we installed the client for outlook because the "More Actions" is not displayed in the form toolbar. Actually when we installed the client for outlook, the "My Home Page" and Settings in the navigation pane dissappeared. I just edit the sitemap to make it displayed again but the problem is it seems like it disregard the administrator role when we install the client since the actions and features for administrators are not available.
    Wednesday, February 6, 2008 1:13 AM

Answers

  • It's not really that admin privileges are disregarded, it's that most admin functions are not available within the Outlook client, and this affects the web client for CRM if Outlook is running.

     

    What you have to do is close Outlook and the web client, then just open the web client to do CRM admin functions

     

    Wednesday, February 6, 2008 8:58 AM
    Moderator
  •  

    Are you working with CRM 3.0?

     

    In the CRM Outlook Client under version 3.0, some settings areas don't show in either the web client or the outlook client if Outlook is open.

     

    If you close down Outlook and then open the web client you should find that these administrative settings work as normal.

     

    It isn't a case of ignoring administrator settings or roles more a case of how the application presents itself.

     

     

    Wednesday, February 6, 2008 9:26 AM
    Moderator
  • Hi,

     

    Well you can mark all correct answers as "MARK AS CORRECT". 

     

     

    About your disabled CRM menus in Outlook:

    It seems that your outlook is unable to connect to your CRM. This may due to many reasons:

     

    1. DNS setting on client machine is not correct.

    2. You are not properly connected to LAN.

    3. During your installation you didn't provide full name alongwith the port number in CRM URL e.g. http://crm:5555

    4. You don't have installed Rollup 2 for MS CRM Client for Outlook.

     

    Solutions

    1. Check your DNS settings

    2. Make sure that you are connected to LAN.

    3. During installation of Client always provide the correct URL alongwith the port #.

    4. Download Rollup 2 from http://www.microsoft.com/downloads/details.aspx?familyid=81674DA5-FFEF-492A-A7B1-7E1F1951B05F&displaylang=en and install it

     

    Generally there is no harm in uninstalling CRM Client for Outlook and reinstalling it. You can try this to resolve your scenario. I recommand that if you don't find any solution you better reinstall Client for Outlook. Again don't forget to install Rollup 2 for Clients.

     

    Thursday, February 7, 2008 5:18 AM

All replies

  • When you use Outlook client to use CRM, you can't see Settings tab and admin rights even on CRM web...If you want to do the admin tasks and see the "settings" tab, then :

     

    Close Outlook --> Open web browser --> Open CRM web --> perform admin tasks

    Wednesday, February 6, 2008 5:26 AM
  • When you use Outlook client to use CRM, you can't see Settings tab and admin rights even on CRM web...If you want to do the admin tasks and see the "settings" tab, then :

     

    Close Outlook --> Open web browser --> Open CRM web --> perform admin tasks

    Wednesday, February 6, 2008 5:52 AM
  • It's not really that admin privileges are disregarded, it's that most admin functions are not available within the Outlook client, and this affects the web client for CRM if Outlook is running.

     

    What you have to do is close Outlook and the web client, then just open the web client to do CRM admin functions

     

    Wednesday, February 6, 2008 8:58 AM
    Moderator
  •  

    Are you working with CRM 3.0?

     

    In the CRM Outlook Client under version 3.0, some settings areas don't show in either the web client or the outlook client if Outlook is open.

     

    If you close down Outlook and then open the web client you should find that these administrative settings work as normal.

     

    It isn't a case of ignoring administrator settings or roles more a case of how the application presents itself.

     

     

    Wednesday, February 6, 2008 9:26 AM
    Moderator
  • Ok, I understand now, but they didn't point it out in their documentation?
    Thursday, February 7, 2008 12:15 AM
  • Oh my! You all have the answer. Which of you guys will i'm going to mark as answer?
    Thursday, February 7, 2008 12:17 AM
  • There's another problem that came up now, the crm menu and toolbar button in our outlook are not working and the admin functions in crm web is now available, it means that the client for outlook is not running even though our outlook is up.
    Thursday, February 7, 2008 1:06 AM
  • Hi,

     

    Well you can mark all correct answers as "MARK AS CORRECT". 

     

     

    About your disabled CRM menus in Outlook:

    It seems that your outlook is unable to connect to your CRM. This may due to many reasons:

     

    1. DNS setting on client machine is not correct.

    2. You are not properly connected to LAN.

    3. During your installation you didn't provide full name alongwith the port number in CRM URL e.g. http://crm:5555

    4. You don't have installed Rollup 2 for MS CRM Client for Outlook.

     

    Solutions

    1. Check your DNS settings

    2. Make sure that you are connected to LAN.

    3. During installation of Client always provide the correct URL alongwith the port #.

    4. Download Rollup 2 from http://www.microsoft.com/downloads/details.aspx?familyid=81674DA5-FFEF-492A-A7B1-7E1F1951B05F&displaylang=en and install it

     

    Generally there is no harm in uninstalling CRM Client for Outlook and reinstalling it. You can try this to resolve your scenario. I recommand that if you don't find any solution you better reinstall Client for Outlook. Again don't forget to install Rollup 2 for Clients.

     

    Thursday, February 7, 2008 5:18 AM