locked
My Findings re Server Off Line from Launch Pad and 95% install and roll back no install RRS feed

  • General discussion

  • Right this is my findings and I hope this helps people out, its taken 3 Days I will never get back but it now fully installed and works on Vista x64

    So First 95% installs roll back and Error

    This took days and the use of

    msiexec /i  ClientCore.msi /L*v  debug.log

    After hunting and wasting Hours playing with a CAPI2 error and advanced loggin guess what it was ???

    The Error
    MSI (s) (80:18) [16:25:04:187]: Executing op: RegCreateKey()
    MSI (s) (80:18) [16:25:04:187]: Executing op: RegOpenKey(Root=-2147483646,Key=SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoPlayHandlers\CancelAutoPlay\CLSID,,BinaryType=1,)
    MSI (s) (80:18) [16:25:04:187]: Executing op: RegAddValue(Name=6D9D34EE-D6A4-417C-9CB9-A2A26D489A92,,)
    MSI (s) (80:18) [16:25:04:191]: SFC: The following entry was not added, because its key is protected by Windows: Key: \SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoPlayHandlers\CancelAutoPlay\CLSID Name: 6D9D34EE-D6A4-417C-9CB9-A2A26D489A920
    MSI (s) (80:18) [16:25:04:191]: Executing op: RegCreateKey()
    MSI (s) (80:18) [16:25:04:192]: SFC: Cannot create the following key due to windows protection: \SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoPlayHandlers\CancelAutoPlay\CLSID

    So this meant the permissions on HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\AutoplayHandlers\CancelAutoplay\CLSID was wrong

    Fire up regedit (Start -> Run regedit)

    Locate said path, now my permissions where broke, couldn't create new key or delete existing, so what we need to do is take ownership of CLSID

    Right Click the CLSID folder, Click Permissions Click Advanced, Owner TAB, Click , choose click administrator. Click OK then you can give Administrators and User Full Control.
    Then reinstall :) this worked for Me, still get the CAPI2 error but who cares :)

    OK

    The Launch Pad Offline Error

    The connector needs NetTcpPortSharing service to be running, (Note service is not needed to install !!!!)

    Start - Control Panel - Administrative Tools - Services

    Look for Net.Tcp Port Sharing Service is it Started ?? Start up Type Automatic ??

    If auto but not running,

    Start - Control Panel - Administrative Tools - Event Viewer

    In Event Viewer Click Windows Logs - Application

    Now back to Services window double Click Net.Tcp Port Sharing Service then click Start

    Look in the Application Window, you should see a RED CROSS next to the error, double click it.

    This should give you the error as to why Net.Tcp Port Sharing Service died off, my reason was a old Killer Nic driver, Just uninstall the said

    Restart the Launch Pad and Happy Days :)

    Hope this help someone

    Giz
    • Edited by Gizmo1234 Tuesday, October 25, 2011 6:59 PM
    • Changed type Ken Warren Tuesday, October 25, 2011 7:07 PM Not a question
    Tuesday, October 25, 2011 6:58 PM