none
SOA HelloWorldR2 samples (in the sp2 samples download) and .net 4 problems RRS feed

  • Question

  • Hello Everyone,

    The SOA HelloWorldR2 samples (in the sp2 sdk) have projects that reference .net 4, however when I try to run these samples I get an error "Could not load file or assembly 'file:///C:\ServicesR2\EchoService.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded"  All of my nodes have .net 4 installed so I'm not quite sure what needs to be upgraded here.  Do I need to do an uninstall/reinstall of something?  What exactly needs to be installed to run these SOA samples in .net 4?

    Thanks,

    Bob
    Monday, July 25, 2011 4:35 AM

Answers

  • I found the answer to this here:

    http://technet.microsoft.com/ru-ru/library/ee815854%28en-us,WS.10%29.aspx?ppud=4#BKMK_vs10

    Although, in my opinion these executables should already run .net 4 by default and having to manually add a config file to make .net 4 services work is a waste of time for developers.

    Bob

    Monday, July 25, 2011 4:54 AM

All replies

  • I found the answer to this here:

    http://technet.microsoft.com/ru-ru/library/ee815854%28en-us,WS.10%29.aspx?ppud=4#BKMK_vs10

    Although, in my opinion these executables should already run .net 4 by default and having to manually add a config file to make .net 4 services work is a waste of time for developers.

    Bob

    Monday, July 25, 2011 4:54 AM
  • Thanks for the feedback. We'll consider changing our sample based on this.

    Monday, July 25, 2011 1:42 PM
  • Why would you want to change the sample?  The problem is that the HPC Server installation doesn't run .net 4 services by default and requires this config file hack to make them work.  Fix the stuff you install with HPC server, not the samples.

    Bob

    Monday, July 25, 2011 3:45 PM