none
SSRS 2008 - Passing parameters to subreports RRS feed

  • Question

  • Hi there,

    I have been stuck on this issue for quite some time now. I have basically reports that have sub-reports within them. My main report is passing a parameter to the subreport, however when i check the parameter collection the value of its shows me unknown collection member.

    Now, here is what i have ensured:

    1. Table that contains the subreport control is linked to a dataset.
    2. My subreport parameter is populated by a value passed through the main report.

    This is very strange as other regions of the table control in the main report contain expression values from the same Dataset.

    Can anyone please explain how can this pass parameters to a my subreport? I have recently converted all my reports from version 2003 to 2008 and that's when this problem started. It was working fine in 2003.

    Many Thanks.
    Rohan
    • Moved by Bill.Wang Thursday, June 25, 2009 9:50 AM Redirected to the ASP.NET forums. (From:Team Foundation Server - Reporting & Warehouse)
    Friday, June 19, 2009 3:28 AM

All replies

  • Hi Rohan

    Sorry for the late response. This forum is for topic such as building reports against TFS warehouse or troubleshooting issues about TFS warehouse and reporting. It seems you are asking a reporting service specific question? You can contact SQL Server Reporting Services forums for better luck.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Thursday, June 25, 2009 9:50 AM