locked
Communication between Laptop (Atheros Wifi Card) and Sora on 11a/g Mode RRS feed

  • Question

  • Hi there,

           I meet some problems when I tried to set a connection between Sora and my laptop. My laptop uses Atheros wifi card, and I uses Mode "802.11a" in sdr.inf under free environment.

           1) I made an ad hoc network with channels on 2.4GHz and change the BSSID of Sora. The icon will show there is a connection, but the signal strength is "No Signal". Therefore, I cannot "ping" between Sora and laptop. Does anyone meet this problem before? What should I do next? I have tried to change --rxgain and --txgain, but it seems no effect.

           2) After that, I forced the ad hoc network on 5GHz (channel 36). However, after I set the BSSID, there is no connection. Is there any suggestion if I want to set the communication on 5GHz channels?

           3) I found that after I made some changes with "dot11config --rxgain" or "dot11config --txgain", the displayed information ("dot11config -i") has no changes with the default numbers. Is this an error in codes? Because the "rxgain_preset0" and "rxgain_preset1" will update after changing. I want to know this because I am not sure whether I change the gain successfully or not.

           Thanks for reading and I am glad to see any answers.

           Regards,

           Wenhan

    Thursday, April 7, 2011 12:21 AM

All replies

  • Broadcast packets in your laptop, and adjust rxgain, then check if sora peer can RX packets.

    Please open dbgview to see if rxgain is proper.


    Sen Xiang (项森)
    Thursday, April 7, 2011 10:24 AM
  • Hi Sen Xiang,

              Thanks for reply. I still have two problems after trying with your suggestions. The radio daughterboard used is xcvr2450.

              1) I tried to broadcast in my laptop, and the sora peer can RX frames. However, this only works on 2.4GHz channels. First, I set up an ad hoc network on 11g mode (2.4GHz and driver with mode "802.11a" for sora) with 3 laptops and one sora peer. I can "ping" within 3 laptops, but I cannot "ping" from laptops to sora peer. After that, I forced network to the 5GHz channels, but I cannot capture any thing with oscillator.

                  Do you know how should I make the connection between Sora peer and laptop on 5GHz channels?

              2) I tried to use dbgview.exe. There is nothing printed out when I did "dot11config". I did not change the codes, and I found that the codes such as "DbgPrint("")" are not commented in codes. I tried to rebuilt the codes, but it still not worked.

                  What error do you think it should be? How can I fix it?

              Thanks again.

              Wenhan

    Thursday, April 7, 2011 10:50 PM
  • Hello Wenhan and Sen,

       Now I am testing the communication between commercial card and SORA .And I used ASUS WL-167g .

       But I cannot find how to get the commercial card's BSSID. So I want to ask that how to get it? Or what is your solution about this problem?

       Thanks a lot.

    Albert.

    Friday, April 8, 2011 2:26 AM
  • Hi Albert,

              If you are working on 11b mode, you can try to capture a broadcasting frame first. Use "dot11config -d" to get a .dump file and open oscillator to decode it. Then, you will find the content information of this frame. The first 6 2-bit of the second line should be the BSSID (Address 3 of MAC frame format). This is for my example, if it not work, you can try Address 4.

              Another simpler method is to use some utility tools. They will tell you the BSSID.

              Cheers,

              Wenhan

    Friday, April 8, 2011 1:08 PM
  • Actually you don't need to know the BSSID, sora peer would auto connect to ad hoc network with SSID "sdr". You can find the code in sdr_mac_rx.c ModifyBSSID.

    Of course, you RX gain must be well configured to make beacon demodulation successful.

    Thanks.


    Sen Xiang (项森)
    Monday, April 11, 2011 2:02 AM
  • Hi all,

    sorry for the confusion.

    In the released code, we actually add the code to automatically exact BSSID from beacon frames, though you can still use oscolliscope to get and manually set BSSID.

    The manual is a bit out-of-dated at this point.

    To Wenhan, I would suggest you to check if you have correctly set the 44Mhz sampling rate Macro in the sources file. The default is 40Mhz, but I think your Sora RF frontend should be working in 44Mhz. You should make them compatible.

    Thanks,

    - Kun

    Monday, April 11, 2011 2:32 PM