locked
Problem with Email Router Forward Mailbox RRS feed

  • Question


  • Hello,

    We are on CRM 2013 and using CRM Email Router. So far so good but now we have a requirement to use the forward mailbox in order to delete emails after processing.

    The problem is all of the emails sent to that new forward mailbox is getting delivered immediately to 'Undeliverable' folder. 

    I read online according to Microsoft that this means the router is having problem creating an email activitiy, that's why putting the email in the Undeliverable folder.

    I look into our email router server event viewer and found these error messages:

    #17174 - An error occurred while validating the email message with subject "Test" in mailbox focusforwardmailbox@zzz.com. Microsoft.Crm.Tools.Email.Providers.EmailException: E-mails for address zzz@zzz.com in forward mailbox could not be processed as the e-mail address is not associated with any approved forward mailbox user or queue record in CRM.
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.CheckForApprovedForwardMailboxUsersOrQueue(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.ValidateMessageInternal(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()

    It is weird because the email account that I'm using is actually an approved user record in CRM. I tried sending on behalf of an approved queue record in CRM, and got the same error. I tried sending the emails in Outlook, haven't tried it directly on CRM.

    Anyone has any suggestions? Thanks in advance.

    Just to specify our versions:

    Our CRM 2013 version is 6.1.0002.0112

    Our CRM 2013 Email Router is 6.1.0001.0132

    -tri



    • Edited by triangular Tuesday, January 12, 2016 10:02 PM
    Friday, January 8, 2016 9:20 PM

All replies

  • A couple of things to check - which you may well have already done.

    Are you forwarding emails as attachments to the forward mailbox? I believe that you must do this

    Have you changed the incoming email synchronization method to forward mailbox for each user mailbox record and then run the Email Router Configuration Manager to load user/queues etc?

    Wednesday, January 13, 2016 1:38 PM
    Moderator
  • A couple of things to check - which you may well have already done. 

    Are you forwarding emails as attachments to the forward mailbox? I believe that you must do this tri: correct we have set the rule to 'redirect' the email ass attachment to forward mailbox

    Have you changed the incoming email synchronization method to forward mailbox for each user mailbox record and then run the Email Router Configuration Manager to load user/queues etc? tri: yes we have done this for the users that try to send the emails 

    Thanks Feridun for your reply. As above yes we have everything set up as per your questions.

    We're reading about the Rule Deployment Wizard if we need to enable the rule using this tool instead now. This tool correctly loads our forward mailbox and the other mailbox that forwards the attachments. 

    However when we try to "Deploy Rule to user Mailboxes" (as instructed in this MSDN article:

    https://msdn.microsoft.com/en-us/library/hh550229%28v=crm.6%29.aspx?f=255&MSPPError=-2147217396)

    We keep getting error "Failed to access the default store for this user".

    So we read this article to fix it: https://support.microsoft.com/en-us/kb/2545688

    We are using Exchange 2013 we have to run scripts in order to give my account full access to the email router and forward mailbox. But it still doesn't solve it...

    Any ideas is appreciate, thanks.

    -tri


    • Edited by triangular Wednesday, January 13, 2016 8:34 PM
    Wednesday, January 13, 2016 8:33 PM
  • I wonder if the message "failed to access the default store for this user " means that the store for the user has not been created rather than a permission error?  Do you get the error for every CRM user that you try to deploy the rule for?  If you have already manually created a forwarding rule for each CRM user to the forward mailbox there is no need to run the Rule Deployment Wizard.

    Monday, January 18, 2016 12:10 PM
    Moderator