locked
Default Webpage is missing RRS feed

  • Question

  • Hello

    Basically i had a working WHS 2011 Default Web Page stop working, always got a "Server Error in '/' Application" error.  Little bit of troubleshooting showed me my 'Default.htm' or 'Index.htm' (i am not sure which one it is) was missing, i could drop a different .html file in the directory, and the web page would work, remove it and back to my error.

    Since i could not find the default file again, i reformatted WHS with a fresh install after a drive format, and i am STILL having the issue, i can not find the default web page file anywhere??  All i did was update WHS via Windows Update and copy back over my Teamspeak and Minecraft server files, other than that no changes were made, and yet default web page is still MIA.  I know it is not my router again as i can drop a different test .html file into the directory and that page displays fine.

    I would hate to have to format again, especially since i had no luck the 2nd time, but am i just looking in the wrong places?  Or anyone know exactly what the default page is named so i can search for it on the Disk?  Or did i miss a critical step while installing?

    Or know where i can find the Default webpage HTML file?

     

    Thanks in Advance

     

    Thursday, September 22, 2011 4:40 PM

All replies

  • After you reinstalled Windows Home Server 2011, when exactly did the issue start to occur? Before or after you installed Teamspak and Minecraft?
    I'm not on the WHS team, I just post a lot. :)
    Thursday, September 22, 2011 6:48 PM
  • Sadly i was so confident a re install would fix it that i did not test the remote access till after those 2 programs were placed back over.  I am smacking myself, i know.   

     Not that it makes a difference, but i did just copy the folders back into my "D:" and started the programs, the only actual installing of anything was adding Java (minecraft needed this) and Windows Updates. 

     

    If i can not figure anything out today i may re install again tonight then and after standard windows updates test remote access, like i should have done the first time.  I am just curious if anyone looks in their web directory, is it a .aspx file or a .htm file that the default webpage is, so i know if something keeps deleting a file on me, or if its some sort of software issue, like IIS keeps getting corrupted by something i am doing.

     

    I guess, and i fully admit i know pretty much nothing about HTML/ASPX, but, is that  Default.ASPX located in C:/Program Files/Windows Server/Bin/WebApps/Site/, is that what i am expecting to be the Default Webpage, and not some actual HTML file?  And perhaps i am just having a ASP Net issue (or whatever you call it).  

    Thursday, September 22, 2011 7:24 PM
  • Success!

     

    Problem was in my system permissions, i had to add SYSTEM and NETWORK SERVICE to the Administrator group and now all is well.

     

    Odd that this was not done by Windows when i reformatted, i promise i did not go into group settings and remove them, and can not imagine how or why a JAVA install would do this.  But either way problem solved!

    Thursday, September 22, 2011 8:49 PM
  • On Thu, 22 Sep 2011 20:49:52 +0000, Combatbob wrote:

    Problem was in my system permissions, i had to add SYSTEM and NETWORK SERVICE to the Administrator group and now all is well.

    As an FYI, while I'm glad that solved your issue, neither of those accounts
    are in the Administrator group on my WHS 2011 server and it is fully
    functional.


    Paul Adare
    MVP - Identity Lifecycle Manager
    http://www.identit.ca
    The attention span of a computer is only as long as its power cord.

    Friday, September 23, 2011 11:57 AM