locked
Bare Metal Restores using WHS 2011 RRS feed

  • Question

  • I've been using WHS V1 since the very beginning and it has been working flawlessly.  However, lately, I've run out of space and needed to add some new disk drives.  As I could get 2TB drives pretty cheaply and wasn't sure whether or not my existing server would handle that large a drive, I decided to take WHS 2011 for a spin.  What an experience this has been!

    First I installed WHS 2011 on a Core 2 Duo box with 8Gb of memory, a single 160 GB system drive and 4 2TB storage drives.  The went pretty smoothly, but not as I expected.  After some shucking and jiving, I was able to get it all set up the way I wanted.  The 4 2TB drives were set up as two mirrored 2TB file systems; one for file shares and one for system backup and the 160 GB drive was for system only.

    Next I connected two client machines to this private network; one a Windows XP Pro box and one a Windows 7 Pro box.  The Windows 7 box installed the connector with no problems, but the XP box failed to install the connector.  This was a freshly built XP SP3 system with ALL updates applied but the connector would not load.  After tearing my hair out and doing internet searches (very little information to be found), I eventually figured out that the problem had to do .NET 3.5 not being installed.  The prerequisites indicated .NET 4, but nothing was said about .NET 3.5.  Anyway after installing .NET 3.5, the connector installed properly and all was good.

    Next I did some backups and let the system do automatic backup and these all worked as expected.

    However, when I tried to do a bare metal restore to the Win7 box, nothing I could do would get this restore to happen.  I have spent the last day trying to figure out how to do a bare metal restore.  Every time I tried, it would fail at the same place (calculating restore time) and error in the logfile said "Error: Could not load vds".

    Of course I searched the net high and low and as usual with MS products, found neither a meaningful resolution nor a response from any MS person. 

    It seems that this is a known problem for others, but nobody seems to have found a fix!  What good is a backup if you do not have a method to do a recovery.  Are these products not tested before being shipped (and sold) to unsuspecting customers!  With WHS V1 I was able to get a 180 day trial and used this period to work the bugs out and was then able to make an informed decision to purchase the product.  But with WHS 2011, no trial was available so I had to pay for software that does not work!

    Can someone from Microsoft not tell me what is causing this problem and how to fix it!

    In the meantime, I'll just have to see if I can upgrade my WHS V1 server with my new disks.

    Thanks.

    Greg

    Tuesday, December 11, 2012 11:02 PM

All replies

  • Couldn't have said it better, I used v1 for almost 3 years with out a hitch; test recoveries and even one real client recovery went flawlessly. Not so after 2 years with WHS 2011. The only thing its good for is saving Files and Folders when you have 6 clients, well only if you don't sneeze.

    There are some knowledgeable folks over at connecteddigitalworld that have a WHS 2011 forum that I used to get a couple questions answered and actually after a great deal of singing and dancing restored my server after a phantom crash (never figured that one out). wegotserved has a good forum too.

    Anyway, all you'll find here is M$ attitude and denial. Good luck

    Wednesday, December 12, 2012 10:14 PM
  • Thanks for the reply.  I've checked out both sites you suggested and could not find anything that would help me get my restore going.  I did find a 3 part tutorial at WeGotServed regarding Bare Metal Restores, but the whole thing was about restoring your server and not a client.    I desparately need to be able to Bare Metal Restores of my clients as I use some of these client machines as test boxes.  I have been using Acronis for recovering base installs, but sometimes it is just easier with WHS (at least V1 it was!).

    Anyway, I still do not have an answer for why I cannot BMR my client  box so am giving up and reverting back to V1.

    Thursday, December 13, 2012 12:35 AM
  • The bare metal restore of clients from WHS 2011 in normally pretty straight forward.

    Boot the client off the client recovery DVD and follow the prompts. The only issue I have had is during the restore wizard is that I have always used the advanced disk management to create the partitions needed. In theory this is not needed but I have never succeded if I let the restore create them.

    What process are you following to restore the client?.

    I have had to restore several win 7 machines with no issues. One thing to bear in mind is you cannot restore a client backup to a smaller hard drive than the one used to make the backup initially.

    Dave


    The Frog on the Lilypad at Home

    Thursday, December 13, 2012 10:30 PM
  • Yes Dave, the bare metal restores of clients from WHS 2011 backups SHOULD be straightforward.  However, in my testing, that has not been the case.  I've used WSH V1 for many years and have done numerous BMRs, usually without incident!

    But with WHS 2011, I have tried everything to do a restore and nothing seems to work.  I have used the restore CD that came with the WHS package, both not loading and loading additional drivers from a USB stick.  I have tried a restore by creating a bootable USB, again with and without loading additonal drivers.

    In all cases I get the same error message:

    [12/12/2012 16:03:59  440] Recreating 1 volumes
    ERROR: Could not load VDS (0x80080005)
    [12/12/2012 16:04:29  440] ERROR: Failed to initialize VDS, 0x80080005
    [12/12/2012 16:04:29  440] RestoreHelper::T_Restore: Unable to recreate volumes
    [12/12/2012 16:04:29  440] RestoreHelper::T_Restore: restore complete with return value 536870913
    [12/12/2012 16:04:29  440] ERROR: CDialog_Restore::Completed failed, HR=0x80070001 (at func: CDialog_Restore::Completed, d:\wssg_src\colorado_qfe\backup\pc\bmr\restorewizard\dialog_restore.cpp (88)

    Dave, I'm not new at doing this!  As I said, been using V1 since it went beta and MS first invited testors onboard.  And V1 also had many problems initially with BMRs (amongst other problems!).

    Greg

    Friday, December 14, 2012 4:14 AM
  • Dave, I'm not new at doing this! 

    Greg

    That may be, but you still did not directly answer his question about your process.

    Did you try manually creating the target partitions in Disk Manager?  Is the disk you are restoring to at least the same size as the original disk?

    Are you looking for help restoring your drives, or are you trying to make a point about WHS 2011?  If it's the later, I think most of us would agree that the product can be fragile, and that the user experience has taken a few steps backwards since WHS version 1.  But that's completely moot at this point, since the product line has been discontinued. 

    Monday, December 17, 2012 1:46 PM
  • Dave, I'm not new at doing this! 

    Greg

    That may be, but you still did not directly answer his question about your process.

    Did you try manually creating the target partitions in Disk Manager?  Is the disk you are restoring to at least the same size as the original disk?

    Are you looking for help restoring your drives, or are you trying to make a point about WHS 2011?  If it's the later, I think most of us would agree that the product can be fragile, and that the user experience has taken a few steps backwards since WHS version 1.  But that's completely moot at this point, since the product line has been discontinued. 

    Monday, December 17, 2012 1:46 PM
  • I'm sorry, but I thought I had answered it. 

    Yes, I went into Disk Manager and deleted the single partition on the drive.  I then went back and tried again to do the recovery.  When I attempted to recover again, I was presented with the screen asking what backup I wanted to restore to what partition (the screen with the red and/or green arrows showing the from and to).  As this system had two drives, the only option I had for restoring was from my either my system or data partition (both backed up) to the only partition still active which was my data drive.  Not what I wanted.  So back into disk manager again, re-partition the system drive as one big partition, format and then off to the recover process again.  Same results; abject failure.

    I have been using WHS for many, many years.  I use it to backup the five systems in my house, I use it as a centralized file share for all systems and that's it.  However, I also use it to recover systems that I have torn apart or installed something wierd to test.  While I don't use the BMR frequently, I have used it often enough to know that it is one of the features that is a requirment.

    So, when my existing WHS V1 system was running out of space, I thought it might be a good time to not just upgrade the disks, but also upgrade WHS.  But before commiting myself to the new system, I wanted to make sure that it did what I NEEDED.  For the most part, I liked WHS 2011, the new interface was ok, the backup worked as expected, file sharing appeared to be much faster.  Drive Extender was missing, but with mirrored drives, that was no big deal.

    Am I trying to make a point.  NO.  I just need the functionality of being able to recover a crashed system back to a point in time!

    Monday, December 17, 2012 2:09 PM
  • Okay Greg, no worries.

    I am far from an expert on WHS 2011 backup internals, but I believe that during a restore operation the system reconstructs the volume to be restored as a virtual disk.  If for some reason the virtual disk cannot be reconstructed on the server, then the restore operation will fail on the client.  The "VDS" errors you are seeing in the log seem to indicate a problem with the Virtual Disk Service.

    A few possibilities come to mind:  1) The backup database on your server is corrupt; 2) There is a low-level problem with a disk on your server that is preventing all the data in the virtual disk being that is being constructed to restore from being read properly; 3) You mentioned "mirrored disks"--presumably on the server?  Are you using a dynamic disk for the client backup share or motherboard RAID?  This is a wild guess, but if the first two issues are okay, then you may have hit a weird incompatibility between WHS and your storage model.  WHS 2011 does not support any form of RAID storage through the dashboard, of course. In theory volume layouts that you create in Disk Manager or your RAID software should work with WHS, but as you know there are limitations when using dynamic disks or GPT volumes in WHS.   

    For troubleshooting, I would check the event logs on the server to see if there are any disk-related errors that could indicate a bad disk. I'd also try to do a folder-level restore of some kind from the client backup, just to see if *any* restore from that disk is possible, not just BMR.  If this failed I'd consider running the repair wizard on the client backup database. Finally, I might consider moving the client backup folder to another, non-RAID disk and then attempting the restore.

    Good luck!

    Monday, December 17, 2012 8:50 PM
  • Gary, I don't think my problem has to do with a corrupt database.  Let me explain.

    As this is a test system, everything is built from scratch just to perform the test.  So WHS 2011 is installed, patched and configured.  Then both a Win7 and WinXP client are built from DVDs, patched and configured.  Once all three machines are running, then I perform a manual backup of each client.  Sometimes I then wait overnight for an automatic backup of each client to happen, but that is optional.  After each client has been backed up, I then try to restore by booting the Computer Restore Disk (or creating a USB recovery stick).

    Originally I tried this with what I figured would be my final configuration; a system with a 160GB drive for system and 4 x 2TB drives for shares and backup.  The 4 2TB drives would be divided into two banks of 2 drives each using the Intel Matrix Manager (motherboard RAID) to create 2 mirrored drives.  On to this configuation I would install WHS 2011.

    I knew in advance that OOTB WHS itself did not support any type of RAID, but of course, if the hardware presents a RAID drive to the OS as just another hard drive, then the OS really just takes it at face value and runs with it.  The OS does not know nor can it know it is a RAID enabled drive!

    Anyway after all my failures, I decided to simplify by just using the 160GB drive and 2 x 2TB drives without any mirroring.  That is how the system is configured right now.  This is as vanilla a setup as I can come up with!

    As for checking the event logs, that I did as soon as I started having these failures.  In no cases has there ever been a disk related event in the logs.  I have restore individual files from the backup and have also restore a complete folder hierarchy composed of over 45GB of data; again without problem.

    As I speak right now, I have just completed another completly fresh build of server and two clients (only this time one client is a Win8).  The backup of the two clients are in progress and then I'll load some data from my existing V1 server.  Once that is complete (in about an hour), I'll try to do a restore again.  This time I'll do as somebody else suggested; perform a 32bit recovery instead of a 64bit.  The only success I've had was when I recovered my WinXP system and it was done with a 32bit recovery.  You never know!!

    Hope this answered your questions.

    Greg

    Monday, December 17, 2012 9:35 PM
  • Okay... good luck with your test.

    A couple of other thoughts: 

    1) For a BMR, it is necessary that the disk you are restoring to is at least as large as the original disk. This is true even if the OS was installed originally on a smaller partition.

    2) Your target disk must have an MBR partition type; GPT will not work.  If you are repurposing a disk from another build, you may want to check this to make sure.  Even if the disk has no active partition, it may still be set as a GPT disk. You can change this in Disk Manager.

    Wednesday, December 19, 2012 7:16 AM
  • Thanks again Gary. 

    As I said, right now during this "test" phase, I'm doing a backup from a system with an 80 GB drive and restoring to the same system with the same 80 GB drive. I know that WHS will not allow you to restore to smaller drives (but ok for bigger ones).  In addition, all systems tested so far are MBR type systems.

    Also discovered something else about WHS 2011 that's not good in my book.  Cannot have two systems with the same name.  I have two systems that are dual boot Win7 32/64bit but node names are same on each boot.  Both backup perfectly on WHS V1, but had to change node name on WHS 2011!  Just one more nail in the coffin!

    Greg

    Wednesday, December 19, 2012 1:11 PM
  • Interesting discussion as I had the same problem.  So, I tried everything suggested in this discussion as well as others with no resolution.  I had saved the system disk from my WHSv1 so I reinstalled the drive into my server and attempted to do a bare metal restore (BRM) from it AND it didn't work either (same error messages) where in the past it had worked each time I needed it.  So I took out the WHSv1 drive and replaced it with the WHS2011 drive in the server and restarted my attempt to do a BRM from WHS2011.  As I was going through the manual approach, I realized that I had set up one partition on the hard drive but had forgotten to format it.  So ... I formatted the entire drive and selected the automatic restore and it's off and running.

    If you are doing a BRM from WHS2011, use the manual mode and run the disk manager, partition the drive into one partition, format the drive then proceed with the restore.

    Good luck!

    Mike

    I wonder why someone from Microsoft didn't chime in on this.  I suppose if they didn't know how, I should charge them for my services.  As far as their on-line support for WHS2011, I'll look on the back of a package of Charmin for improved support.


    Tuesday, May 21, 2013 6:06 PM