locked
OCS 2007 Address Book Not Updating RRS feed

  • Question

  •  

    I've read a couple different threads on this, but none of them solve my problem.  I created a new Distribution Group in AD with 3 people in that group.  Their communicator will not see this new group.  Here is what I've done:

     

    1.  Ran abserver -regenUR and waited for the event log to say it completed.

    2.  Ran abserver -syncnow and waited.

    3.  Completely closed the communicator and deleted the Galcontacts.db, then logged back in to have it recreated.  Still doesn not work.

    4.  Rebooted server, rebooted client.

     

    Any ideas?

    Friday, August 8, 2008 8:23 PM

Answers

  • Stupid question, but are you positive it's a distribution group and has a valid SMTP addresses set on it?  The OCS Address Book won't show security groups or groups with null email address fields.

     

    Monday, August 11, 2008 1:50 PM
    Moderator

All replies

  •  

    Have you resolved this problem? how many DC's do you have? Often we see this when replication has not completed and the DC that the OCS server is pulling from has not updated. alot of time waiting 24 hours will generally fix this
    Monday, August 11, 2008 2:03 AM
  • Stupid question, but are you positive it's a distribution group and has a valid SMTP addresses set on it?  The OCS Address Book won't show security groups or groups with null email address fields.

     

    Monday, August 11, 2008 1:50 PM
    Moderator
  • Ugh.  Not a stupid question, a stupid admin.  Thanks for pointing that out.  I gave it an email address and ran abserver -syncnow, and the group is showing up now....   Thanks again!

     

    Monday, August 11, 2008 2:13 PM
  • I guess that's why they say 'there are no stupid questions".  Glad it was a simple fix.  I spent too much time the other day troubleshooting an external user login issue in my lab before I realized that I forgot to even enable that account for External access.  We all have 'duh' moments Smile
    Monday, August 11, 2008 2:45 PM
    Moderator
  • When I run the command abserver -regenUR or -syncnow .. from our OCS 2007 front end server I get the message below:

    Triggering Address Book Server synchronization pass - function not available when RTCSRV service is not running.  Start the RTCSRV service.

    I check and the RTCSRV service (OCS front-end) is started and running on the server so not sure how to resolve this message, does anyone have any thoughts?
    Monday, September 15, 2008 8:51 PM
  • Amperch,  while this reply is a bit late I did come across this post and saw your reply and figured I'd reply anyways.  We had this issue when load balancing and using DNAT. Here's the fix: http://www.shudnow.net/2008/10/24/ocs-absserver-issue-with-dnat-load-balancing/
    Monday, December 8, 2008 7:53 PM