Exchange 2003 mail flow SMTP 451 Transaction failed RRS feed

  • Question

  • Hi Guys,

    I've got a client with 2 sites connected by an IPSEC tunnel via ADSL. We didn't setup the link its managed by someone else.

    I installed a new DC and Exchange server (not on same server) in the other site. All Active Directory subnets and site links etc etc are correct.

    Initially we had problems with the replication to one side only - we pointed out that it has to be the link causing the issue because we were getting "Cannot read from source" errors when we try and copy a small 100kb file from the one side to the other - the other way around worked fine - replication as well. When you connected to the machine IP - \\<ipadress\c$ the same error occurs.

    The client requested assistance from MS - they did some DNS changes and registry changes - Im not sure what changes were made, but they got the replication working for AD - I still suspect the link is an issue as I still cannot copy from the one site to the other - same error - my gut feeling is they worked around the link being the problem - Im not 100% sure if this could be accurate.

    Now, the problem I'm facing now is that I cannot get mail flow between the Exchange servers working. The servers are in different Administrative groups in the same org. Routing group connectors were created and DNS resolves fwd and reverse.

    When I telnet to the one Exchange server to port 25 over the WAN link (from any machine on the other side) I can successfully connect, but when I try to send a test mail in the telnet session I get 451 transaction failed. This happens to both sides of the link. The networking guys assured me that all ports are open between the sites. All the mails sent via outlook will queue in the routing group connector just retrying.

    But when I connect to the same server on the local lan and telnet with the same test the mail is queued for delivery.

    I've uninstalled SMTP on the new server and reinstalled then reinstalled Exchange 2003 with same Service pack and I'm still getting the same problem. I set the logging on the SMTP virtual server and I only see - transaction failed on each SMTP connection in the log.

    When I run ehlo on both servers I get the desired results as explained in a KB from MS.

    Server is running on ESX 4i

    Windows 2003 SP2

    Exchange 2003 STD SP2

    If anyone could assist I would appreciate it greatly as I am stumped and dunno what to do next.


    Thursday, July 1, 2010 9:48 PM