locked
CRM Outlook client configuration error RRS feed

  • Question

  • Hi,

    I'm trying to do CRM Outlook client configuration, i'm getting the following error: "Action Microsoft.Crm.Config.Common.InstallDatabaseAction failed.

    The network path was not found."

    In the list of components to be installed i only got Microsoft Visual C++ Runtime, i didn't get the other two components to install. Is it possible that the error is because of them missing.

    If yes how can i install them?

    If no, any idea how i can solve this problem?

    It's urgent...

     

    Wednesday, April 16, 2008 2:20 PM

Answers

  • The first step is to locate where the CRM database is to be installed.  You should be able to look in the SQL Express log file, which should be somewhere in Program Files\Microsoft SQL Server.  That will tell you the directory where the installation should take place.  Open Computer and navigate to that folder, then go up one folder.  Right click the destination folder and go to Properties.  On the security tab, look for Network Service to see if any permissions have been granted to that account yet.  If Network Service is not there, add Network Service and give it full control over the folder and all sub folders and files.  Then retry the configuration.  I apologize for the vagueness of these steps, I don't have a laptop client on hand to give you the exact paths and specific steps.

     

    Because you are manually granting an account permissions on a folder structure, you are opening a security hole on that computer.  If this concerns you, once the installation is complete, pare down the permissions of network service on that folder structure and test the Go Online/Go Offline process.

     

    • Proposed as answer by Jim Glass Jr Thursday, February 12, 2009 9:45 PM
    • Marked as answer by Matt Parks Wednesday, May 6, 2009 10:20 PM
    Tuesday, October 28, 2008 3:58 PM

All replies

  • I got a similar error, added the account I was installing under permissions to administer in the SQL Server Surface Area Configuration utility and it let me install.

     

    TJ

     

    Wednesday, April 16, 2008 11:34 PM
  • Hi thanks for you reply but can you explain for me the steps to do it?

    Thanks

     

    Thursday, April 17, 2008 5:47 AM
  • Dear TJ,

    Kindly let me know what you mean by your answer and how can i achieve it because i still didn't solve my problem.

    Thanks...

     

    Friday, April 18, 2008 2:06 PM
  • Hi TJ,

    Since you solved your problem, can you just tell me the steps to follow to solve mine?

    I would really appreciate it.

    Thanks

     

    Thursday, April 24, 2008 6:44 AM
  • Were you able to find a solution to this?

     

    I have a user having the same exact error.

     

    The solution that was posted referred to the correct Action:  "Action Microsoft.Crm.Config.Common.InstallDatabaseAction failed." but not the same error.

     

    Thanks

     

    Wednesday, April 30, 2008 2:20 PM
  • Hi,

    I found this article: http://support.microsoft.com/kb/950247

    I tried it but it didn't work.

    Try it and let me know if it works for you and if it does please let me know what did you do.

    Good luck!

    Friday, May 2, 2008 8:31 AM
  • Any updates on this problem?

    Still i can't find a solution Sad

     

    Monday, May 5, 2008 6:54 AM
  •  

    Hi, was anybody able to find a solution for this problem?

    I need some updates!!

    Thanks in advance...

    Wednesday, May 7, 2008 6:15 AM
  • Sabine, it might be time to bump this up to support.

     

    Thursday, May 8, 2008 8:38 PM
  • The solution is the SQL 2005 Provisioning tool that runs after installing SQL 2005.  In this case, you need to manually kick it off by going to "Programs\Microsoft SQL Server 2005\Configuration Tools\SQL Server Surface Area Configuration" then select the option to add administrators.

     

    This works for machines running Vista and using the offline CRM 4 client.

     

    Monday, June 2, 2008 1:32 PM
  • I had the same error when trying to run the configuration wizard, however I am a local admin on the machine.  The issue was that the folder in my profile referenced in the error was compressed, see below.  I set the entire MSCRM folder not to be compressed.

     

    1. Navigate to  C:\Users\<username.domain>\AppData\Roaming\Microsoft\MSCRM\Data\
    2. Right click MSCRM_MSDE.mdf
    3. Select Properties
    4. Click the Advanced button
    5. Is the Compress contents to save disk space checkbox checked? If it is, please uncheck it and try the CRM 4.0 Outlook Client Configuration Wizard again.

     

    If the file has not been compressed, the MSCRM_MSDE.mdf file may have been corrupted.  Try to update this file with a new copy.  Once you have replaced the file, please try the CRM 4.0 Outlook Client Configuration Wizard again.

     

    Friday, October 17, 2008 6:11 PM
  • Maybe is not neccesary to ask but.. have you put the port in the assistant URL address field. We made this mistake long time ago.

    We ever have to install the same C++ component every time we use the assistant wizard so I don't think that this could be your problem.

     

    Bye

    Monday, October 20, 2008 10:00 AM
  • Sabine, where are you with this issue? Did you try the two suggestions above and/or  bump it to support?   

     

    Tuesday, October 21, 2008 8:49 PM
  • I ran into this error and I had to adjust the Windows permissions on the SQL file structure.  Network Service did not have permissions on the folders where the SQL database is stored.  I added Network Service and gave it full control, which fixed the issue.
    Tuesday, October 28, 2008 3:18 PM
  • Hi Richard,

    Can you please tell me the steps to follow?

     

    Tuesday, October 28, 2008 3:31 PM
  • The first step is to locate where the CRM database is to be installed.  You should be able to look in the SQL Express log file, which should be somewhere in Program Files\Microsoft SQL Server.  That will tell you the directory where the installation should take place.  Open Computer and navigate to that folder, then go up one folder.  Right click the destination folder and go to Properties.  On the security tab, look for Network Service to see if any permissions have been granted to that account yet.  If Network Service is not there, add Network Service and give it full control over the folder and all sub folders and files.  Then retry the configuration.  I apologize for the vagueness of these steps, I don't have a laptop client on hand to give you the exact paths and specific steps.

     

    Because you are manually granting an account permissions on a folder structure, you are opening a security hole on that computer.  If this concerns you, once the installation is complete, pare down the permissions of network service on that folder structure and test the Go Online/Go Offline process.

     

    • Proposed as answer by Jim Glass Jr Thursday, February 12, 2009 9:45 PM
    • Marked as answer by Matt Parks Wednesday, May 6, 2009 10:20 PM
    Tuesday, October 28, 2008 3:58 PM
  • Make the service account in the crm install an administrator on the sql server.  That should take care of it.

    ken
    Thursday, August 12, 2010 5:30 AM