none
How to change default paper size in reporting options

    Question

  • I am using the Microsoft CRM  2011 hosted service. When ever we print reports the default paper size is set to Letter. Is it possible to set this default to be A4? It is possible for each print job to change the printer properties but this is very laborious.

     

    Many Thanks

     

    Phil

    Friday, October 28, 2011 3:33 PM

All replies

  • The only way of doing it: by using either Microsoft Report Builder, or Visual Studio (or notepad, but it is a little more complex :-)

    The steps are:

    1. Download the report by going to 'Reports', by selecting the report you want to modify and by clicking 'Modify the report'; then you simply have to select 'Actions -> Download the report' and IE will prompt you with a .RDL file
    2. Open the RDL file in Report Builder (it is easier), right-click on the page and select 'Report Properties...'
    3. There you can change the paper size, the orientation, the margins, etc.
    4. Save your RDL file and re-upload it to Microsoft CRM by going to 'Reports', selecting the report you want to update and clicking on 'Modify report'; then, be sure to select the updated RDL file and hit the 'Save' button (you will get a warning stating that the current report will be replaced by the chosen RDL file)
    5. Browse to your report and print it, it should be good!
    source: http://community.dynamics.com/product/crm/f/117/p/41499/75346.aspx

    BR
    Mads 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Prijil.P.S Tuesday, June 19, 2012 11:07 AM
    Friday, October 28, 2011 8:10 PM
  • Mads,

    When the Report opens in Report Builder it asks for a Reporting Server name, seems I can Cancel past this, however in step 4.  Nowhere can I find this Modify report option.

    Wednesday, May 23, 2012 3:36 PM
  • Hi,

    I am having the same issue, however my reports are custom made by me in BIDS and are already set to A4, my default printer is set to A4, but any report in CRM when you press print defaults to Letter :( Reports viewed directly on the report server default correctly to the paper size of the report but not through CRM.

    Chris

    Tuesday, June 19, 2012 9:14 AM
  • Wow! Thanks a million! Still working in 2017.
    Friday, April 21, 2017 8:11 AM