locked
Windows NTLM auth works fine when hitting http://netbios but prompts when hitting FQDN or external hostname? RRS feed

  • Question

  • Running CRM 4.0, everything is working fine. However, I want my domain users to be able to use their pass-through credentials to log in to CRM from home. They can hit crm.domain.com right now and it will prompt them for credentials and provide the domain. If they enter the creds then everything works fine. However I would like them to be able to use pass-through.

    If they are inside the domain and hit http://crmserv1 they can use pass-through, however if they hit crmserv1.domain.local or crmserv1.domain.com they are prompted for creds.
    Wednesday, October 21, 2009 2:56 PM

All replies

  • Hi Defag,

    Add  crmserv1.domain.local or crmserv1.domain.com  or *.domain.com to your 'local intranet' zone in Internet Explorer.
    Alex Fagundes - www.PowerObjects.com
    Wednesday, October 21, 2009 2:58 PM
  • I tried this, also confirmed Windows Auth was enabled under IE option, also tried it with it disabled. Same results, still prompts for creds
    Wednesday, October 21, 2009 3:18 PM
  • Also confirm that your 'local intranet' settings have not been changed.  Go to custom settings in 'local intranet' and confirm that 'User Authentication' is set to 'automatic logon'.  And after making changes in this area or the advanced area, you need to close all open browsers.
    Alex Fagundes - www.PowerObjects.com
    Thursday, October 22, 2009 3:28 PM
  • Confirmed this setting is also correct, still getting prompted for credentials
    Thursday, October 22, 2009 4:12 PM
  • Is your crm site using host headers?  If it is using host headers, then the issue is probably related to setting up SPNs.
    Alex Fagundes - www.PowerObjects.com
    Thursday, October 22, 2009 4:30 PM
  • Nope, no host headers
    Thursday, October 22, 2009 5:20 PM
  • A couple more items:
    -pinging server name and server.domain.com go to the same ip address?
    -have you configured ifd using ifdconfig tool ?


    Alex Fagundes - www.PowerObjects.com
    Thursday, October 22, 2009 6:28 PM
  • While connected to the VPN everything returns the same IP

    I have not messed with the IFD tool at all, just publishing port 80 direct to the internet
    Thursday, October 22, 2009 8:38 PM